PDA

Bekijk de volledige versie : mount/access a NAS from wl-500gp/oleg



onewiki
26-09-2009, 04:17
I have a terastation (a NAS from Buffalo), but I am having difficulty mounting it from wl-500gp/oleg/samba3. I can access it via smbclient and see it via smbtree, but cannot mount it because the firmware does not have smbmount/smbmnt.

I've tried mount.cifs without success. I've also tried the method from newbiefan, http://www.wl500g.info/showpost.php?...0&postcount=24, but the files he provided seems to work only for samba2, but I want samba3 for its support international character support. I've also tried http://riot.org/seb/smbfs_0.0_mipsel.ipk, but it leads to error segmentation.

I then tried mount my NAS via nfs without success, even though my ubuntu laptop mounted the same NAS via nfs easily. This is what I got:

"showmount -e 192.168.2.4"
Export list for 192.168.2.4:
/mnt/array1 <anon clnt>
/mnt/array1/Buffalo 192.168.2.0/255.255.255.0

but then
"mount -t nfs 192.168.2.4:/mnt/array1/Buffalo ./test"
mount: mounting 192.168.2.4:/mnt/array1/Buffalo on ./test failed: No such device

Would someone please provide some guidance on how to mount a NAS from a wl-500gp with samba3 installed? Thanks.

DrChair
26-09-2009, 09:24
mount: mounting 192.168.2.4:/mnt/array1/Buffalo on ./test failed: No such device


Just a thought: does the directory ./test exist ??

Also the -o is only needed when specifying options, which you aren't doing...

So drop the -o and maybe use an absolute path...

for example:

first make a directory:
mkdir -p /tmp/mnt/nfs

then mount it to that directory:
mount -t nfs 192.168.2.4:/mnt/array1/Buffalo /tmp/mnt/nfs

Lesiuk
26-09-2009, 12:07
Simply use samba2 and load smbfs.o (insmod) from that archive: http://wl500g.googlecode.com/files/modules-1.9.2.7-d-r617.tgz

http://translate.google.pl/translate?prev=hp&hl=pl&js=y&u=http%3A%2F%2Fwl500g.info%2Fshowthread.php%3Ft%3D 20954&sl=pl&tl=en&history_state0=&swap=1

onewiki
26-09-2009, 16:43
I followed Lesiuk's first link and extracted smbfs.o, and put it in /opt/lib/modules (it can be somewhere else, but not /lib/modules because there it is read-only).

Then I downloaded samba2 from http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/samba2_2.2.12-1_mipsel.ipk to my PC and extracted smbmnt and smbmount from that package. I put the two files into /opt/bin.

After that, just
insmod /opt/lib/modules/smbfs.o
mkdir -p test
smbmount /ip address/sharename test

You will be prompted to type in the password. After that you may receive some error codes, such as "load_client_codepage: filename /opt/lib/codepages/codepage.850 does not exist.", but it does not matter.

cd test
you will find the smbdrive has been successfully mounted.
Thank you all for the help.

onewiki
27-09-2009, 04:32
Now, can someone please help with mounting a NAS via nfs. I have not been able to, even though I was able to mount the same NAS without any problem from a linux laptop.

This is what I have:

"showmount -e 192.168.2.4"
Export list for 192.168.2.4:
/mnt/array1/Buffalo 192.168.2.0/255.255.255.0

but then
"mount -t nfs 192.168.2.4:/mnt/array1/Buffalo ./test"
mount: mounting 192.168.2.4:/mnt/array1/Buffalo on ./test failed: No such device

any suggestions? thanks.

Lesiuk
27-09-2009, 07:40
Now, can someone please help with mounting a NAS via nfs. I have not been able to, even though I was able to mount the same NAS without any problem from a linux laptop.

This is what I have:

"showmount -e 192.168.2.4"
Export list for 192.168.2.4:
/mnt/array1/Buffalo 192.168.2.0/255.255.255.0

but then
"mount -t nfs 192.168.2.4:/mnt/array1/Buffalo ./test"
mount: mounting 192.168.2.4:/mnt/array1/Buffalo on ./test failed: No such device

any suggestions? thanks.

I think you must insmod nfs.o from the same archive where you find smbfs.o.

onewiki
27-09-2009, 20:53
No, that does not solve my problem. I have nfs enabled so nfs mode was already running. And that was when I received the error message "no such device".

[admin@Asus root]$ lsmod
Tainted: P
smbfs 55056 0 (unused)
nfsd 96600 1
lockd 64244 1 [nfsd]
sunrpc 81728 1 [nfsd lockd]
usb-storage 63080 3
sd_mod 12660 6
scsi_mod 72624 2 [usb-storage sd_mod]
printer 13060 0 (unused)
ehci-hcd 28212 0 (unused)
usb-ohci 19428 0 (unused)
usbcore 78600 1 [usb-storage printer ehci-hcd usb-ohci]
ip_nat_ftp 3136 0 (unused)
ip_conntrack_ftp 4584 1
wl 897336 0 (unused)
et 29088 0 (unused)


Now if I disable nfs from the web interface, and try to "ins nfs.o", then I receive the error message
[admin@Asus modules]$ insmod nfs.o
insmod: unresolved symbol rpc_wake_up_task