PDA

Bekijk de volledige versie : Cant get Samba working



Mr.EoniX
08-04-2005, 11:00
Hi there,

Iv been working around with my new Asus WL-500G Deluxe for a few weeks now - reading like a madman on this forum. Great work btw ;).

But Im still having my share of problems with setting samba up properly.
Iv gotten SSH working easily - and my external 200gb disk is partitioned like the "GETTING STARTED HOWTO" explained to do, to avoid errors.

http://wl500g.info/showthread.php?t=1984&highlight=samba

But - after following that guide in superdetail (fixing some typo's in some of the commands) - and really tried to understand why samba isnt working - im slowly giving up, and calling you guys for help.

I have set a hostname in the webinterface as well - but there is simply no response from my router when i type either \\192.168.1.1 or \\500GDeluxe (which is my hostname).

My /etc/smb.conf looks like this:



[global]
workgroup = WORKGROUP
guest account = nobody
security = share
browseable = yes
guest ok = yes
guest only = no
log level = 1
max log size = 100
encrypt passwords = yes
dns proxy = no

[fat32]
path=/tmp/harddisk
writeable = yes
browseable = yes
force user = admin

[ext3]
path=/tmp/harddisk/part1
path=/tmp/harddisk
writeable = yes
browseable = yes
force user = admin


my partitions look like this:


WITH DF:

Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 2688 2688 0 100% /
/dev/discs/disc0/part1 31239152 64 31239088 0% /tmp/harddisk
/dev/discs/disc0/part5165252792 32828 156825604 0% /tmp/harddisk/part1

IN FDISK:

/dev/scsi/host0/bus0/target0/lun0/part1 1 3891 31254426 c Win95 FAT32 (LBA)
/dev/scsi/host0/bus0/target0/lun0/part2 3892 24792 167887282+ 5 Extended
/dev/scsi/host0/bus0/target0/lun0/part5 3892 24792 167887251 83 Linux


Im using the firmware surgested in the "Getting started" guide (1.9.2.7-4).

I hope you guys can help me.


EoniX

barsju
08-04-2005, 11:35
\\192.168.1.1 or \\500GDeluxe

Asuming you tried \\192.168.1.1\fat32 or \\500GDeluxe\ext3....?

Other tips..
- make sure smbd and nmbd is running ("ps")
- and that they are listening "netstat -a"
- Have you messed around with firewall? If so you can post restults from "iptables -L"

S.

Mr.EoniX
08-04-2005, 11:50
Asuming you tried \\192.168.1.1\fat32 or \\500GDeluxe\ext3....?

Tried both now - not working at all.

I should prolly mention that my router isnt replying on 500GDeluxe when pinging it. But it does reply on 192.168.1.1. I have no idea why its not responding on the set hostname in the webinterface.



- make sure smbd and nmbd is running ("ps")

None of them is running... (which would explain alot I guess) - How do I start them - and why arent they started ?



- and that they are listening "netstat -a"

Which ports am I looking for here ?

Havent messed around with my firewall other than disabling it.

Please help :P

barsju
08-04-2005, 11:58
Well did you enable it from web admin? Usb Application -> Samba?

Try that. If it doesn't work you can put


/usr/sbin/nmbd -D
/usr/sbin/smbd -D

in your post-mount file.

S.

Mr.EoniX
08-04-2005, 12:13
In the webinterface all I can set is:

Enable Samba Demo mode? Yes No
Enable hidden read-write share? Yes No

Which tell me shit - At which state is it enabled ? - I cannot enable DEMO MODE - even after saving and restarting the router.

And this is the commands from the "HOWTO" guide to put in smbd -D and nmdb -D in my post-mount file.

echo "/usr/sbin/smbd -D" >> /usr/local/sbin/post-boot
echo "/usr/sbin/nmbd -D" >> /usr/local/sbin/post-boot

Please help

barsju
08-04-2005, 12:23
echo "/usr/sbin/smbd -D" >> /usr/local/sbin/post-boot
echo "/usr/sbin/nmbd -D" >> /usr/local/sbin/post-boot

And then you need to "flashfs save", "flashfs commit" and the first time you need to "flashfs enable".

But you can also just run /usr/sbin/smbd -D and /usr/sbin/nmbd -D from command line, and see if it works then. If that works try to stick into post-mount (since they access the hd..)

S.

Mr.EoniX
08-04-2005, 12:52
Hey,

I just tried completly to reset my router to default - and then i followed the intire GETTING STARTED GUIDE one more time - and did exactly what you said just now - but even the
/usr/sbin/smbd -D
/usr/sbin/nmbd -D
in the commandline ISNT starting anything up.

My god this is frustrating.

Please help

barsju
08-04-2005, 13:08
Check your syslog.

"cat /tmp/syslog.log"

S.

Mr.EoniX
08-04-2005, 16:55
syslog shows only this


Apr 8 13:44:12 login[137]: root login on `pts/0'
Apr 8 13:47:46 dropbear[151]: Running in background
Apr 8 15:42:30 ntp client: Synchronizing time with time.nist.gov ...
Apr 8 16:33:01 dnsmasq[58]: DHCPINFORM(br0) 192.168.1.20 00:01:80:3e:80:df
Apr 8 16:33:01 dnsmasq[58]: DHCPACK(br0) 192.168.1.20 00:01:80:3e:80:df eonix
Apr 8 16:33:04 dnsmasq[58]: DHCPINFORM(br0) 192.168.1.20 00:01:80:3e:80:df
Apr 8 16:33:04 dnsmasq[58]: DHCPACK(br0) 192.168.1.20 00:01:80:3e:80:df eonix
Apr 8 17:42:34 ntp client: Synchronizing time with time.nist.gov ...

And cant find anything of samba

barsju
08-04-2005, 19:42
Strange. If you try without the -D maybe you'll get some error messages..

S.

Mr.EoniX
19-04-2005, 08:09
Nothing up the above works!! - :(

So lets try going over things again - I really want this samba share to work.

Right from the beginning the command /usr/sbin/smbd -D and /usr/sbin/nmbd -D would just stall for 2 seconds and then do nothing - like this:


[admin@dhcppc0 root]$ /usr/sbin/smbd -D
[admin@dhcppc0 root]$ /usr/sbin/nmbd -D
[admin@dhcppc0 root]$

And then it should be running - am I right ?

I try to do ps to see if its started - but there is no such process as smbd or nmbd.
Neither in the netstat -a (still dont know which port they listen on)

I have found on this board that the hostname of the router needs to be set - and I have that set to 500GDeluxe... this is my hosts file.


127.0.0.1 localhost.localdomain localhost
192.168.1.1 500GDeluxe my.router my.WL500g.Deluxe

Really looking forward to getting this samba stuff working.


EoniX

Mr.EoniX
19-04-2005, 10:15
OK - I finally had a break at the problem - but i solved it rather oddly - I realized it had something to do with the hostname not beeing set correctly.

But the smbd was complaining about dhcppc0 didnt have a host - which I thought was strange because i had set the hostname in the webinterface to deluxe.

So i tried to change the hostname in the webinterface to "dhcppc0" - and now it works - the samba deamon starts and everything works - but this isnt the proper way to deal with this. - Can i please get to know how to save permanent changes in the hosts file without the use of the webinterface.

I would simply just like it if this would be added - Im guessing it would fix everything:

192.168.1.1 dhcppc0

But how to save and commit the changes to the hosts file?


EoniX

Oleg
19-04-2005, 11:41
But the smbd was complaining about dhcppc0 didnt have a host - which I thought was strange because i had set the hostname in the webinterface to deluxe.

This is the right way for now.

ikke_ook
20-04-2005, 21:11
But the smbd was complaining about dhcppc0 didnt have a host - which I thought was strange because i had set the hostname in the webinterface to deluxe.


Please tell me where you saw the complaining, thus: which file logged the output?



So i tried to change the hostname in the webinterface to "dhcppc0" - and now it works -
EoniX

Same here, deamon is starting :) Now the configuring is needed, since I'm not able to write to the disk. Oh well, back to the HOWTO I assume.......

Mr.EoniX
21-04-2005, 15:14
It was complaining in the log files of smbd

ikke_ook
21-04-2005, 21:27
It was complaining in the log files of smbd


Ok, :p what I meant to ask was. What's the exact location of these files (path)?

barsju
21-04-2005, 22:35
cat /tmp/var/log/smb

If I'm not mistaken.

S.

LeperKing
03-06-2005, 14:53
OK - I finally had a break at the problem - but i solved it rather oddly - I realized it had something to do with the hostname not beeing set correctly.

But the smbd was complaining about dhcppc0 didnt have a host - which I thought was strange because i had set the hostname in the webinterface to deluxe.

So i tried to change the hostname in the webinterface to "dhcppc0" - and now it works - the samba deamon starts and everything works - but this isnt the proper way to deal with this. - Can i please get to know how to save permanent changes in the hosts file without the use of the webinterface.

I would simply just like it if this would be added - Im guessing it would fix everything:

192.168.1.1 dhcppc0

But how to save and commit the changes to the hosts file?


EoniX


I'm having the same problems, where is the hosts file?

LK

Oleg
03-06-2005, 20:03
upgrade your unit to 1.9.2.7-5a, it has fixed host name issue.

LeperKing
03-06-2005, 20:35
Already on that. Perhaps its a different problem. After going through all the steps, samba and ftp don't work.

LK

Oleg
03-06-2005, 20:53
So, this is not a samba problem. Most likely your usb stick is not recognized.

LeperKing
03-06-2005, 22:35
Forgot the lan ip setting. Samba's working now. But the contents is blank. Ftp keeps coming back with 'connection reset'. The harddisk directory is empty, but I know there is files on my harddrive. (2 fat32 partitions).

any ideas?

Thanks Oleg for the help.

LeperKing
15-06-2005, 17:23
Ok restarted the setup, and ftp is working. I'm using just a simple usb flash drive.
Still, Samba isnt running. Here is the syslog..

Compressor
25-03-2007, 17:09
I'm running into the same problems here. It really isn't strange that linux won't be used by "normal" users... It'll never get a representative marketshare on the consumer market if you really need to make a study out of it just to get one little thing to work. IF it will work at all..... That really is utter crap. :mad: Thank god for community's like this one :)