PDA

Bekijk de volledige versie : Bandwidth Management for sipgate account



Mainzer99
07-04-2005, 23:12
After spending some time in this forum I am a little bit lost. I am still trying to fix the following problem:

I have a WLAN Network as the following:

Router: Asus WL-500g, 1.9.2.7-4 firmware
APs: Asus WL-300g, Asus WL-500g deluxe (using WDS)
ATA: Grandstream HandyTone 486 in Client Mode with fixed IP (e.g. 192.168.1.6) connected to the WL-500g deluxe

VoIP Account: Sipgate.de

Phone calls via sipgate are working pretty bad, I experience dropouts from time to time. I assume QoS problems.

What is the correct setting for the bandwidth management? Or do I need to adjust the Wondershaper script? :confused: What is exactly what I ahve to do then?

Looking forward to your support!

cw17
08-04-2005, 19:33
Hello,

upload management isn't working, no matter which firmware from ASUS or anybody else. Download management is working, but that's usually not the problem. In most cases, you wanna limit the upload.

To fix your problem, try netlimiter (www.netlimiter.com) or bandwidth controller (www.... com).

Netlimiter can manage down-/upload for each application on your PC, it's easy to use. This will usually solve your problem.

Greetings from Germany

Mainzer99
08-04-2005, 20:53
Bad news for me, since there are 10+ clients in the network. I do not have access to all of them. What is the reason for this failure of the Asus routers? They advertise the bandwidth management!

Any idea if the Wireless -> Advanced options can improve the situation (e.g. WMM)?

Besides bandwidth, might latency be another issue in this situation?

Best regards,
Michael

cw17
09-04-2005, 00:45
Hello Michael,

somebody from Germany, too :)

Well, I was faced with pretty much the same problem. A lot of users, can't install netlimiter to all their PCs and so on.

As far as I know (and I spent a lot of time researching) this is not possible with any W-LAN Router. The only way I know is to set up a server with KERIO Winroute 6 (www.kerio.com), which allows you to limit the number of connections for each user (helps to keep your pings low... "latency" is another word for it).
As I've mentioned, wwww.bandwidthcontroller.com is the tool to look for concerning up-/download management.
With KERIO+Bandwidthcontroller, you can manage EVERYTHING, and the Users don't even know. No software-installation on the Clients-PCs, no proxy or anything like this.

Upload Management isn't working with the 500g and all firmwares, I don't know why. Asked that in this forum before, no real answer.
Besides, even with working upload management, you would still have the problem that one single user can kill your connection building up 1000 or more connections at the same time (emule, bittorrent.....).
Haven't tried the Advanced Options in the ASUS Router, but I don't think it will help.

Some guys say that "wondershaper" might solve all these problems. This is a script for Linux. But as far as I've read, it's very difficult to install and to configure, if you're not a linux expert. KERIO+BC are user-friendly Windows-Programms.

Grüße aus Sachsen!

PS: Maybe I can help you more if you tell me a little bit more about your configuration (T-DSL? 1000? 2000? 3000? How many users? ....)

WlanMan
09-04-2005, 14:25
Hi

Well, i use a Grandstream 101 phone here and till now there were no notisable dropouts in the calls with my dsl1000 connection even with 90% line usage. But i must say i haben´t tried it jet with, say a maximum ftp upload.

Also, just if someone is interrested all providers i tested worked without any sort of sip-stun or sip proxy...

Greets

Mainzer99
09-04-2005, 14:57
#WlanMan

I think the problem is the WLAN connection between the Router and the AP. The ATA ist connected to the AP.

#cw17
We operate a 2 MBit TDSL line with T-Online.

At the Asus WL-500g router we have 1 client PC via Ethernet and 3 Client PCs via WLAN

The WL-300g has 1 Client via Ethernet and 4 Clients via WLAN

The WL-500g deluxe AP has the ATA 486 connected via Ethernet and 2 Clients via WLAN.

This setup is due tot he fact, that we are only able to get 1 DSL (according to Deutsche Telekom) line in this house, so we share this connection between different families. With a running VoIP via WLAN I could save the money for my Telekom account.

cw17
09-04-2005, 20:52
@Mainzer99

Maybe your W-LAN connection is unstable. I usually check this before I setup a VoIP account:

1. Check your pings directly at the Router. NOT OVER W-LAN. For example, type "ping -t heise.de" in the command-line (Start -> Ausführen -> "cmd") of a client-PC that is connected directly to the router. For a normal T-DSL line, it should be between 40-80 ms. My line (3MBIT, Fastpath activated) has this typical ping:

Antwort von 193.99.144.80: Bytes=32 Zeit=44 ms
Antwort von 193.99.144.80: Bytes=32 Zeit=45 ms
Antwort von 193.99.144.80: Bytes=32 Zeit=44 ms
Antwort von 193.99.144.80: Bytes=32 Zeit=44 ms

193.99.144.80 = heise.de

Please use only heise.de, it's very stable.

If you're ping changes like 44ms, 70ms, 80ms, 50ms or something like that, it indicates that someone else is using the connection.

This is my typical ping if i'm uploading with 50% of the line capacity (I have 48kb upload, so i'm using 24 here):

Antwort von 193.99.144.80: Bytes=32 Zeit=60 ms
Antwort von 193.99.144.80: Bytes=32 Zeit=77 ms
Antwort von 193.99.144.80: Bytes=32 Zeit=44 ms
Antwort von 193.99.144.80: Bytes=32 Zeit=58 ms

As you can see, the numbers are going up, the more you down- or upload.

2. Check your ping over a W-LAN PC. Use the same commands, type: "ping -t heise.de". -t means to do the ping over and over again. Let it run for about 5 minutes. To do this, type this:

"ping -t heise.de > output.txt".

After 5 minutes, check the file output.txt. Look for drop-outs ("Zeitüberschreitung") in the ping-commands. If you have no drop-outs, you're w-lan connection seems to be stable. If you do have drop-outs, VoIP won't usually work well. Usually, EVERY W-LAN has drop-outs every once in a while. 1 dropout for 100 pings seems to be okay, the more you have the worse your connection will be.

Also, compare your w-lan ping to your directly connected client-pc. Usually, the w-lan pings are about 1-2ms higher. If it's much higher, you have to solve that problem first.

That's all, check this and tell me what you've got.

Greetings

Mainzer99
09-04-2005, 23:37
Unfortunately I am not able to check teh connection at the router, but behind the WLAN I get a very unstable connection.

Reply from 193.99.144.80: bytes=32 time=118ms TTL=248
Reply from 193.99.144.80: bytes=32 time=343ms TTL=248
Reply from 193.99.144.80: bytes=32 time=322ms TTL=248
Reply from 193.99.144.80: bytes=32 time=443ms TTL=248
Reply from 193.99.144.80: bytes=32 time=512ms TTL=248
Reply from 193.99.144.80: bytes=32 time=215ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=67ms TTL=248
Reply from 193.99.144.80: bytes=32 time=555ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=94ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=68ms TTL=248
Reply from 193.99.144.80: bytes=32 time=64ms TTL=248
Reply from 193.99.144.80: bytes=32 time=65ms TTL=248
Reply from 193.99.144.80: bytes=32 time=68ms TTL=248
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=58ms TTL=248
Reply from 193.99.144.80: bytes=32 time=63ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Reply from 193.99.144.80: bytes=32 time=72ms TTL=248
Reply from 193.99.144.80: bytes=32 time=63ms TTL=248
Reply from 193.99.144.80: bytes=32 time=211ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=86ms TTL=248
Reply from 193.99.144.80: bytes=32 time=568ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=191ms TTL=248
Reply from 193.99.144.80: bytes=32 time=66ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=78ms TTL=248
Reply from 193.99.144.80: bytes=32 time=70ms TTL=248
Reply from 193.99.144.80: bytes=32 time=80ms TTL=248
Reply from 193.99.144.80: bytes=32 time=236ms TTL=248
Reply from 193.99.144.80: bytes=32 time=102ms TTL=248
Request timed out.
Request timed out.
Reply from 193.99.144.80: bytes=32 time=65ms TTL=248
Reply from 193.99.144.80: bytes=32 time=143ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=103ms TTL=248
Reply from 193.99.144.80: bytes=32 time=247ms TTL=248
Reply from 193.99.144.80: bytes=32 time=239ms TTL=248
Reply from 193.99.144.80: bytes=32 time=98ms TTL=248
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Reply from 193.99.144.80: bytes=32 time=74ms TTL=248
Reply from 193.99.144.80: bytes=32 time=156ms TTL=248
Reply from 193.99.144.80: bytes=32 time=161ms TTL=248
Reply from 193.99.144.80: bytes=32 time=166ms TTL=248
Reply from 193.99.144.80: bytes=32 time=771ms TTL=248
Request timed out.
Request timed out.
Request timed out.
Reply from 193.99.144.80: bytes=32 time=77ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=79ms TTL=248
Reply from 193.99.144.80: bytes=32 time=98ms TTL=248
Reply from 193.99.144.80: bytes=32 time=454ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=58ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=71ms TTL=248
Reply from 193.99.144.80: bytes=32 time=149ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=159ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=144ms TTL=248
Reply from 193.99.144.80: bytes=32 time=238ms TTL=248
Reply from 193.99.144.80: bytes=32 time=95ms TTL=248
Reply from 193.99.144.80: bytes=32 time=236ms TTL=248
Reply from 193.99.144.80: bytes=32 time=123ms TTL=248
Reply from 193.99.144.80: bytes=32 time=184ms TTL=248
Reply from 193.99.144.80: bytes=32 time=249ms TTL=248
Reply from 193.99.144.80: bytes=32 time=550ms TTL=248
Reply from 193.99.144.80: bytes=32 time=75ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=84ms TTL=248
Reply from 193.99.144.80: bytes=32 time=136ms TTL=248
Reply from 193.99.144.80: bytes=32 time=118ms TTL=248
Reply from 193.99.144.80: bytes=32 time=172ms TTL=248
Reply from 193.99.144.80: bytes=32 time=170ms TTL=248
Reply from 193.99.144.80: bytes=32 time=216ms TTL=248
Reply from 193.99.144.80: bytes=32 time=355ms TTL=248
Reply from 193.99.144.80: bytes=32 time=368ms TTL=248
Reply from 193.99.144.80: bytes=32 time=504ms TTL=248
Reply from 193.99.144.80: bytes=32 time=455ms TTL=248
Reply from 193.99.144.80: bytes=32 time=469ms TTL=248
Reply from 193.99.144.80: bytes=32 time=586ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=618ms TTL=248
Request timed out.
Reply from 193.99.144.80: bytes=32 time=113ms TTL=248
Reply from 193.99.144.80: bytes=32 time=150ms TTL=248
Reply from 193.99.144.80: bytes=32 time=353ms TTL=248
Reply from 193.99.144.80: bytes=32 time=324ms TTL=248
Reply from 193.99.144.80: bytes=32 time=401ms TTL=248
Reply from 193.99.144.80: bytes=32 time=343ms TTL=248
Reply from 193.99.144.80: bytes=32 time=575ms TTL=248
Reply from 193.99.144.80: bytes=32 time=190ms TTL=248
Reply from 193.99.144.80: bytes=32 time=662ms TTL=248
Reply from 193.99.144.80: bytes=32 time=637ms TTL=248
Request timed out.

Ping statistics for 193.99.144.80:
Packets: Sent = 391, Received = 352, Lost = 39 (9% loss),
Approximate round trip times in milli-seconds:
Minimum = 58ms, Maximum = 1072ms, Average = 187ms

I am pretty sure to have a WLAN problem. What can I do to solve this?

Michael

cw17
10-04-2005, 12:34
Hello Michael,

thank you for your log-files, this helps a lot.

As I've thought, your W-LAN Connection is very unstable. At this point, you can't really use that line for VoIP.

Here's what I usually do to solve this problem:

1. Do you still use the original atenna from ASUS for your 500g? Replace it!

I got this one:

http://www.reichelt.de/inhalt.html?SID=14QjTeV9S4AQ4AAHq%40OKwbbffae2a387 fb9193d424f8af4a523db;ACTION=3;LASTACTION=2;SORT=p reis;GRUPPE=ECB3;WG=0;SUCHE=antenne;ARTIKEL=LAN%25 20WL-IW151RS;START=0;END=16;STATIC=0;FC=669;PROVID=0;TI TEL=0

It increases your antenna range from 2 db to 5 db, this normally already solves your problem. Its only 10 Euros and VERY easy to install (just plug it in). If this antenna works for your 300g, too, get it!

2. If that still doesn't help, try the LinkSYS WRT54G Router at your W-LAN Client-PCs. With a special firmware (I have all the links if you wanna try this) you can increase the power to the antennas. This firmware also allows you to track the w-lan signal, so you can see in realtime if the signal gets worse if you move the Router from one place to another. This can be VERY helpful.

I had the situation that the signal was stable if I move the router just a little bit.


As far as I can tell, the combination ASUS 500g with the 5 db antenna and LinkSYS WRT54G with special firmware for antenna-boost is a very powerful combination. But normally the bigger antenna should help you already.


If you don't wanna spend money at all, try moving the antenna at your 500g and your 300g. Sometimes, this helps already.


Good Luck, don't hesitate to ask me if you have further questions.

Greetings from Saxony, Germany

Mainzer99
25-04-2005, 20:40
Thank you for your hints. The major problem was the WLAN-connection. I solved the problem and now the ATA works behind the AP pretty fine. What did I do?
- better antennas and positioning of bridges
- I removed the second AP from the bridge list of the router. Now the second AP is only in the bridge list of the first AP, which is closer to the router. I do not know why, but otherwise it did not work. Maybe the second AP found a very low connection to the router and was using the bad connection instead using the first bridge.
- in Advanced Wireless settings I enabled "WMA"
- I put ports 5004, 5060, 8000:8012, 10000 in the Virtual Server List of the ATA's IP adresse

But still, the system does not run stable enough to substitute the telephone. I was wondering which settings in bandwidth management have to be made. What do you think of:
Download: Ip adress of ATA, 80 kbps
Upload:
Port
5004 80 kbps
5060 80 kbps
10000 80 kbps
??

Any ideas or comments?

Bets regards...

cw17
29-04-2005, 09:51
Hello,

sorry for answering so late, i'm not coming by here every day. If you would like me to answer instantly, just mail your questions to me at cw17 (at) gmx.net (would also be nice to talk in german :) )

So, you got your connection stable...... could you send me another ping-log? Would be helpful.

Anyway, the ASUS Bandwidth Management for Upload isn't working at all (don't ask me why...), so this won't work. I've tried a couple of firmwares (also some Non-Asus Firmwares), they all have the same problem (no upload management). Hope this will change in the future.

Which VoIP company are you using? 1&1? Sipgate? Something like that?

Usually, if your pings are stable, but VoIP doesn't work, I can only think of 2 possible answers:

- Someone is using a P2P-application (Emule, Bittorrent etc.)
(This usually causes pings >200 and they're changing a lot, so it's easy to see)
- Someone is using all of your upload (FTP, large E-Mails etc.)
(Same, high pings, easy to check)
- Your VoIP company has a problem with NAT (Network Address Translation) or something similar

In order to help you more, send me another ping-log.

As a said, send me your questions via mail if you want faster answers.

Greetings

Mainzer99
29-04-2005, 11:16
I think, the problem ist the upload management. Most of the time it works fine (90%). Sometimes I recognize drop outs. I assume somebody else using the bandwidth.

Can anyone else confirm, that there is no way to manage upload bandwidth with an Asus WL-500g?

Btw: I use sipgate.

Here my protocol:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\>ping -t heise.de

Pinging heise.de [193.99.144.80] with 32 bytes of data:

Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=114ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=133ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=66ms TTL=248
Reply from 193.99.144.80: bytes=32 time=66ms TTL=248
Reply from 193.99.144.80: bytes=32 time=65ms TTL=248
Reply from 193.99.144.80: bytes=32 time=64ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=67ms TTL=248
Reply from 193.99.144.80: bytes=32 time=65ms TTL=248
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=61ms TTL=248
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=68ms TTL=248
Reply from 193.99.144.80: bytes=32 time=66ms TTL=248
Reply from 193.99.144.80: bytes=32 time=65ms TTL=248
Reply from 193.99.144.80: bytes=32 time=64ms TTL=248
Reply from 193.99.144.80: bytes=32 time=62ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=59ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248
Reply from 193.99.144.80: bytes=32 time=60ms TTL=248

Ping statistics for 193.99.144.80:
Packets: Sent = 64, Received = 64, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 59ms, Maximum = 133ms, Average = 62ms

cw17
01-05-2005, 02:40
Hello,

thanks for log. Your connection seems stable now.

You're saying it works fine 90% of the time...... in that case, probably (as you've mentionend) somebody is using all the upload. The only thing you can do about this:

1. adjust upload for every user (isn't working for the 500g although....)

2. Install Netlimiter on every client-PC (you've told me already that this is not possible)

3. Setup a server with Kerio and BandwidthController. This solution always works fine, but its necessary to setup a PC that is running 24/7.

Links:
http://www.kerio.com/kwf_home.html
http://www.bandwidthcontroller.com

4. Use another routher instead of the 500g (like the WRT54G).

Hope I could help.

Greetings