PDA

Bekijk de volledige versie : Atheros do Asusa WL-500gP



maleo_m
04-09-2009, 08:27
Witam,

Chcę podmienić Broadcom`a na taką kartę: miniPCI WLAN TP-Link TL-WN861N z chipsetem Atherosa. Używam OpenWrt Kamikaze 8.09.1 (r16206) kernel 2.4, gui Luci.
Wg http://nuwiki.openwrt.org/oldwiki/OpenWrtDocs/Hardware/Asus/WL500GP#head-0397af4737142e0571dea1870f8cdda1ce8adbbb
przepinam kartę, daję komendę:

uci set wireless.wifi0.disabled=0
uci commit wireless && wifi

i działa.
Czy to na pewno wszystko? Nie muszę doinstalowywać jakichś sterowników do Atherosa?
Ktoś z Was testował takie rozwiązanie?

Dzięki za odpowiedź

Lesiuk
04-09-2009, 12:37
Witam,

Chcę podmienić Broadcom`a na taką kartę: miniPCI WLAN TP-Link TL-WN861N z chipsetem Atherosa. Używam OpenWrt Kamikaze 8.09.1 (r16206) kernel 2.4, gui Luci.
Wg http://nuwiki.openwrt.org/oldwiki/OpenWrtDocs/Hardware/Asus/WL500GP#head-0397af4737142e0571dea1870f8cdda1ce8adbbb
przepinam kartę, daję komendę:

uci set wireless.wifi0.disabled=0
uci commit wireless && wifi

i działa.
Czy to na pewno wszystko? Nie muszę doinstalowywać jakichś sterowników do Atherosa?
Ktoś z Was testował takie rozwiązanie?

Dzięki za odpowiedź

Wifi działa od razu.
Tylko pamiętaj żeby użyć fw dla atherosa

http://downloads.openwrt.org/kamikaze/8.09.1/atheros/

lub doinstaluj madwifi z repo i edytuj plik

/etc/config/wireless:

config wifi-device wifi0 (w tej linii zmieniłem wl0 na wifi0)
option type 'atheros'
option channel 5
option disabled '0'
option distance '20'
option mode '11g'
option diversity '0'
option txantenna '2'
option rxantenna '2'

# REMOVE THIS LINE TO ENABLE WIFI:

config wifi-iface
option device wifi0 (tutaj także wl0 -> wifi0)
option network lan
option mode ap
option ssid OpenWrt
option encryption 'psk2'
option hidden '0'
option isolate '0'
option txpower '8'
option bgscan '0'
option wds '0'
option key 'aaabbbccc'

maleo_m
04-09-2009, 14:04
Dzięki za pomoc.

Wybiorę opcje ze zmianą fw.
Jeszcze jedno pytanko fw dla atherosa nie ma rozszerzenia trx, tak ma być czy muszę coś zmieniać?
A może warto kamikadze od razu z 2.6 (http://downloads.openwrt.org/kamikaze/8.09.1/brcm47xx/-ten o ile się nie mylę) bo na http://wireless.kernel.org/en/users/Drivers/ath9k#ath9k piszą, ze przy 2.6 ten sterownik jest od razu no i kamerka powinna mi zadziałać.

Lesiuk
04-09-2009, 18:29
Tak, w fw z kernelem 2.6 od razu są sterowniki od atherosa.

http://downloads.openwrt.org/kamikaze/8.09.1/brcm47xx/openwrt-brcm47xx-squashfs.trx

maleo_m
04-09-2009, 19:34
Ok. To będę działał z 2.6 Jeszcze raz serdecznie dziękuje za pomoc.

swwitch
07-09-2009, 16:59
witam,
a co daje zmiana fw na 2.6?
tez myślę o wymianie karty wifi na atherosa, ale nie chciałbym się pozbawić innych rzeczy, jak transmission, rsget, itd...
czy wszystko to co było na 2.4 będzie działać na 2.6?
co wnosi wogóle 2.6, jaka jest różnica pomiędzy nimi?
dzięki

Lesiuk
07-09-2009, 18:03
witam,
a co daje zmiana fw na 2.6?
tez myślę o wymianie karty wifi na atherosa, ale nie chciałbym się pozbawić innych rzeczy, jak transmission, rsget, itd...
czy wszystko to co było na 2.4 będzie działać na 2.6?
co wnosi wogóle 2.6, jaka jest różnica pomiędzy nimi?
dzięki

http://rainbow.mimuw.edu.pl/SO/Projekt04-05/temat4-g5/

I wiele wiele innych.

Programy będą działały.

kauczu
12-09-2009, 10:52
Pytanie do użytkowników konfiguracji 'wl500gp-karta atheros-openwrt kernel 2.6':

czy występuje u was bug opisany tutaj (https://dev.openwrt.org/ticket/2558) (problem z przekierowaniem portów)?
W zasadzie to już nie wiem, czy ten bug jest tylko związany z kernelem 2.4 czy może z 2.6 też, dlatego proszę o opinię. Niby ten bug jest już naprawiony, ale na forum openwrt użytkownicy dalej zgłaszają problemy związane z nim.

Planuję zmianę karty minipci na coś opartego na atherosie + chciałbym spróbować openwrt na kernelu 2.6 ale nie wiem czy jest sens brnąć w ten soft skoro bug opisany wyżej może nadal występować ...

D.jeamb
09-10-2009, 04:04
I have a atheros ar5007eg that doesnt connect to wireless networks
I know that I have to do something involving ndiswrapper or madwifi but what?

Im grateful for any help

P.S, as to complicate things I am unable to use LAN

maleo_m
13-11-2009, 19:05
Pytanie do użytkowników konfiguracji 'wl500gp-karta atheros-openwrt kernel 2.6':

czy występuje u was bug opisany tutaj (https://dev.openwrt.org/ticket/2558) (problem z przekierowaniem portów)?
W zasadzie to już nie wiem, czy ten bug jest tylko związany z kernelem 2.4 czy może z 2.6 też, dlatego proszę o opinię. Niby ten bug jest już naprawiony, ale na forum openwrt użytkownicy dalej zgłaszają problemy związane z nim.

Planuję zmianę karty minipci na coś opartego na atherosie + chciałbym spróbować openwrt na kernelu 2.6 ale nie wiem czy jest sens brnąć w ten soft skoro bug opisany wyżej może nadal występować ...

U mnie nie występuje. Nie mam problemów z przekierowaniem portów.

kauczu
13-11-2009, 20:06
U mnie nie występuje. Nie mam problemów z przekierowaniem portów.

Dzięki za nfo :)

Mógłbyś się podzielić swoimi spostrzeżeniami, uwagami odnośnie użytkowania OpenWrt 8.09.1 @ WL500gp ? Bardzo mnie interesuje jaka jest stabilność, użycie ram, ficzersy. Jak długo korzystasz openwrt na asusie?
Korzystałeś wcześniej z fw Olega z czy zainstalowałeś OpenWrt bezpośrednio na stockowe fw asusa?

Sorry że tak przepytuje ale to jak dla mnie dość poważna hardwarowo-softwarowa zmiana i chciałbym się przyzwoicie do niej przygotować ;)

Sam od samego początku korzystam z softu Olega, jednak kusi mnie kernel 2.6 w openwrt, którego na próżno szukać w fw Olega.

maleo_m
13-11-2009, 22:40
Dzięki za nfo :)

Mógłbyś się podzielić swoimi spostrzeżeniami, uwagami odnośnie użytkowania OpenWrt 8.09.1 @ WL500gp ? Bardzo mnie interesuje jaka jest stabilność, użycie ram, ficzersy. Jak długo korzystasz openwrt na asusie?
Korzystałeś wcześniej z fw Olega z czy zainstalowałeś OpenWrt bezpośrednio na stockowe fw asusa?

Sorry że tak przepytuje ale to jak dla mnie dość poważna hardwarowo-softwarowa zmiana i chciałbym się przyzwoicie do niej przygotować ;)

Sam od samego początku korzystam z softu Olega, jednak kusi mnie kernel 2.6 w openwrt, którego na próżno szukać w fw Olega.

Jestem zadowolony. OpenWrt wybrałem ze względu na to, że obsługuje kamerkę, której używam (Logitech Qc Pro for Notebook Business). Olega nie testowałem. OW v 2.4 zainstalowałem na wiosnę - nie miałem problemów, miesiąc temu zmieniłem wifi na Atheros`a i 2.6. Na razie były dwie zwieszki wifi, ale reboot załatwił sprawę, nie powtarzają się. Może to dziwnie zabrzmi, ale na 2.6 OpenWrt działa jakby szybciej. Pamięć wygląda tak: total 29952 used 17100 free 12852 shared 0 buffers 1208

Oprócz kamerki, nic jeszcze nie instalowałem, dopiero się przymierzam (samba, poczta, www, odtwarzacz mp3 - howto są)

Z ciekawostek to zamianę fw z 2.4 na 2.6 zrobiłem przy pomocy zakładki flash firmware w Luci, bez wprowadzania routera w tryb diagnostyczny. Madwifi trzeba było doinstalować.

kauczu
24-12-2009, 00:21
miesiąc temu zmieniłem wifi na Atheros`a i 2.6.

Wracając do tematu...
Poszedłem trochę Twoimi śladami - nabyłem TL-WN861N i trochę eksperymentowałem przez miesiąc. Muszę przyznać, że trochę się rozczarowałem. Otóż z tego co zdążyłem wyedukować: TL-WN861N jest wspierana w OpenWrt tylko przez jądro 2.6 i to w wersji trunk (gdzie jest dostępny sterownik ath9k). Na jądrze 2.4 nie udało mi się uruchomić tej karty wifi. Pisałeś wyżej, że wcześniej miałeś 2.4 z kartą TL-WN861N czy z broadcomem? Bo może ja coś źle robię.

Moje odczucia po miesiącu testowania Openwrt 8.09.1, trunk, zarówno 2.4 jak i 2.6, pobierane jak i kompilowane własnoręcznie:
- Openwrt 8.09.1 (2.4) - wifi na broadcomie działa, na atherosie nie, generalnie nawet znośne to chodzi wszystko
- Openwrt 8.09.1 (2.6) - nie działa wifi na atherosie (brak sterów ath9k, które są dostępne tylko w trunk), katastrofa, jeżeli chodzi o transfer z HDD (podpiętego do asusa) do komputera ok 700kb/s po ftp, samba gorzej
- Openwrt trunk (2.4) - wifi na broadcomie działa, na atherosie nie, luci się sypie, co któreś kliknięcie w odnośnik wywala "białą" stronę i trzeba odświeżać
- Openwrt trunk (2.6) - praktycznie jedyna (mi znana) opcja uruchomienia karty TL-WN861N. Luci sypie się standardowo (patrz wyżej) w trunk, a wifi na atherosie potrafi wywalić wszystkich losowo (z powodu "deauthenticated") i pomaga jedynie (na jakiś czas) network reload. Transfery z dysku twardego - żółwie tempo, tak jak na 8.09.1. (2.6)

Na fw Olega używałem routera (po za jego oczywistymi funkcjami) do drukowania (HP LJ P1005 i HP DJ 5150) i pobierania za pomocą skryptu ADOS.
Jeżeli chodzi o drukowanie, to w OpenWrt działa ale ile się namęczyłem, żeby OpenWrt nie przesyłał firmware do drukarki P1005 dwa razy a raz, a i tak mi się nie udało.
Co do ADOS'a (główny powód dla którego dziś znowu zainstalowałem soft Olega) niestety nie działa, bo nie ma w trunk Openwrt wymaganych rozszerzeń php przez ADOS do skompilowania...

Podsumowując moje wypociny:
podpowiedz mi - bo chyba nieskapowałem - ty masz kartę TL-WN861N i działała Ci na kernelu 2.4 jak i teraz działa Ci bez żadnych zwisów wifi na kernelu 2.6?