PDA

Bekijk de volledige versie : Ftp Wan



CPTC
06-04-2005, 10:33
i read the Thread below : "no ftp connection from wan anymore" but didnt understand a word :)



could someone tell me the solution in easy english :)



router: WL500gx
my router has the IP 192.168.0.1


in which menu i can connect my FTP-Server to the WWW/WAN. When is use a computer in my HomeLan i can connect to the FTPServer by using 192.168.0.1 and by using the WAN ip I get from my provider.


but when i give the address of my FTP to other ppl they cant connect to it. They dont get any connection.

The link i gave them is in this form:

ftp://nameassword@xxx.xxx.xxx.xxx
port 21

it works for my homeLAN but not for WAN



i even tried to do port forwarding
in Virtual Server List i did the settings:
PORT RANGE = 20:21
Local IP 192.168.0.1
local port 21
Protocol TCP
Protocol No. *empty*
Description ....



i tried to find something in the forums, but hardly found something and if i found anything it was to difficult english for me...


THX
Christoph

Snufkin
06-04-2005, 11:19
i can connect to the FTPServer by using ... WAN ip I get from my provider.
It's seems router provides you with so called loopback, and it's OK.


...but when i give the address of my FTP to other ppl they cant connect to it.

Does you subscription with local ISP include some type of port filtering? For example I have subscription with all server-type port filtering i.e. TCP: 20, 21, 23, 25, 53, 69, 80, 135-139, 161, 254, 255, 443, 445, 3128, UDP: 53, 69, 135-139, 161. That meens I should choose another type of subscription in case I would like to establish public server of any type.

Styno
06-04-2005, 11:30
In simple words:
- Make sure you use firmware 1.7.5.9 CR3 or higher
- Reset your router to defaults using the webinterface.
- Perform basic setup
- Don't do anything with 'Virtual Server', 'Port forwarding' or 'Virtual DMZ'
- Enable FTP server
- Allow anonymous access (for testing perposes)
- Check if its working (it should)

Background: The FTP server needs only to be enabled in the webinterface, nothing more. When you've enabled the FTP server, people should be able to connect to it without further configuration.

When this is working you can setup the proper user privileges.

CPTC
06-04-2005, 21:54
THX ill try it

tthen
07-04-2005, 19:33
I had firmware 1.9.2.7, asus built-in ftp was working ok. download speed was about 400 kb/s from local lan.

Upgraded to olegs firmware 1.9.2.7-4. ftp is not reachable anymore.

get this message: (using ftp commander software):
connecting to 192.168.1.1 , 07 apr 2005 20:28:47
500 Connection refused (Winsock error #10061)

i'm using the same settings as before.

do i have to do some other settings/commands to make ftp work on the new firmware?

Have searched the forum, but have not seen anything.

Oleg
07-04-2005, 19:47
Please post your complete ftp page settings.
Also, telnet to device (telnet://my.router) and type the following:


mount
ps
cat /tmp/stupid-ftpd.conf

and post your results.

tthen
07-04-2005, 20:27
Enable FTP Server? Yes
Allow Anonymous User to Login? No
Allow Super User to Login? Yes
FTP Port: 21
Maximum Users Allowed to Log in: 12
Login Timeout in Seconds: 120
Stay Timeout in Seconds: 240

user account list:
user: test
passord: test
max login: 2

THIS HAPPEND ON TELNET SETTINGS:

(none) login: admin
Password:
[admin@(none) root]$ mount
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
[admin@(none) root]$ ps
PID Uid VmSize Stat Command
1 admin 676 S /sbin/init
2 admin SW [keventd]
3 admin SWN [ksoftirqd_CPU0]
4 admin SW [kswapd]
5 admin SW [bdflush]
6 admin SW [kupdated]
7 admin SW [mtdblockd]
39 admin 308 S telnetd
44 admin 424 S httpd eth1
50 admin 328 S klogd
51 admin 372 S syslogd -m 0 -O /tmp/syslog.log -S -l 7
52 nobody 480 S dnsmasq
57 admin SW [khubd]
69 admin 272 S lpd
71 admin 252 S p9100d -f /dev/usb/lp0 0
73 admin 252 S p9101d -f /dev/printers/0 1
76 admin 364 S waveservermain
78 admin 364 S rcamdmain
82 admin SW [usb-storage-0]
83 admin SW [scsi_eh_0]
87 admin 676 S pppd file /tmp/ppp/options.wan0
89 admin 312 S infosvr br0
90 admin 472 S watchdog
91 admin 360 S ntp
117 admin 484 S upnp -D -L br0 -W ppp0
120 admin 520 S -sh
122 admin 372 R ps
[admin@(none) root]$ cat /tmp/stupid-ftpd.conf
cat: /tmp/stupid-ftpd.conf: No such file or directory
[admin@(none) root]$

NO CHANGES SO FAR, GET THIS MESSAGE ON FTP COMMANDER:

Connecting to my.router , 07 apr 2005 21:26:36
500 Connection refused (Winsock error #10061)

Oleg
07-04-2005, 20:52
according to mount output your stick is not plugged to the router or it's not detected.
type this


mount
ls /dev/discs/
cat /proc/scsi/scsi
dmesg

tthen
07-04-2005, 21:17
(none) login: admin
Password:
[admin@(none) root]$ mount
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
[admin@(none) root]$ ls /dev/discs/
disc0
[admin@(none) root]$ dmesg
802.1Q VLAN Support v1.7 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
FAT: bogus logical sector size 21760
FAT: bogus logical sector size 21760
NTFS: Unable to set blocksize 512.
VFS: Mounted root (squashfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 68k freed
Warning: unable to open an initial console.
Algorithmics/MIPS FPU Emulator v1.5
eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.7.0
eth1: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.7.0
PCI: Enabling device 01:02.0 (0004 -> 0006)
eth2: Broadcom BCM4320 802.11 Wireless Controller 3.90.7.0
device eth0 entered promiscuous mode
device eth2 entered promiscuous mode
br0: port 2(eth2) entering listening state
br0: port 1(eth0) entering listening state
br0: port 2(eth2) entering learning state
br0: port 1(eth0) entering learning state
br0: port 2(eth2) entering forwarding state
br0: topology change detected, propagating
br0: port 1(eth0) entering forwarding state
br0: topology change detected, propagating
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xb8004000, IRQ 2
usb-ohci.c: usb-00:04.0, PCI device 14e4:4715
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
hub.c: new USB device 00:04.0-1, assigned address 2
hub.c: USB hub found
hub.c: 4 ports detected
lp0: using parport0 (polling).
usb.c: registered new driver usblp
printer.c: v0.13: USB Printer Device Class driver
hub.c: new USB device 00:04.0-1.2, assigned address 3
usb.c: USB device 3 (vend/prod 0x5ab/0x60) is not claimed by any active driver.
hub.c: new USB device 00:04.0-1.3, assigned address 4
printer.c: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x04B8
pid 0x0005
printer.c: usblp0 Device ID string [90]='MFG:EPSON;CMD:ESCPL2,BDC,D4;MDL:Stylus
Photo 950;CLS:PRINTER;DES:EPSON Stylus Photo 950;'
usb.c: registered new driver audio
audio.c: v1.0.0:USB Audio Class driver
Linux video capture interface: v1.00
SCSI subsystem driver Revision: 1.00
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: WDC WD12 Model: 00JB-00CRA1 Rev: 17.0
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
Partition check:
/dev/scsi/host0/bus0/target0/lun0: p1 p2 p3 p4
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
USB Mass Storage support registered.
lp driver: get device ID
neg fail
printer.c: usblp0 Device ID string [90/max 1552]='MFG:EPSON;CMD:ESCPL2,BDC,D4;MD
L:Stylus Photo 950;CLS:PRINTER;DES:EPSON Stylus Photo 950;'
printer.c: Parsing USBLPID...
lp driver: get device ID
neg fail
neg fail
I/O error: dev 08:01, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:01, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:01, sector 0
FAT: unable to read boot sector
I/O error: dev 08:01, sector 0
NTFS: Reading super block failed
I/O error: dev 08:02, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:02, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:02, sector 0
FAT: unable to read boot sector
I/O error: dev 08:02, sector 0
NTFS: Reading super block failed
I/O error: dev 08:03, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:03, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:03, sector 0
FAT: unable to read boot sector
I/O error: dev 08:03, sector 0
NTFS: Reading super block failed
I/O error: dev 08:04, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:04, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:04, sector 0
FAT: unable to read boot sector
I/O error: dev 08:04, sector 0
NTFS: Reading super block failed
usb.c: USB disconnect on device 00:04.0-1.2 address 3
hub.c: new USB device 00:04.0-1.2, assigned address 5
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 5
I/O error: dev 08:01, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:01, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:01, sector 0
FAT: unable to read boot sector
I/O error: dev 08:01, sector 0
NTFS: Reading super block failed
I/O error: dev 08:02, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:02, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:02, sector 0
FAT: unable to read boot sector
I/O error: dev 08:02, sector 0
NTFS: Reading super block failed
I/O error: dev 08:03, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:03, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:03, sector 0
FAT: unable to read boot sector
I/O error: dev 08:03, sector 0
NTFS: Reading super block failed
I/O error: dev 08:04, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:04, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:04, sector 0
FAT: unable to read boot sector
I/O error: dev 08:04, sector 0
NTFS: Reading super block failed
usb.c: USB disconnect on device 00:04.0-1.2 address 5
usb.c: USB disconnect on device 00:04.0-1 address 2
usb.c: USB disconnect on device 00:04.0-1.3 address 4
printer.c: usblp0: removed
hub.c: new USB device 00:04.0-1, assigned address 6
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 6
I/O error: dev 08:01, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:01, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:01, sector 0
FAT: unable to read boot sector
I/O error: dev 08:01, sector 0
NTFS: Reading super block failed
I/O error: dev 08:02, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:02, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:02, sector 0
FAT: unable to read boot sector
I/O error: dev 08:02, sector 0
NTFS: Reading super block failed
I/O error: dev 08:03, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:03, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:03, sector 0
FAT: unable to read boot sector
I/O error: dev 08:03, sector 0
NTFS: Reading super block failed
I/O error: dev 08:04, sector 2
EXT3-fs: unable to read superblock
MSDOS FS: Using codepage 950
MSDOS FS: IO charset cp950
I/O error: dev 08:04, sector 0
FAT: unable to read boot sector
FAT: freeing iocharset=cp950
I/O error: dev 08:04, sector 0
FAT: unable to read boot sector
I/O error: dev 08:04, sector 0
NTFS: Reading super block failed
[admin@(none) root]$

tthen
07-04-2005, 21:23
i tried to downgrade the firmware to 1.9.2.7 again, and everything is working perfectly.