PDA

Bekijk de volledige versie : VPN problem



vlek
23-03-2005, 21:02
Well my dad needs VPN for his work when i have opened al the ports for vpn it is still not working. It connects to VPN but the harddrives stays offline. If i have his computer straight to the modem VPN works fine but with the router it doesnt.

my firmware version is the 1.9.2.7 downloaded from the ASUS website.

I just dont know what to do, i hope some one can solve my problem.

The internet connection is trew DHCP.

wiz
23-03-2005, 21:08
replace the stock firmware with one of oleg.

Currently mine is running 1.9.2.7-3c at the moment, and vpn connections through this router are no problem.

I use pptp (that's the microsoft one) and cisco's vpn client as well and both run nicely.

Jeroen Vonk
23-03-2005, 21:12
Well my dad needs VPN for his work when i have opened al the ports for vpn it is still not working. It connects to VPN but the harddrives stays offline. If i have his computer straight to the modem VPN works fine but with the router it doesnt.

my firmware version is the 1.9.2.7 downloaded from the ASUS website.

I just dont know what to do, i hope some one can solve my problem.

The internet connection is trew DHCP.

Like Wiz says, PPTP should be no problem. But if you use L2TP then the server must support NAT traversel, of not, you're out of luck I'm afraid....

Do you know which protocol of client your father uses?

vlek
23-03-2005, 21:47
well when i looked at the connection details it sais it is a PPTP vpn

so it is connected to vpn but i cant get on the harddrives. It only works when I connect my fathers computer straight to the cable modem.

But then I dont have internet and thats a problem :p


Update with the firmware version of wiz it still does not work :<

Kitsok
24-03-2005, 08:04
If I understood you right, you have PC connected somehow to WL-500g with private address, WL-500g is connected to Internet and everything works fine through NAT.

After that you establish VPN connection from your PC to external computer through WLs' NAT and connection is established.

But after that you can not reach computer through VPN connection?
Check routing table on PC. You probably will find two(2) default routes - one to WL-500g and another one to VPN connection.

If all my guesses right than you have to customize routing table on your PC which means - remove default gateway to VPN connection and add network-based or even host-based routes.

Styno
24-03-2005, 08:42
Also, PPTP works through the Asus right out of the box, you don't need to forward anything at all. Maybe your previous effords are breaking up now, so perhaps you need to cleanup the setup on the Asus and try again.