PDA

Bekijk de volledige versie : Enabling dropbear sshd ?



puppet master
21-03-2005, 16:57
Hi,

I just bought a wl500gx, and I'm discovering all the possibilities this little toy can offer.

I'm trying to enable the dropbear ssh server, but the instructions found on the wiki ( http://wiki.wl500g.info/index.php/PackageDropbear ) doesn't seem to apply to my firmware (1.9.2.7-4), as I don't have any "/init" directory :confused:

Of course, I tried searching the forum, the wiki, and my best friend google.

Am I missing something ?

Thanx for your help

Styno
21-03-2005, 18:13
Well, wiki pages are a bit outdated (They were built in the 1.7.5.x era).

Just use the wiki as a hint to your solution. If you have the urge to correct them: please do.

/usr/sbin/dropbearkey

puppet master
21-03-2005, 19:36
Well, wiki pages are a bit outdated (They were built in the 1.7.5.x era).

Just use the wiki as a hint to your solution. If you have the urge to correct them: please do.

/usr/sbin/dropbearkey

Thank you for your hint.
I managed to enable sshd at boot time, and updated the wiki page.

guti
03-07-2007, 10:46
ok, I'm trying to follow the Wiki to set up dropbear. Here is where I get stuck:


5. If the test is successfull you will need to add /usr/sbin/dropbear to /usr/local/sbin/post-boot
6. If you want SSH WAN access add: iptables -A INPUT -p tcp --dport 22 --syn -j ACCEPT to your /usr/local/sbin/post-firewall script

There is no directory /usr/local/sbin on my WL-500g (Firmware Olec's 1.9.2.7).

I would like to update the wiki, can anyone let my know what the right directory is?

al37919
03-07-2007, 18:22
Probably, you should read more general tutorial on initial setting up of the router. E.g. this one:
http://wl500g.info/showthread.php?t=5909
AFAIK, the difference between setting up of 500gP and 500g is minimal (just avoid doing something mentioned there related to memory size)