PDA

Bekijk de volledige versie : How do I disable the built-in caching DNS server?



madoka
19-03-2005, 01:44
To moderators: I mistakenly posted this in the HowTo forum, and scratched my head for the next 1/2 hour wondering why it didn't show up. I'm sorry for my confusion :o

Is there a way to disable the caching DNS server that WL-500g runs, so that machines behind it gets the nameserver address given by the ISP? I'm using stock 1.8.2.4 firmware.

The built-in DNS server is just not reliable and behaves incorrectly at times; for example, it always resolves a hostname to the same IP even if multiple IPs are bound to it (common in mirrored sites). This means that if I happen to hit a bad mirror, I will always hit it until I reset the router.

Also, my ISP's primary nameserver is unstable, which is probably why they set up a secondary and tertiary nameserver as well. Usually at least one of them is responsive. When the primary nameserver is down, however, it takes WL-500g a long time to try the other two--almost always longer than the timeout period of whatever program I'm running. WinXP seems to switch over much faster.

Finally, sometimes the caching DNS server will just stop responding if the router's under heavy load. It happens when I back up my laptop HD with partimage over the network.

Right now, I just manually configure the DNS server addresses, but I'd prefer not doing that. There is always a slight chance that my ISP would change the nameservers' IPs in the future.

jago25_98
21-03-2005, 15:20
ssh in and look for (i think) named / dns:

ps aux |grep named
ps aux |grep dns

and kill that process with killall.

then try to find how it gets started on bootup

that's all i'll say

Styno
21-03-2005, 15:24
To moderators: I mistakenly posted this in the HowTo forum, and scratched my head for the next 1/2 hour wondering why it didn't show up. I'm sorry for my confusion :oNo problem. One click and it was removed from the face of the earth. Never to be found again... :D

You're not alone when it comes to making that mistake, hehe

hugo
21-03-2005, 16:18
ssh in and look for (i think) named / dns:

ps aux |grep named
ps aux |grep dns

and kill that process with killall.

then try to find how it gets started on bootup

that's all i'll say
I think we are working on a different beast here than a common linux distro.

You can choose to kill the dnsmasq process, but you have to do this from the secret admin webpage (search the forum for adress) by typing killall dnsmasq, then click on refresh (not enter)
Using a custom firmware, you could remove it from a post-boot script.

You will lose DHCP fonctionality with this setup.

You can also try to configure in DHCP settings, or on your PC directly the requested DNS. Go for the web interface, and setup the DNS in the DHCP config panel.
You can also modify /etc/resolv.conf to remove the local ip adress. This would be a bit awkward from the hidden admin page, so I would suggest you to use a custom firmware for a more flexible setup.