PDA

Bekijk de volledige versie : Firmware to use wl300g as client



miraculix
04-03-2005, 14:55
Hi,
I just got a new ap (belkin pre-n) an i want to use my old ASUS WL300g as a client i the wifi network. (Insted of bying a wifi game adaptor). Is there any firmware that supports this on wl300g? Also I wounder if it is possible to use a wl500g firmware or if that would turn my wl300g into a brick?

Oleg
04-03-2005, 15:05
At the moment only custom firmware support this. Visit this page to get one: http://oleg.wl500g.info/

miraculix
04-03-2005, 17:34
Thanx for the fast reply. I will try to flash WL300g-1.9.2.7-3c.trx can I use ASUS tools to downgrade to erlier fw ver?

Oleg
04-03-2005, 20:24
Sure, firmware restoration tool does not care of versions.

miraculix
07-03-2005, 15:21
Now I have upgraded my router using the custom fw WL300g-1.9.2.7-3c.trx. But I still have some problem getting it to work. My setup in the ASUS router is AP and bridge mode. If i run my WiFi net work as open i get a connection to the belkin router and i get a ipaddress on my ASUS router from DHCP on Belkin. But if i try to set upp security on my WiFi net it breaks down. My ASUS just keeps saying connecting.... I have tried to use WPA-PSK / TKIP and also WPA-PSK / AES but none of them works. I have surfed the forum for info on how to trubbleshoot this from linuxconsole to get more info but it didn't make me any smarter (I'm no linux guru :o ) I use cut and paste from USB Stick on my settings so I'm sertin that the passphrase is correct. Do you have any tips for me on how to continue?

Oleg
08-03-2005, 20:57
Have you tried WEP? Most likely you've some sort of incompatibility with belkin device...

miraculix
09-05-2005, 09:14
Currently using fw WL300g-1.9.2.7-4.trx (Saw that you released WL300g-1.9.2.7-5.trx but have not flashed it yet).

I was able to do the following:

1. Open system is working - Router joins the "MyWifiNet" automaticly on boot.
2. WEP 64bit is working - Router joins the "MyWifiNet" automaticly on boot.
3. WEP 128bit is working - Router joins the "MyWifiNet" automaticly on boot.
4. WPA-PSK partualy working - Router logg is saying connecting to MyWifiNet on boot but nerver succeds in joining after boot. If i telnet to the router an write the following command
wl join "MyWifiNet" imode bss amode wpapsk it joins correctly and everything works fine. I can do with this but my girlfriend is not telnet friendly so I need to fix this. She keeps nagging. I never shutoff the router an it only seems to need a reboot when I'm not at home. Any suggestions?

this is my set up

[xbox] <-x-> <[ASUSWL300G]> <<<wifi>>> <[BelkinPRE-N]> <---> {internet}

Oleg
09-05-2005, 09:55
ok, this seems should fix WPA-PSK in the client mode. I will prepare test firmware for you.

Oleg
09-05-2005, 09:56
btw, could you please run


nvram get wl0_auth_mode
nvram get wl0_join

and post results? You may need to remove your PSK key.

miraculix
09-05-2005, 10:34
I will do that as soon as I get home from work :-)

btw
I'm using bridgemode to connect (forgot to write that) now.

this is my set up.

[xbox] <-crossoverkabel-> <[ASUSWL300G]> <<<wifi>>> <[BelkinPRE-N]> <-networkcabel-> {internet ADSL2+}

miraculix
09-05-2005, 10:50
I was browsing around in the wl500g howto forum an read about some post-boot script. Would this be a possible workaround?


echo "wl join "MyWifiNet" imode bss amode wpapsk" >> /usr/local/sbin/post-boot

flashfs save
flashfs commit
flashfs enable

Oleg
09-05-2005, 11:20
I was browsing around in the wl500g howto forum an read about some post-boot script. Would this be a possible workaround?


echo "wl join "MyWifiNet" imode bss amode wpapsk" >> /usr/local/sbin/post-boot

flashfs save
flashfs commit
flashfs enable
Your post-boot should look like this:


#!/bin/sh
nvram set wl0_join="wl join MyWifiNet imode bss amode wpapsk"

This way it should even reconnect automatically.

miraculix
09-05-2005, 12:35
Ok when I get home I will try that also! :)

I've attached my settings save file if that is to any help for U ;)

miraculix
09-05-2005, 18:56
Well, I'm home from work and continuing!
I started with a firmware update to the latest 1.9.2.7-5 firmware. Tried a reboot to see if it magicly started to work. But no still the same.
Checked the two commands you asked about and this is the printout

[admin@(none) root]$ nvram get wl0_auth_mode
none
[admin@(none) root]$ nvram get wl0_join
wl join "MyWifiNet" imode bss amode open

I think you have found the problem but what do i do about it?

Also i tried to find the /usr/local/sbin/post-boot file to check what it says but I could not find it i do not even have a /usr/local/sbin katalog. should i create one and put the file in it?

Thanx for the help also I saw the now commandline interface in the webgui it works nicely for input but i do not get any output??!!?? :o

Oleg
09-05-2005, 19:14
I think you have found the problem but what do i do about it?

Also i tried to find the /usr/local/sbin/post-boot file to check what it says but I could not find it i do not even have a /usr/local/sbin katalog. should i create one and put the file in it?

Create directory and post-boot according to samples on my page.


Thanx for the help also I saw the now commandline interface in the webgui it works nicely for input but i do not get any output??!!?? :o
Press Refresh instead of enter.

miraculix
10-05-2005, 07:09
Ok! So I wasn't able to compleate the testings yesterday I got stuck on how to use vi to create the post-boot file but I'm going to readup on my vi skills during the day and have another go tonight. But thank U Oleg for the help I'm sure it will work now. I will post the results. :)

miraculix
10-05-2005, 14:43
Your post-boot should look like this:


#!/bin/sh
nvram set wl0_join="wl join MyWifiNet imode bss amode wpapsk"

This way it should even reconnect automatically.

Ok! I think i got the hang on VI so as soon as I get home I will try this. But I've got another stupid question first should both lines be in the post-boot file?

:o :o :o

Oleg
10-05-2005, 14:56
yes, both lines and remember to chmod it.

miraculix
10-05-2005, 15:13
Thanx
I also need to do

flashfs save
flashfs commit
flashfs enable
Right?

Oleg
10-05-2005, 17:26
yes, as stated on my page.

Oleg
10-05-2005, 18:05
please try this firmware (http://wl500g.dyndns.org/WL500g-1.9.2.7-5a-pre1.trx) it should work with wpa-psk out of the box.

miraculix
10-05-2005, 18:14
Thanx for youre excelent support Oleg. I got the post-boot script to work now.
I'm very greatfull :) :) :) :) :) :D :D :D :D

Does that new firmware work on my wl300g it says WL500G in the file name!? If you say that it works i will try it :)

Oleg
10-05-2005, 19:01
Ok, wl300g firmware (http://wl500g.dyndns.org/WL300g-1.9.2.7-5a-pre1.trx).

miraculix
10-05-2005, 19:37
Thanx again Oleg the new firmware is now on and everithing is working out-of-the-box.

:) :D :)

What would I do if it wasn't for people like you! Keep up the good work!!

OLEG YOU ROCK!!!!!!!

Next up kai-station............do you think it's possible on a wl300g???........ but that will be another thread

nico1980
24-05-2005, 09:35
I've got also the latest OLEG firmware, but when i set the 2 x 300G boxes to WDS (Bridge) i get a lot of time-outs when i sent a big package (ping -t -l 25000 192.168.168.5) 10xis good then 1xtimeout and so on.
The Asus firmware 1.8.1.9 works better in brdige..

Tried almost every setting of channel and power.
No WEP or whatsoever (only MAC filter)

Please help!

miraculix
01-06-2005, 09:55
I don't realy know what you are asking. In my configuration I do not use WDS. My belkin pre-n is connected to internet and set up as a homegw with firewall. My asus 300g is set up as ap in bridgemode. All wireless devices connects to the belkin.