PDA

Bekijk de volledige versie : How do I install Twonky ? ( newbie)



lifeisfun
02-01-2009, 15:27
I recently found this post on how to install Twonky on wl500w using factory FW:
http://www.twonkyforum.com/viewtopic.php?f=8&t=4094

Ok As I have found a solution. I will post here for other.

In fact it was quite easy. WL-ASUS 500W needs a different build. You should take MIPS little endian glibc 2.2.3. Extract it to you your attached drive. Correct all paths in the ini files. Then make a startup script, for example init.sh, which contains


#!/bin/sh
route add -net 224.0.0.0 netmask 240.0.0.0 dev br0

cd /tmp/harddisk/part0/twonkyvision
/tmp/harddisk/part0/twonkyvision/twonkymedia &


This part I can't figure out :confused:
and then put this init.sh in the USB Section /Initial script. Reboot and that should work fine.

Disable the built-in Media server before. tested with firmware 1.9.8.2 and twonky 4.4.2.



Unfortunatelly I'm having hard time to do so since I'm not Linux GURU like most of you here. Can you guys give me some advice ?
I tried to contact the original poster but I doubt that I'll get any response

Thanks

QMax
02-01-2009, 16:16
Where did you found Twonky for Asus ?
It seems they removed from server, leaving only binary for Win, Linux and Mac.

Thanks

Max

lifeisfun
02-01-2009, 16:26
I downloaded this file : twonkymedia-mipsel-glibc-2.2.3.zip
Here: http://www.dreamboxfile.com/DM7025/Plugins/Upnp_client___server_for_DM7025.html

QMax
02-01-2009, 16:34
Thanks for the link.
Now I have to understand how they can sell a license for un unsupported software... :)

PS: actually I'm running WizD with no problems at all. but this one is also unsupported anymore...

Max

lifeisfun
02-01-2009, 17:01
WizD is also DNLA compatible ?

Thanks

QMax
02-01-2009, 17:20
Sorry, don't know.
I use WizD with my Syabas media player.

Max

lifeisfun
12-01-2009, 11:46
The download link is back:
http://www.twonkyforum.com/unsupported/4.4.11/

wpte
12-01-2009, 16:46
The download lik is back:
http://www.twonkyforum.com/unsupported/4.4.11/

nice:D
http://www.twonkyforum.com/unsupported/4.4.11/twonkymedia-mipsel-uclibc-0.9.28-4.4.11-20090108.zip

but you do need some sort of license for this right?
can you still buy one?:)

lifeisfun
12-01-2009, 19:59
I guess so, I didn't even managed to install it :(