PDA

Bekijk de volledige versie : New firmware - dnsmasq



Oleg
15-03-2004, 12:15
Guys, I've prepared the new firmware version. WebCam stuff not tested, so please check it and let me know if something wrong with it.

Differences with previous: Replaced dproxy & udhcpd with dnsmasq to support both static leases and dhcp/dns integration (so you can now resolve host names based on their dhcp names); replaced kernel modules with 2.4.20 version except the printing stuff (webcam stuff not verified!)
In order to use static leases/hosts you will need to perform this steps:
1. Connect to router using telnet;
2. Write the static hosts count & entries to the flash (use /etc/hosts format)
nvram set etc_hosts=3
nvram set etc_hosts0="192.168.1.1 wl500g"
nvram set etc_hosts1="192.168.1.2 laptop"
nvram set etc_hosts2="192.168.1.3 foo"

3. Write the static leases (use /etc/ethers format)
nvram set etc_ethers=2
nvram set etc_ethers0="00:11:22:33:44:55 192.168.1.2"
nvram set etc_ethers1="00:11:22:33:44:56 192.168.1.3"

3a. Also it is a good idea to change the DHCP server settings to not include addresses specified for static leases
4. Commit the changes using
nvram commit
5. Reboot the rooter using
reboot

New custom firmware http://jaffar.cs.msu.su/wl500g/wl500g-1.6.5.3-5.trx and accompanying sources http://jaffar.cs.msu.su/wl500g/wl500g-1.6.5.3-5.tar.bz2 (10 MBytes) for building it.

Technik
18-03-2004, 03:45
Originally posted by Oleg
Guys, I've prepared the new firmware version. WebCam stuff not tested, so please check it and let me know if something wrong with it.

Oleg, thanks a lot for the new version! :) I have just tested it with my Creative Labs WebCam 3. It seems the behaviour is the same as I described couple months ago. The problem with WebCam initialization during reboot still persists.

...
...
br0: topology change detected, propagating
lp0: using parport0 (polling).
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xb8004000, IRQ 2
usb-ohci.c: usb-00:04.0, PCI device 14e4:4715
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver usblp
printer.c: v0.11: USB Printer Device Class driver
Linux video capture interface: v1.00
hub.c: new USB device 00:04.0-1, assigned address 2
usb.c: USB device not accepting new address=2 (error=-145)
hub.c: new USB device 00:04.0-1, assigned address 3
usb.c: USB device not accepting new address=3 (error=-145)
SCSI subsystem driver Revision: 1.00
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
lp driver: get device ID
neg fail
Register User Space Key Handler : 436 0

# WebCam disconnected and plugged again to router:

hub.c: new USB device 00:04.0-1, assigned address 4
usb.c: USB device 4 (vend/prod 0x5a9/0x511) is not claimed by any active driver.
i2c-core.o: i2c core module
usb.c: registered new driver ov511
ov511.c: USB OV511 video device found
ov511.c: model: Creative Labs WebCam 3
ov511.c: Sensor is an OV7610
ov511.c: Device registered on minor 0
ov511.c: v1.61 for Linux 2.4 : ov511 USB Camera Driver
~ #


361 admin SW [khubd]
412 admin 416 S /sbin/lpd
413 admin 456 S /sbin/infosvr br0
416 admin 420 S /bin/sh /init/rc.watchdog ROUTER
436 admin 572 S /usr/sbin/watchdog 30 131.107.1.10 MEZ-1MESZ 0 0 0 0
452 admin 452 S -sh
514 admin 1684 R /usr/sbin/rcamd -m 100 -c 100 -f 640x480 -p 7777 -s 0
515 admin 1684 S /usr/sbin/rcamd -m 100 -c 100 -f 640x480 -p 7777 -s 0
516 admin 1684 S /usr/sbin/rcamd -m 100 -c 100 -f 640x480 -p 7777 -s 0
530 admin 312 R ps

Oleg
18-03-2004, 10:09
Good news is what it works. :) As for reboot - the problem is not with the cam driver, but with usb subsystem. It's seems drivers timed out waiting for cam - possibly cam still initializing when linux queries it...

fabiosantos
19-03-2004, 15:23
Hey folks,
First of all, congratulations on your great work Oleg! I was looking for addver to make my custom fw work, and found this forum, that was awesome! :D
I got the -2 version of Oleg's work, and installed it yesterday, and my site is offline today, I would find ou what heappened, as soon as I get home, but I guess the pppoe went down becouse of the idle connection... never heappened before, but now I have the telnet to inspect it ;)
My main aim on trying to make a custom fw was to make an watchdog to the connection. My isp disconnect me from 12 to 12hr, to compute the traffic accounting, normally my 500g detect and reconect it, but, in 1% of the ocurrences it doesnt notice that the connection was dropped and I get offline till a cold reboot take place. Usually I can check it every night, but last time it was up for more than 90 days, and gone down when I was in vacation 10.000km from home, and found myself without email server :mad:
I would ask if someone knows how the reconnection takes place? Its about the watchdog ? Or some kind of dial on demand? I'm reading all those scripts in the filesystem, but its not so clear yet... I've seem pppoecd on watchdog.conf, but it doesnt seem to reboot when the connection is dropped...
I'm planning to put a ping default router from time to time, and kill ppoecd if it fails... any better tip?
Another issue is about the upnp, it seems to dont work very well... I havent tryied with the last fw from Oleg yet, but heard from some friends that upnp on linksys routers works much better!

I wrote to much I guess...
Cya guys arround...
Fábio.

Oleg
19-03-2004, 15:56
I'm recommending you to update to 1.6.5.3-5 version - previous does not work correctly due to changes in busybox default PATH.
As for watchdog - it's monitoring the existance of the processes listed in the watchdog.conf and does do anything for reconnect.
As for connection/reconnection all the stuff are controlled by pppoecd daemon which is the pppd with pppoe plagin in fact.
As for your problem - pppd daemon is the weird thing... You can dig onto it using linksys wrt54 sources. The simplest solution is to write the script which will ping the default dns server or something and reboot if it can't reach it for some period of time.

Regards,
Oleg.

fabiosantos
19-03-2004, 22:24
Hey Oleg,
In order to do such changes I would like to customize your -5 version, and would like to know which are the sizes of vmlinuz and cramfs...
Actualy I could figured it out if the kernel was the same as original and knowing its size and trailler size, but as an fc said the kernel has been modified I dont know its correct size...
Could you tell us ?
Thanx a lot!:D
Fabio.

Oleg
20-03-2004, 10:23
Kernel are left as is - it's from the ASUS firmware. But anyway I'm suggesting you to download the firmware sources and modify them rather than do packing/unpacking. The Makefile will add the required things to your firmware.
You can also try tools provided by RCR and available here - http://files.wl500g.info/asus/wl500g/firmware/app/wltools-1.tgz