PDA

Bekijk de volledige versie : Samba 2.2.12 - Festplatte wacht immer auf



marrrtin
15-09-2008, 14:23
Seit ich per ipkg Samba 2.2.12 auf den WL500GP installiert habe, wacht meine angeschlossene Festplatte alle 11 Minuten auf. Zuvor (also vor Samba 2.2.12) konnte ich sie per scsi-stop bei Nichtnutzung schlafen legen.

Frage 1: Kann ich das irgendwie wieder lösen? Ich möchte nicht, dass die Platte ständig läuft.

Frage 2: Wieso wacht die Platte exakt nach 11 Minuten auf? Irgendwas muss da doch im Gange sein?

wengi
15-09-2008, 15:06
Moin,

Meine vermutung wäre der nmbd, der als workgroup master arbeiten will und im Zweifelsfall ins syslog schreibt.

Kontrolliere mal syslog und die samba logs.

wengi

marrrtin
15-09-2008, 15:21
Das mit dem workgroup master stimmt wohl, allerdings ist das auch der letzte Eintrag im Log. Im Syslog steht seit 3 Tagen weder was von smbd noch nmbd.

Ich schaue mal, wie sich das ohne nmdb verhält...

marrrtin
18-09-2008, 19:22
Tatsächlich: Ohne nmbd wacht die Festplatte nur dann auf, wenn sie es soll. Blöd nur, dass das Ganze dann auch nicht wirklich viel Nutzen hat...

Welche Möglichkeiten habe ich, dieses Verhalten von nmbd zu deaktivieren?

pc-nico
19-09-2008, 07:46
ich versuchs mal....

wenn local master in der smb.conf auf yes gesetzt ist, versucht der nmbd an der
Wahl zum Master Browser teilzunehmen. Je nach OS Level gewinnt er oder eben
ein andere Rechner im Netz. (Mal nach Master Browser google´n für mehr Infos....)

Diese Wahl wird in gewissen Abständen wiederholt... (in der regel dann wenn
ein neuer Rechner sich im Netz "meldet" und glaubt master browser werden zu können....)

Also einfach mal die smb.conf posten, dann kann man mal gucken.
Gibt es weitere Samba Server im Netz? Wenn ja sollte nicht bei 2 Server gleichzeitig
preferred master auf yes gesetzt sein, da es sonst zu periodischen Neuwahlen
kommen kann...Wenn Samba gar nicht an der Wahl teilnehmen soll, local master
auf no setzen....

marrrtin
22-09-2008, 15:13
Hier die smb.conf. Alle Master-Einträge sind entweder auf "no" oder komplett auskommentiert. Es existiert ein weiterer Samba-Server im Netz (2.0.12).

Ich würde ja nmbd weglassen, so wacht die Platte ja nur auf wenn ich sie brauche. Allerdings kann ich dann nicht von Vista drauf zugreifen (Von XP aus geht es aber auch ohne nmdb problemlos). Wenn Vista sich wie XP verhalten würde wäre also alles kein Problem...



#======================= Global Settings =====================================
[global]
[...]

guest account = nobody
log file = /opt/var/log/samba/log.%m
max log size = 50
security = share
encrypt passwords = no

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
; os level = 33

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
; domain master = yes

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
; preferred master = yes

# Use only if you have an NT server on your network that has been
# configured at install time to be a primary domain controller.
; domain controller = <NT-Domain-Controller-SMBName>


#============================ Share Definitions ==============================
[...]

pc-nico
23-09-2008, 10:02
ok, dann setz mal bitte (explizit) preferred master auf no am Router... und probier das ganze nochmal aus.... das könnte das Problem dann wirklich beheben
wenn noch ein 2ter SMB im Netz vorhanden ist....

(Den nmbd nicht zu starten ist keine Lösung... er ist für das Browsing zuständig...)

marrrtin
23-09-2008, 15:26
Eben getestet: preferred master steht auf no (alle anderen master-Einträge auch), geholfen hat es wenig... Siehe scsi-stop.log. Ab dem zweiten Eintrag war nmbd wieder aktiv, ich selber habe auf die Platte nicht zugegriffen:


15:02:10: Disk first used after 299910 seconds
15:07:41: Disk first used after 150 seconds
15:09:12: Disk first used after 30 seconds
15:17:44: Disk first used after 420 seconds
15:28:46: Disk first used after 600 seconds
15:36:18: Disk first used after 330 seconds
15:40:49: Disk first used after 210 seconds
15:43:50: Disk first used after 120 seconds
15:47:51: Disk first used after 180 seconds
15:52:52: Disk first used after 240 seconds
15:58:53: Disk first used after 300 seconds
16:05:55: Disk first used after 360 seconds
16:07:56: Disk first used after 60 seconds
16:13:57: Disk first used after 300 seconds


Interessant sind doch die ziemlich "glatten" Werte.

Ich dachte zwischendurch, dass da irgendwas in Logfiles geschrieben würde, aber die liegen alle in /tmp

marrrtin
26-09-2008, 21:59
So: Hab jetzt einfach mal auf die integrierte Samba-Version gewechselt die zuvor nicht mit Samba laufen wollte, benutze aber die smb.conf der neueren IPKG-Version. Und siehe da: Es klappt auch mit Vista, und da die integrierten smbd und nmbd im Flash liegen wird die Festplatte nicht unnötig geweckt.

Was für eine Zeitverschwendung ;-) Danke allen für die Mithilfe.