PDA

Bekijk de volledige versie : WL-HDD as WebServer??



fstolle
24-01-2005, 08:39
Hi WL-HDD Freaks,
im new here and ive found this forum via google.
Ive one small question about the WL-HDD.
Is it possible to use the hdd as webserver with another firmware??
I only have ftp access to the device. Does anybody know a solution for this problem?
Thanks.
Frank

hugo
24-01-2005, 09:29
yes it's possible. Please search the forum for thttpd and custom firmwares

fstolle
24-01-2005, 20:19
Hi Hugo and thanks for the fast answer.
For better understanding. I only have to copy the linux files as per description in /tmp to part1 and execute the init.sh. ?
My firmware now is the 1.2.3.0. Is it possible to keep this firmware with the procedure without change to 1.2.2.8?
Thanks
Frank

Styno
25-01-2005, 09:19
Hmm, I didn't see the init.sh anywhere in the thttpd tarballs. I just extracted them, replaced the binaries with the latest from the same thread, edited my config file, added a startup command to /usr/local/sbin/post-boot (you need to use the flashfs method for that) and that was about it.

Please note: The filenames are case sensitive, so you need to keep them intact.

fstolle
25-01-2005, 16:39
Hmm
do we talk about the wl-hdd or wl-500 ??
I only find something about thttpd in the wl-500 forum?!?
Frank

hugo
25-01-2005, 17:05
both, file are compiled staticaly.

fstolle
25-01-2005, 21:00
Hi,
i can do what i want but my webserver doesnt work.
I installed the linux files as described and edit the configurations files.
I flashed the firmware from 1.2.3.0 to 1.2.2.8 custom but my webserver doesnt work.
Does anybody here has a step by step manual for me?
What the hell is wrong with my wl-hdd. ( or with me ).
Please help. All i want is a small webserver running on my wl-hdd.
Thanks
Frank

hugo
25-01-2005, 21:15
You can download full busybox (search the wiki) and run it if you want a small webserver. Your best option is to flash Oleg's latest firmware http://wl500g.dyndns.org/1.9.2.7-3b/WLHDD-1.9.2.7-3b.trx

You will be able to set up your web server after that. You will have to mount your partition manually before accessing the HD.

Styno
26-01-2005, 10:26
Well, yes, I run the webserver on my WL-500g but if you run a firmware from Oleg you can probably run it on the WL-HDD as well.

But noone can help you if you don't supply any detailed info: You only say it doesn't work. Please post the error codes and the steps you've done allready.

fstolle
26-01-2005, 11:10
I did exactly what was in the readme file.

copy the files tmp.rar and conf.tar.gz to the root directory of the part1 share
4) unrar the file tmp.rar to /tmp (!! be careful: the files should be in /tmp *not* in /tmp/tmp !!) --> OK

5) open the "backdoor" webpage in your browser: http://192.168.1.220/Main_AdmStatus_Content.asp (username=admin, password=admin) --> OK

6) copy the following command to the "System Command" textbox and then click the "Refresh" button:
chmod a+x /tmp/harddisk/part1/tmp/busybox --> OK

7) copy the following command to the "System Command" textbox and then click the "Refresh" button:
chmod a+x /tmp/harddisk/part1/tmp/telnetd --> OK

8) copy the following command to the "System Command" textbox and then click the "Refresh" button:
ln -s /tmp/harddisk/part1/tmp/busybox /tmp/harddisk/part1/tmp/sh --> OK

9) copy the following command to the "System Command" textbox and then click the "Refresh" button:
/tmp/harddisk/part1/tmp/telnetd -d -l /tmp/harddisk/part1/tmp/sh --> OK
10) the previous command started the telnet daemon and now you can access it from your PC with: telnet 192.168.1.220 !!i use 192.168.0.220 !!

11) on the prompt type:
cd /tmp/harddisk/part1 --> OK

12) enter the command:
tmp/busybox tar xzvf conf.tar.gz --> OK

13) all necessary files are now installed on the harddisk and now you flash the new firmware WLHDD_1.1.2.8-JockyW-1.0_en.trx on your WL-HDD
Sometimes it works, sometimes not. Error could not write firmware.etc.

14) wait until flashing is done and until the Asus has rebooted itself

15) congratulations! you (hopefully) made it :D

After restart the power led is blinking. Ok Filesystem inconsistent. No way out. Check filesystem. wait wait wait reboot after checking--> same problem. Filesystem inconsistent.
When i go back and flash the ASUS firmware 1.2.2.3 everything is ok.

I had 4 partitions on my hdd but after sucsessful flashing i only have 2. Part 3 and 4 are disappeared.

2. problem. How i get access to the webserver. I edit the "export" configuration file and set the right folders. --> oK
Did i forgot something?? Perhaps to mount the device? If yes, how ?

Well then??
I need a description what i have to do after flashing the hdd. Far better a step by step manual.

Does anybody have such a description for rookies :-)
Thanks
Frank

Antiloop
26-01-2005, 13:28
After restart the power led is blinking. Ok Filesystem inconsistent. No way out. Check filesystem. wait wait wait reboot after checking--> same problem. Filesystem inconsistent.
When i go back and flash the ASUS firmware 1.2.2.3 everything is ok.


can you access the device?
if yes, just ignore it?
and proceed

fstolle
27-01-2005, 07:28
Hi,
thanks for all your proposals but i think it doesnt work. I dont know why.
Yes i have access to the drive when the LED is blinking.
How do i get access from the WAN ? Wich folder is for the WAN pages?
Thanks
Frank