PDA

Bekijk de volledige versie : [Problem] NFS Server und Client



thejew
31-07-2008, 13:52
Ich möchte 2 wl500gp router über eine OpenVPN verbindung gegenseitig ihre shares mounten lassen können.

Was ich bisher gemacht habe:

1. Openvpn funktioniert wunderbar (ping, andere services etc.)
2. Im webinterface den NFS server aktiviert.
3. folgendes in die export list eingefügt:
/opt/storage 10.8.0.6(rw,async,no_root_squash)
Mein verständnis: /freigabe OP.EN.VPN.IP(screibzugriff etc)
4. versucht die freigabe zu mounten: mount 10.8.0.1:/opt/storage /opt/test
volgende fehlermeldung:

mount: 10.8.0.1:/opt/storage failed, reason given by server: Permission denied
mount: nfsmount failed: Bad file descriptor
mount: Mounting 10.8.0.1:/opt/storage on /opt/storage/test failed: Bad file descriptor


5. So wie ich das verstehe kann man mt dem showmount befehl überprüfen ob die freigaben angezeigt werden: showmount 10.8.0.1 -e (auf dem NFS Server)
bekomme allerdings folgende anwort:

[admin@myasus root]$ showmount 10.8.0.1 -e
Export list for 10.8.0.1:
[admin@myasus root]$



sieht für mich so aus als würde auf dem server die freigabe schon schief laufen...
Jemand eine Idee was da das problem sein könnte?


OK .... Bin jetzt schon ein bischen weiter hab einfach nochmal den NFS Server neugestartet ( killall mountd
/usr/sbin/mountd ) wie es hier irgendwo im forum beschireben ist und meine shares tauchen auf bei showmount. Totzdem will der client noch nicht so richtig
folgende ausgabe:


[admin@asus storage]$ mount 10.8.0.1:/opt/storage /opt/storage/test
mount: Mounting 10.8.0.1:/opt/storage on /opt/storage/test failed: No such device

der client sieht übrigens auch die showmount liste

thejew
31-07-2008, 14:13
problemm gelöst der client braucht noch folgende module:
insmod sunrpc
insmod lockd
insmod nfsd
insmod nfs

showmount -e localhost