PDA

Bekijk de volledige versie : WL-HDD Festplatte wird nicht mehr erkannt



bugmenot
29-07-2008, 21:03
Guten Abend,

ich habe mir vor einiger Zeit ein Yakumo Wireless Storage 60 gekauft. Da keine Festplatte mitgeliefert wurde habe ich erstmal eine 30GB Festplatte angeschlossen und erfolgreich Ordner/Daten dort abgelegt. Auch das Upgrade zu Olegs Firmware klappte problemlos. So nun zu meinem Problem, nachdem ich das ganze nun ein paar Wochen rumlag (ohne Stromversorgung) ist die Festplatte nicht mehr zu sehen. :(

Die Festplatte taucht weder im Windows-Explorer noch in der Konfigurationsseite auf (Status-Seite). Habe die Festplatte an einem anderen Rechner getestet auch nochmal neuformatiert (Fat, ext3, unformatiert) und die Firmware neudraufgespielt, ohne Erfolg. :(

Ist das ein Bug oder hat jemand ne Ahnung woran das liegt, bzw. wie ich das beheben kann? :confused: Ansonsten funktioniert das Ding ohne Probleme...

Danke!

wengi
30-07-2008, 07:07
Hi,

Taucht die Platte unter /dev/discs auf?
Poste mal das Syslog nach einem boot.

wengi

bugmenot
30-07-2008, 20:17
Hi,

habe mir das Logfile schon angeschaut, aber so ganz blicke ich da nicht durch, vielleicht findest du ja gleich die Lösung.
Firmware 1.9.2.7-7g

Jan 1 00:00:03 syslogd started: BusyBox v1.1.3
Jan 1 00:00:03 kernel: Loading BCM4710 MMU routines.
Jan 1 00:00:03 kernel: Primary instruction cache 8kb, linesize 16 bytes (2 ways)
Jan 1 00:00:03 kernel: Primary data cache 4kb, linesize 16 bytes (2 ways)
Jan 1 00:00:03 kernel: Linux version 2.4.20 (root@omnibook) (gcc version 3.2.3 with Broadcom modifications) #75 Fri Apr 6 00:12:23 MSD 2007
Jan 1 00:00:03 kernel: Setting the PFC value as 0x15
Jan 1 00:00:03 kernel: Determined physical RAM map:
Jan 1 00:00:03 kernel: memory: 01000000 @ 00000000 (usable)
Jan 1 00:00:03 kernel: On node 0 totalpages: 4096
Jan 1 00:00:03 kernel: zone(0): 4096 pages.
Jan 1 00:00:03 kernel: zone(1): 0 pages.
Jan 1 00:00:03 kernel: zone(2): 0 pages.
Jan 1 00:00:03 kernel: Kernel command line: root=/dev/mtdblock2 noinitrd init=/linuxrc console=ttyS0,115200
Jan 1 00:00:03 kernel: CPU: BCM4710 rev 0 at 125 MHz
Jan 1 00:00:03 kernel: !unable to setup serial console!
Jan 1 00:00:03 kernel: Calibrating delay loop... 82.94 BogoMIPS
Jan 1 00:00:03 kernel: Memory: 13840k/16384k available (1799k kernel code, 2544k reserved, 248k data, 68k init, 0k highmem)
Jan 1 00:00:03 kernel: Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Jan 1 00:00:03 kernel: Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
Jan 1 00:00:03 kernel: Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Jan 1 00:00:03 kernel: Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Jan 1 00:00:03 kernel: Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
Jan 1 00:00:03 kernel: Checking for 'wait' instruction... unavailable.
Jan 1 00:00:03 kernel: POSIX conformance testing by UNIFIX
Jan 1 00:00:03 kernel: PCI: Fixing up bus 0
Jan 1 00:00:03 kernel: PCI: Fixing up bridge
Jan 1 00:00:03 kernel: PCI: Fixing up bus 1
Jan 1 00:00:03 kernel: Linux NET4.0 for Linux 2.4
Jan 1 00:00:03 kernel: Based upon Swansea University Computer Society NET3.039
Jan 1 00:00:03 kernel: Initializing RT netlink socket
Jan 1 00:00:03 kernel: Starting kswapd
Jan 1 00:00:03 kernel: Journalled Block Device driver loaded
Jan 1 00:00:03 kernel: devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
Jan 1 00:00:03 kernel: devfs: boot_options: 0x1
Jan 1 00:00:03 kernel: NTFS driver v1.1.22 [Flags: R/O]
Jan 1 00:00:03 kernel: pty: 256 Unix98 ptys configured
Jan 1 00:00:03 kernel: Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
Jan 1 00:00:03 kernel: HDLC line discipline: version $Revision$, maxframe=4096
Jan 1 00:00:03 kernel: N_HDLC line discipline registered.
Jan 1 00:00:03 kernel: loop: loaded (max 8 devices)
Jan 1 00:00:03 kernel: PPP generic driver version 2.4.2
Jan 1 00:00:03 kernel: PPP Deflate Compression module registered
Jan 1 00:00:03 kernel: PPP BSD Compression module registered
Jan 1 00:00:03 kernel: MPPE/MPPC encryption/compression module registered
Jan 1 00:00:03 kernel: Amd/Fujitsu Extended Query Table v1.1 at 0x0040
Jan 1 00:00:03 kernel: Flash Id: Vendor: 0x00c2 Device: 0x00a7
Jan 1 00:00:03 kernel: Physically mapped flash: Swapping erase regions for broken CFI table.
Jan 1 00:00:03 kernel: number of CFI chips: 1
Jan 1 00:00:03 kernel: Flash device: 0x400000 at 0x1fc00000
Jan 1 00:00:03 kernel: Physically mapped flash: squashfs filesystem found at block 941
Jan 1 00:00:03 kernel: Creating 5 MTD partitions on "Physically mapped flash":
Jan 1 00:00:03 kernel: 0x00000000-0x00040000 : "pmon"
Jan 1 00:00:03 kernel: 0x00040000-0x003f0000 : "linux"
Jan 1 00:00:03 kernel: 0x000eb714-0x003f0000 : "rootfs"
Jan 1 00:00:03 kernel: 0x003f0000-0x00400000 : "nvram"
Jan 1 00:00:03 kernel: 0x003e0000-0x003f0000 : "flashfs"
Jan 1 00:00:03 kernel: sflash: chipcommon not found
Jan 1 00:00:03 udhcpc[37]: Lease of 192.168.0.20 obtained, lease time 86400
Jan 1 00:00:03 kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Jan 1 00:00:03 kernel: IP Protocols: ICMP, UDP, TCP, IGMP
Jan 1 00:00:03 kernel: IP: routing cache hash table of 512 buckets, 4Kbytes
Jan 1 00:00:03 kernel: TCP: Hash tables configured (established 1024 bind 2048)
Jan 1 00:00:03 kernel: Linux IP multicast router 0.06 plus PIM-SM
Jan 1 00:00:03 kernel: ip_conntrack version 2.1 (128 buckets, 1024 max) - 352 bytes per conntrack
Jan 1 00:00:03 kernel: ip_conntrack_pptp version 1.9 loaded
Jan 1 00:00:03 kernel: ip_nat_pptp version 1.5 loaded
Jan 1 00:00:03 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jan 1 00:00:03 kernel: ipt_time loading
Jan 1 00:00:03 kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Jan 1 00:00:03 kernel: IPv6 v0.8 for NET4.0
Jan 1 00:00:03 kernel: IPv6 over IPv4 tunneling driver
Jan 1 00:00:03 kernel: NET4: Ethernet Bridge 008 for NET4.0
Jan 1 00:00:03 kernel: 802.1Q VLAN Support v1.7 Ben Greear <greearb@candelatech.com>
Jan 1 00:00:03 kernel: All bugs added by David S. Miller <davem@redhat.com>
Jan 1 00:00:03 kernel: FAT: bogus logical sector size 54016
Jan 1 00:00:03 kernel: FAT: bogus logical sector size 54016
Jan 1 00:00:03 kernel: NTFS: Unable to set blocksize 512.
Jan 1 00:00:03 kernel: VFS: Mounted root (squashfs filesystem) readonly.
Jan 1 00:00:03 kernel: Mounted devfs on /dev
Jan 1 00:00:03 kernel: Freeing unused kernel memory: 68k freed
Jan 1 00:00:03 kernel: Warning: unable to open an initial console.
Jan 1 00:00:03 kernel: Algorithmics/MIPS FPU Emulator v1.5
Jan 1 00:00:03 kernel: Uniform Multi-Platform E-IDE driver Revision: 6.31
Jan 1 00:00:03 kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Jan 1 00:00:03 kernel: PDC20265: IDE controller on PCI bus 01 dev 08
Jan 1 00:00:03 kernel: PCI: Enabling device 01:01.0 (0004 -> 0007)
Jan 1 00:00:03 kernel: PDC20265: chipset revision 2
Jan 1 00:00:03 kernel: PDC20265: not 100% native mode: will probe irqs later
Jan 1 00:00:03 kernel: PDC20265: ROM enabled at 0x000d0000
Jan 1 00:00:03 kernel: PCI Mode Secondary PCI Mode.
Jan 1 00:00:03 kernel: PDC20265: FORCING BURST BIT 0x00 -> 0x01 ACTIVE
Jan 1 00:00:03 kernel: ide0: BM-DMA at 0x0140-0x0147, BIOS settings: hda:DMA, hdb:pio
Jan 1 00:00:03 kernel: ide1: BM-DMA at 0x0148-0x014f, BIOS settings: hdc:pio, hdd:pio
Jan 1 00:00:03 kernel: hda: HTS424030M9AT00, ATA DISK drive
Jan 1 00:00:03 kernel: ide2: ports already in use, skipping probe
Jan 1 00:00:03 kernel: ide3: ports already in use, skipping probe
Jan 1 00:00:03 kernel: ide4: ports already in use, skipping probe
Jan 1 00:00:03 kernel: ide5: ports already in use, skipping probe
Jan 1 00:00:03 kernel: ide0 at 0x100-0x107,0x10a on irq 6
Jan 1 00:00:03 kernel: blk: queue c00222e8, I/O limit 4095Mb (mask 0xffffffff)
Jan 1 00:00:03 kernel: hda: 58605120 sectors (30006 MB) w/1739KiB Cache, CHS=62016/15/63, UDMA(33)
Jan 1 00:00:03 kernel: Partition check:
Jan 1 00:00:03 kernel: /dev/ide/host0/bus0/target0/lun0: [PTBL] [3648/255/63] p1
Jan 1 00:00:03 kernel: eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.37.0
Jan 1 00:00:03 kernel: eth1: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.37.0
Jan 1 00:00:03 kernel: PCI: Enabling device 01:02.0 (0004 -> 0006)
Jan 1 00:00:03 kernel: eth2: Broadcom BCM4320 802.11 Wireless Controller 3.90.38.0
Jan 1 00:00:03 kernel: device eth2 entered promiscuous mode
Jan 1 00:00:03 kernel: device eth1 entered promiscuous mode
Jan 1 00:00:03 kernel: br0: port 2(eth1) entering learning state
Jan 1 00:00:03 kernel: br0: port 1(eth2) entering learning state
Jan 1 00:00:03 kernel: br0: port 2(eth1) entering forwarding state
Jan 1 00:00:03 kernel: br0: topology change detected, propagating
Jan 1 00:00:03 kernel: br0: port 1(eth2) entering forwarding state
Jan 1 00:00:03 kernel: br0: topology change detected, propagating
Jan 1 00:00:04 dhcp client: bound IP : 192.168.0.20 from 192.168.0.1
Jan 1 00:00:04 kernel: usb.c: registered new driver usbdevfs
Jan 1 00:00:04 kernel: usb.c: registered new driver hub
Jan 1 00:00:04 kernel: usb-ohci.c: USB OHCI at membase 0xb8004000, IRQ 2
Jan 1 00:00:04 kernel: usb-ohci.c: usb-00:04.0, PCI device 14e4:4715
Jan 1 00:00:04 kernel: usb.c: new USB bus registered, assigned bus number 1
Jan 1 00:00:04 kernel: hub.c: USB hub found
Jan 1 00:00:04 kernel: hub.c: 2 ports detected
Jan 1 00:00:04 kernel: usb.c: registered new driver usblp
Jan 1 00:00:04 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 00:00:07 kernel: usb.c: registered new driver audio
Jan 1 00:00:07 kernel: audio.c: v1.0.0:USB Audio Class driver
Jan 1 00:00:07 kernel: Linux video capture interface: v1.00
Jan 1 00:00:08 kernel: SCSI subsystem driver Revision: 1.00
Jan 1 00:00:09 kernel: Initializing USB Mass Storage driver...
Jan 1 00:00:09 kernel: usb.c: registered new driver usb-storage
Jan 1 00:00:09 kernel: USB Mass Storage support registered.
Jul 30 19:19:56 ntp client: Synchronizing time with time.nist.gov ...
Jul 30 19:19:56 kernel: VFS: Can't find ext3 filesystem on dev ide0(3,0).
Jul 30 19:19:56 kernel: MSDOS FS: Using codepage 950
Jul 30 19:19:56 kernel: MSDOS FS: IO charset cp950
Jul 30 19:19:56 kernel: FAT: bogus logical sector size 64543
Jul 30 19:19:56 kernel: VFS: Can't find a valid FAT filesystem on dev 03:00.
Jul 30 19:19:56 kernel: FAT: freeing iocharset=cp950
Jul 30 19:19:56 kernel: FAT: bogus logical sector size 64543
Jul 30 19:19:56 kernel: VFS: Can't find a valid FAT filesystem on dev 03:00.
Jul 30 19:19:57 kernel: kjournald starting. Commit interval 5 seconds
Jul 30 19:19:57 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
Jul 30 19:19:57 kernel: EXT3-fs: recovery complete.
Jul 30 19:19:57 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jul 30 19:19:57 USB storage: ext3 fs mounted to /tmp/harddisk
Jul 30 19:19:57 FTP server: daemon is started

wengi
31-07-2008, 07:41
Jul 30 19:19:57 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
Jul 30 19:19:57 kernel: EXT3-fs: recovery complete.
Jul 30 19:19:57 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jul 30 19:19:57 USB storage: ext3 fs mounted to /tmp/harddisk

Es wird doch gemountet!!! (USB???? Hast Du noch was dran?????)
Was hast Du bei diesem boot anderes gemacht als vorher???
Könnte es sein, dass der Router einfach länger an war und das Dateisystem gecheckt wurde?
Lies Dir mal unter 4b) den Kommentar zur pre-mount durch. Das trifft für Dich vermutlich nicht 100% zu, da Du ja nicht mein neues Setup hast, könnte aber dennoch in die Richtung gehen.

Wenn Du mir jedes mal ein anderes Ergebnis bringst kann ich Dir nicht helfen.
das muss schon reproduzierbar sein, sonst wirds wirklich schwer....

wengi

bugmenot
06-08-2008, 07:34
Ja gemountet schon, aber ich kann nicht über den Windows-Explorer auf die Partitionen zugreifen bzw. sehe ich im Webinterface keine Möglichkeit Partitionen oder Ordner+Freigabe anzulegen. Habe bei diesem Boot-Vorgang auch nichts zu den anderen verändert. Es sind keine USB-Geräte angeschlossen nur die Festplatte ist im Gehäuse eingebaut...

Werde mir mal des komplette FAQ durchlesen :rolleyes: ...

wengi
06-08-2008, 07:47
Werde mir mal des komplette FAQ durchlesen :rolleyes: ...
Das ist ein verdammt gute Idee BEVOR man Fragen stellt!

wengi

bugmenot
10-08-2008, 17:25
Hab deine Anleitung nun durchgearbeitet, hatte die vorher nur überflogen, deswegen das "komplett durchlesen" in meinem anderen Post.
So du schreibst selber unter Punkt 10 zu Samba, dass man das eingebaute Samba-Modul nutzen sollte:

10a. original SAMBA
Samba dient der Darstellung der angeschlossenen Festplatte im Windows Netzwerk.
Ab der -9er Firmware wird die von Oleg integrierte Samba Version genutzt werden.
Also Im Webinterface unter USB Application -> Samba die nötigen Einstellungen machen.

Am einfachsten Samba File Shares auf "All partitions" und Default Access Level auf "read/write".
Hostname und Workgroup eingeben und gut ist's.
10b. IPKG SAMBA
Ich empfehle jedem die Installation von Samba nach Kapitel 10a. Die jetzt folgende Version ist für diejenigen, die mehr Flexibilität benötigen.
Jedoch habe ich im Webinterface unter USB Application -> Samba nur folgenden Menüpunkte:
USB Application - Simple Samba File Sharing
Enable Samba Demo mode? Yes No
Enable hidden read-write share? Yes No
Die Menüpunkte: Samba File Shares auf "All partitions" und Default Access Level auf "read/write".
sind nicht zu finden :confused: (aktivieren oder deaktivieren der Optionen hilft auch nicht weiter...).
Möchte auch gar nicht großartig was einstellen, die einfache Sambaversion würde mir reichen, nur wie komme ich an meine Festplatte/Partitionen?

Noch eine andere Frage, würde es ausreichen die alte Firmware draufzuspielen um auch die ganzen installierten Programmpakete + Einstellungen zu löschen oder muss ich noch was anderes machen um sozusagen an den Auslieferungszustand zu kommen?