PDA

Bekijk de volledige versie : Samba, NFS über WAN Port



robert@debian
16-06-2008, 11:18
Wieso ist es möglich vom WAN aus per ssh und per ftp auf meinen Router zuzugreifen, aber nicht wie im Webinterface eingestellt auch mit NFS oder Samba?
Die Firewall ist deaktiviert und Port Forwarding Geschichten hab ich auch alles deaktiviert, bzw. nichts eingetragen.
Welche Einstellungen müssen konkret vorgenommen werden, um auch auf nfs bzw. smb shares von außerhalb zuzugreifen?
Vom internen LAN aus klappts ohne Probleme.

als Bsp: Samba anfrage:


smbclient -L wl-500gp
Error connecting to IP Adresse (Connection refused)
Connection to wl-500gp failed (Error NT_STATUS_CONNECTION_REFUSED)


Woran kann es liegen? (Firewall ist aus!)

thejew
16-06-2008, 11:48
schon mal die smb.conf überprüft? (/opt/etc/samba/smb.conf)
könnte sein das dort "interfaces" angegeben wurde so das die freigabe nur auf "br0" oder auf einem bestiummten IP bereich liegt.

Ich hoffe allerdings das du deine freigaben wenigstens mit einem password schützt, sonst kann da jeder an deine daten ran!

robert@debian
16-06-2008, 11:56
könnte sein das dort "interfaces" angegeben wurde so das die freigabe nur auf "br0" oder auf einem bestiummten IP bereich liegt.

Herzlichesten Dank für diesen Hinweis, mir war bis Dato diese Option in smb.conf unbekannt, bzw. hab sie nie gebraucht.
Noch zur Sicherheit: Du hast natürlich absolut Recht mit user spezifischen Zugriffsrechten. Doch da der Router wieder nur Router in nem internen LAN ist und ich es diesen Usern erlaub per security=share zuzugreifen ists ok.

Meine Schritte für die Nachwelt:

1. Im Webinterface Samba auf "Disable" stellen.
2. Kommentiere folgendes in /etc/smb.conf (hab nicht das Sambapaket unter /opt extra noch installiert) aus:


# interfaces = br0
# bind interfaces only = yes

3. Füge in /usr/local/sbin/post-boot noch:


/usr/sbin/nmbd -D
/usr/sbin/smbd -D

ein
4.


echo /etc/smb.conf >> /usr/local/.files
flashfs save && flashfs commit && flashfs enable && reboot

Hast du evtl. noch nen Tipp für NFS, das wär mir ohnehin etwas lieber :-)