PDA

Bekijk de volledige versie : Zeichensatzproblem mit SCP / WinSCP



pc-nico
12-06-2008, 09:26
Hallo Leute,

habe folgendes Problem... habe openssh installiert und läuft auch super...

wenn ich mich mit putty einlogge (UTF-8 kodiert) sehe ich alle Umlaute...
Auch per Samba sehe ich die Umlaute super...

allerdings wenn ich mit WinSCP drauf schaue sehe ich keine Umlaute....

Die Bilder zeigen das Problem sehr gut....
Hat jemand ähnlich Probleme

WLAN-Fan
12-06-2008, 09:31
Geht mir genau so.
Warum?

pc-nico
16-06-2008, 14:13
hat sonst niemand das Problem? Oder leben alle mit diesem Problem?

pc-nico
23-07-2008, 13:40
sorry, das ich den Beitrag Pusche, aber ich kann nicht glauben das alle mit SCP mit diesem Problem leben.... :(:(:(:(

fredlcore
24-07-2008, 13:08
Mit Protokoll SCP gibt es da wohl keine Möglichkeit.

Wenn man als IPKG-Quelle aber schon auf http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable eingestellt ist (Achtung, nicht einfach austauschen, das kann zu ziemlichen Problemen führen, dafür gibt es aber Anleitungen), kann man das Paket openssh-sftp-server per ipkg installieren. Dann ist SFTP als Protokoll bei WinSCP möglich.

Dann noch bei "Environment" (nur in den neuesten WinSCP-Versionen, z.B. 4.1.5.) die Einstellung "UTF-8 encoding for filenames" nicht auf "Auto" sondern auf "on" setzen.

Dann klappt's :)...

CU!

F.

pc-nico
24-07-2008, 13:51
super... der Tipp war jetzt gold werd... ich hatte ja bereits openssh installiert und sftp verwendet...

aber in den bisherigen Versionen von WinSCP gib es diese Option nicht...
oder habe ich sie immer übersehen? Naja nun geht endlich alles....


vielen vielen Dank :-)

fredlcore
25-07-2008, 00:09
Ja, diese Option ist wohl wirklich erst in den letzten Wochen hinzugefügt worden, zumindest an der Stelle...