PDA

Bekijk de volledige versie : THTPPD an Stelle von Webinterface auf Port 80



carter
07-06-2008, 16:28
Hallo,

ich möchte über das WAN-Interface direkt auf den THTTPD-Webserver geleitet werden. Dieser läuft bei mir auf Port 81. Das Webinterface anscheinend auf Port 80. Ich habe die unten angegebene Konfiguration in der post-firewall gesetzt. Ein Routing von Paketen auf Port 81, die für Port 80 bestimmt sind, findet aber damit nicht statt. Wie ist es nun möglich den Port des Webinterfaces (dafür läuft doch anscheinend ein separater Webserver) zu ändern, sodass THTTPD auf Port 80 läuft?

Hier die /usr/local/sbin/post-firewall



#!/bin/sh
iptables -D INPUT -j DROP
iptables -A INPUT -p tcp --dport 81 -j ACCEPT
iptables -A INPUT -p tcp --dport 80 -j ACCEPT
iptables -t nat -A PREROUTING -i $1 -p tcp --dport 80 -j DNAT --to-destination $4:81

iptables -A INPUT -j DROP


Hier die /opt/etc/thttpd.conf



dir=/opt/share/www
port=81
user=nobody
nochroot
nosymlink
novhost
logfile=/opt/var/log/thttpd.log
# Please do not edit pidfile path at it is use to kill thttpd process during init
pidfile=/opt/var/run/thttpd.pid




Danke für eure Tips!

newbiefan
07-06-2008, 19:59
Auf der Console:
'nvram set http_lanport=88'
eingeben und die Config von Deinem neuen httpd auf port 80 stellen.
Danach nur noch das uebliche:
flashfs save && flashfs commit && flashfs enable && reboot

Bitte nicht vergessen: Port 80 muss vom INET erreichbar sein, also im Webif
einstellen.

Ach ja: dein Router ist danach mit http:192.168.x.x:88 erreichbar.

Have fun

carter
08-06-2008, 17:38
Funktioniert!

Habe über die post-firewall den Port 80 freigegeben.
Das ganze habe ich dann über das VPN meiner Hochschule getestet (externes Routing) und siehe da - alles klappt wie gewollt!

Danke!

WLAN-Fan
09-06-2008, 09:49
... den THTTPD-Webserver geleitet werden ...
Wenn du nicht den THTTPD nehmen mußt würde ich dir den LigHTTPd-Webserver empfehlen.
Der THTTPD macht bei mir und auch bei anderen nur Ärger. Erspare dir die Zeit Fehler zu finden die an dem THTTP liegen.

Gruß.

carter
12-06-2008, 14:56
Ja, thttpd ist eine üble Angelegenheit. Ich bin nun auch schon seit einigen Tagen bei lighttpd uns das funktioniert tadellos!

WLAN-Fan
12-06-2008, 16:14
Ja, thttpd ist eine üble Angelegenheit. Ich bin nun auch schon seit einigen Tagen bei lighttpd uns das funktioniert tadellos!
Funktioniert auch cgi-bin? Das will bei mir per du nee laufen. Nur PHP will.

Gruß.