PDA

Bekijk de volledige versie : Umlaute in SMB OK, aber im Filesystem nicht angezeigt



pc-nico
01-06-2008, 17:10
Hallo Leute,

hab schon gesucht aber irgendwie nichts gefunden... habe auf meiner Platte ne ganze Menge daten... die wurden an einem PC mit Linux auf die Platte kopiert...
jetzt hängt die Platte am WL500gp... Leider werden mir die Umlaute im Dateisystem
aber nicht angezeigt.... wenn ich aber mittels smb auf die Platte zugreife, sehe
ich die Dateien ganz normal mit allen Umlauten... ist eine ext3 Partition...
kann mir jemand einen Tipp geben, wie ich das ändern kann?



drwxrwxrwx 3 admin root 4096 May 28 16:50 W??rterbuch

Sollte eigentlich Wörterbuch heißen

in smb.conf steht:
client code page = 850
coding system = utf8

noch ein kleiner Nachtrag:



[admin@wl500gp Install]$ mkdir Täää
[admin@wl500gp Install]$ ll
total 32
drwx------ 2 admin root 16384 May 29 11:16 lost+found
drwxrwxrwx 49 admin root 4096 Jun 1 19:06 quellen
drwxr-xr-x 1 admin root 0 Jun 1 19:09 ..
drwx------ 2 admin root 4096 Jun 1 20:00 T???
drwxr-xr-x 5 admin root 4096 Jun 1 20:00 .



Wenn ich im Dateisystem eine Datei anlege, werden mir die Umlaute auch nicht angezeigt... wenn ich über winscp auf das Filesystemzugreife,
sehe ich die oben angelegt datei richtig, aber dann umlaute in der Partition die unter Win richtig angezeigt wird nicht mehr.... sehr seltsam....

legolas
01-06-2008, 23:07
Hi,

such mal unter samba oder smb. Das Problem wurde schon einmal hier besprochen. Du musst die Einstellungen in der smb.conf ändern.

Wie das genau geht, weiss ich jetzt nicht mehr. Such mal. Schau auch mal bei der Samba-Homepage vorbei und google mal. Da gibt es brauchbare Infos.

Norbert

MMCM
02-06-2008, 02:23
Welche Samba Version hast du im Einsatz? Version 2.x unterstützt kein UTF-8!

pc-nico
02-06-2008, 06:31
also ich habe version 2 (die integrierte von OLEG) am Start....

das Problem liegt aber nicht bei SMB sondern:

wenn ich die coreutils installiere, werden mir im Terminal bei einem ls keine Umlaute angezeigt.

Deinstalliere ich sie und verwende wieder das ls vom OLEG-FW dann werden sie
mir angezeigt...

Es liegt also an den Coreutil... hat jemand von euch ähnlich Probleme?

Nixblicker
08-05-2009, 01:37
also ich habe version 2 (die integrierte von OLEG) am Start....

das Problem liegt aber nicht bei SMB sondern:

wenn ich die coreutils installiere, werden mir im Terminal bei einem ls keine Umlaute angezeigt.

Deinstalliere ich sie und verwende wieder das ls vom OLEG-FW dann werden sie
mir angezeigt...

Es liegt also an den Coreutil... hat jemand von euch ähnlich Probleme?

Ich habe leider das selbe Problem mit den Umlauten, sowohl unter Samba als auch in sh bzw bash. Ich glaube, daß dies auch bei mir mit der Installation der coreutils anfing.
Alle Dateien, die ich bspw. mit Transmission herunterlade und die Umlaute beinhalten werden nicht korrekt angezeigt, wenn ich mich über ssh an der Kiste anmelde, kann ich nicht einmal Umlaute eintippen, zB beim testen via "touch täterää.txt" o.ä.
Ich verstehe nicht warum das so ist, obwohl sh und bash laut Umgebungsvariablen auf utf-8 eingestellt sind.

So kann ich jetzt aber vor allem nicht auf diese Dateien zugreifen, weil mir das Samba meiner Ubuntu-Kiste einfach alle Dateien verschweigt, die Umlaute beinhalten. Was mache ich bloß verkehrt? :confused:

Meine smb.conf sieht folgendermaßen aus (laut Wengis Howto mit xinet.d gestartet):

[global]
coding system = utf8
workgroup = MUHAHA
netbios name = WL500W
server string = Samba_Router
interfaces = br0
bind interfaces only = Yes
security = SHARE
log level = 1
log file = /opt/var/log/samba/log.%m
max log size = 100
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
load printers = No
client code page = 850
#character set = ISO8859-15
dns proxy = No
guest account = admin
guest only = Yes
guest ok = Yes
hosts allow = 192.168.1. 127.

Fehlt da vielleicht noch was? (mit character set = ISO8859-15 ging es auch nicht) Bitte helft!

Hat jemand von Euch das Problem mit den coreutils lösen können?

LG und Danke,

Nix

akbor
08-05-2009, 07:14
Hi,

ich habe ziemlich viel mit Samba rumgespielt, um die UTF-8 Ünterstützung hinzubekommen. Kann schon mal folgendes sagen: Mit Samba2 habe ich es nicht geschafft - sowohl die "built-in" Samba, als auch die neuere 2.x Version, die man mit "ipkg install samba2" von ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable runterladen und installieren kann, konnte ich nicht dazu zwingen, die UTF-8 kodierten Dateinamen richtig darzustellen. Erst mit Samba3 ("ipkg install samba3", oder "ipkg install samba") funktioniert es.

Ich bin aber der Meinung, dass die "built-in" Samba mit der richtigen Einstellung (deutsche Codepage im Web-IF, man muss nicht einmal die smb.conf editieren) die Umlaute wunderbar darstellen kann.

Von Coreutils ehrlich gesagt keine Ahnung. Hatte es von Anfang an drauf und die Umlaute wurden korrekt dargestellt, sowohl im Samba-Share (mit Windows Explorer!) als auch im SSH-Terminalfenster (mit PuTTY!). In PuTTY kann man überigens auch eine Codepage einstellen. Default ist -glaube ich- 1252 und damit werden die Umlaute wunderbar dargestellt.


wenn ich mich über ssh an der Kiste anmelde, kann ich nicht einmal Umlaute eintippen, zB beim testen via ...

...So kann ich jetzt aber vor allem nicht auf diese Dateien zugreifen, weil mir das Samba meiner Ubuntu-Kiste einfach alle Dateien verschweigt, die Umlaute beinhalten. Das ist doch ein Indiz dafür, das auf deinem Ubuntu-Rechner etwas mit der Sprachunterstützung vermurkst ist.

Gruß

Robert