PDA

Bekijk de volledige versie : Не подключается USB HDD



Romuald
18-04-2007, 18:46
А какая у кого статитстика по HDD. У меня диск в WL-HDD проработал около года и ... захрустел. Пока работает, но звуки из него непотребные доносятся. Вот интересно, у кого сколько работаю харды. Вообще, у ASUS при простое они выключаются (например, в WL-700)?

Mirage-net
18-04-2007, 19:38
А какая у кого статитстика по HDD. У меня диск в WL-HDD проработал около года и ... захрустел. Пока работает, но звуки из него непотребные доносятся. Вот интересно, у кого сколько работаю харды. Вообще, у ASUS при простое они выключаются (например, в WL-700)?
время работы диска зависит от его качества и охлаждения ... если работает круглосуточно имеет смысл подумать о доп. олаждении ...

Oleg
18-04-2007, 19:53
А какая у кого статитстика по HDD. У меня диск в WL-HDD проработал около года и ... захрустел. Пока работает, но звуки из него непотребные доносятся. Вот интересно, у кого сколько работаю харды. Вообще, у ASUS при простое они выключаются (например, в WL-700)?
А что за диск был в WL-HDD? Сколько ему лет было?

VOVA_iS
19-04-2007, 05:41
У меня тоже примерно через год захрустел жесткий...
Брал БУ. Возможно в этом и причина...
А чтоб не грелся жесткий повесил вентилятор...

Romuald
19-04-2007, 21:54
Совсем свежий диск был. Работал в переносном боксе, год наверное. Сказать, что грелся сильно и охлаждать его нужно было, не сказать. Чуть тёплый был. Диск: Tohiba MK2018GAS. Вообще, как понимаю не расчитаны 2,5" диски на 24 часовое кручение. Другой видать та же судьба постигнет :(

Oleg
19-04-2007, 22:02
У меня на службе около 600 штук 2.5" тошиб и фуджиков крутятся 24х7х365 в дичайших условиях. За три года умерло не так много, процентов 5. :) Но там мрёт всё, и 3.5 и 2.5. И даже SCSI на 10000RPM ценой по несколько килобаксов за штуку.
Так что, должны жить, видимо у Вас был неудачный экземпляр. Ну а гарантия на них 3 года.

Sheeft
20-04-2007, 19:36
У меня вот стоит новый WD SATA на 400 гигов, так он грееться пламенно, из охлаждения только маленький кулер (1') на боксе для харда. Поскольку стоит вертикально в корпусе немного хрустит, сделал чтобы выключался через 4 мин после простоя. (Тот кто спрашивал про отключение - в поиске spindown)
Какие прогнозы, сколько проживет ?))

Mirage-net
21-04-2007, 09:55
У меня вот стоит новый WD SATA на 400 гигов, так он грееться пламенно, из охлаждения только маленький кулер (1') на боксе для харда. Поскольку стоит вертикально в корпусе немного хрустит, сделал чтобы выключался через 4 мин после простоя. (Тот кто спрашивал про отключение - в поиске spindown)
Какие прогнозы, сколько проживет ?))

Делать прогнозы бесполезное дело ... если сильно греется ставь еще кулеры иначе сдохнет очень быстро ... если охлаждение нормальное то харду пофиг в USB-box`e он или просто в машине стоит ... даже 2.5" харды изначально проектируются на непрерывную работу ... у меня сигейт 80 ГБ ноутбучный в коробке уже около 2-х лет работает не выключаясь (постоянная закачка/отдача 30-40 торрентов) и все нормально

Aleks
10-07-2007, 11:36
в связи с недостатком практического опыта требуется квалифицированная помощь, чтобы получить от этой белой коробочки (Asus Wl500gP + WL500gp-1.9.2.7-7g.trx)все, на что я расчитывал при ее выборе и при изучении материалов сего форума.

требования простые, выглядят следующим образом -
* домашние компы ходят друг к другу, на фтп роутера, в сеть провайдера и в интернет.
* из сети провайдера есть доступ ТОЛЬКО к фтп роутера
под вопросом доступ к самбе из сети провайдера, насколько я понял - у самбы нет возможности регулирования ширины отдаваемого исходящего канала.

форум изучен, понято не все.
с Линуксом и даже Telnet-ом столкнулся в первые, но с помощью могучего интеллекта уже кое что смог. например, поставил MC и запустил его из Putty.

на данный момент -
* компы выходят в сеть провайдера и в инет (PPTP c фиксированным IP)
* компы видят друг друга
* работает Самба (для локалки)

очередь за фтп. хочется сделать так - в нижний порт постоянно воткнута флэшка,на ней планируется хранить конфиги и логи
в верхний порт планируется воткнуть usb хард, на котором будет непосредственно содержимое фтп сервера.
хочется сделать с самого начала все правильно, поэтому для начала вопрос в следующем - как быть с флэшкой? как ее отформатировать и разбить? правильно ли я понял, что для того чтобы все было хорошо, часть флэшки нужно оставить под своп, а часть отформатировать в ext3 и монтирваться она при старте будет автоматически? своп - это отдельный раздел (и не надо хихикать) ?

al37919
10-07-2007, 12:06
флэшка,на ней планируется хранить конфиги и логи

на флешь, скорее всего имеет смысл положить всю файловую систему /opt, т.е. все установленные приложения, а hdd использовать только для пользовательского контента.


как быть с флэшкой? как ее отформатировать и разбить?
правильно ли я понял, что для того чтобы все было хорошо, часть флэшки нужно оставить под своп, а часть отформатировать в ext3 и монтирваться она при старте будет автоматически?

своп нужен, но на флешку его лучше не класть. В него запись может производится интенсивно, а флеш, все таки носитель с ограниченным ресурсом на запись. Своп лучше положить на винт, а на флеши сделать 1 раздел ext3


своп - это отдельный раздел (и не надо хихикать) ?

своп может быть как отдельным разделом, так и файлом в обычном разделе ext3

Aleks
10-07-2007, 19:02
спасибо за оперативную инфу. вопрос по свопу - если он расположен на USB жестком диске - чем чревато его, диска, отключение?

BuHT
10-07-2007, 21:18
если своп был подключен на момент отключения диска - то зависанием роутера. глухим. перезагруз только вкл выкл питание.

usmailer™
10-07-2007, 22:00
если своп был подключен на момент отключения диска - то зависанием роутера. глухим. перезагруз только вкл выкл питание.

Согласен..
Только если всем этим делом заведует хомо сапиен, т.е. чел.разумный, то он не станет отрубать винт от работающего роутера...
Ну а выключений света можно не боятся.... т.к. если наступит его, света, конец... то отрубится моментально и роутер и винт...
Вариант с раздельным питанием (роутер от ИБП, винт от сети) я не рассматриваю... ибо это глупо...

Вариант с "посторонней помощью".... тоже вероятен...
Моей дочке, в последнее время, очень уж нравятся перемигивающиеся огоньки роутера... посто завораженная может стоять долго и смотреть... но увы... до высоты 2.2 метра ей еще лет 15.... под потолок не допрыгнет... так что планируйте и место расположения вашего "помощника", чтобы случайно ему не "помогли"...

удачи!

al37919
11-07-2007, 08:20
еще один прикол заключается в том, что без винта своп не нужен :)

Aleks
11-07-2007, 08:25
я просто предполагаю, что придется периодически (для скорости, например при заливке больших объемов данных через usb 2.0 с компа) этот хард от роутера отключать. получается, я сначала должен дать команду отключения свопа, потом отмонтирования харда (и остановки фтп, вероятно) и только потом выключать питание харда и выдергивать его из роутера. и потом в обратной последовательности. так?

кстати, вопрос вдогонку, про фтп - возможно ли использование ntfs на харде с фтп. скорее всего нет. тогда возможно ли использование fat32 (хотя на него и не залить файло более 2гб размером, но с этим готов смириться, слава богу есть DVD Decrypter) с ограничением доступа по пользователям? я просто не знаю, на каком уровне под линуксом это делается - на уровне файловой системы ли (и тогда нужен ext3, это ясно) либо на уровне сервиса ftp сервера ?

al37919
11-07-2007, 08:36
получается, я сначала должен дать команду отключения свопа, потом отмонтирования харда (и остановки фтп, вероятно) и только потом выключать питание харда и выдергивать его из роутера. и потом в обратной последовательности. так?
именно, плюс к этому скорее всего прибить всякие качалки, которые винт используют, чтобы они не слишком удивлялись его внезапному отсутствию. Однако, эти все комманды можно свести в один скрипт и даже при желании повесить его исполнение на кнопк ez-setup...

на каком уровне под линуксом это делается - на уровне файловой системы ли (и тогда нужен ext3, это ясно) либо на уровне сервиса ftp сервера
На всех уровнях. В файловой системе есть четкий набор прав доступа для различных категорий пользователей. ФТП-сервер тоже может быть настроен так, что пользователь будет видеть только свою home directory

ntfs --- readonly. Доступны несколько драйверов под винду, которые дают полный доступ к ext2/3 fs.

Mam(O)n
11-07-2007, 08:41
я просто предполагаю, что придется периодически (для скорости, например при заливке больших объемов данных через usb 2.0 с компа) этот хард от роутера отключать. получается, я сначала должен дать команду отключения свопа, потом отмонтирования харда (и остановки фтп, вероятно) и только потом выключать питание харда и выдергивать его из роутера. и потом в обратной последовательности. так?

Именно так. Также на premium можно повесить скрипт на кнопку ez-setup, который будет при нажатии демонтировать файловые системы и своп и дальше ждать, пока винт о5 снова не воткнут а затем все обратно монтировать.



кстати, вопрос вдогонку, про фтп - возможно ли использование ntfs на харде с фтп.

Информация к размышлению: http://wl500g.info/showthread.php?t=8948
ИМХО лучше на десктопе поставить поддержку ext3

Aleks
11-07-2007, 08:53
коллеги, спасибо за исчерпывающую крайне полезную инфу. сейчас займусь воплощением.

зы. маленький вопрос не совсем в тему - кнобка в web интерфейсе save&restart какую команду выполняет? случайно не
flashfs save
flashfs commit
flashfs enable
reboot
?
просто есть идея править конфиги в FAR через Samba, сохранять изменения через save&restart/ или все это пустые фантазии?

al37919
11-07-2007, 09:35
х.з. Как говорил дедушка Маркс: "практика --- критерий истины". Экспериментируйте...

imdex
11-07-2007, 10:40
коллеги, спасибо за исчерпывающую крайне полезную инфу. сейчас займусь воплощением.

зы. маленький вопрос не совсем в тему - кнобка в web интерфейсе save&restart какую команду выполняет? случайно не
flashfs save
flashfs commit
flashfs enable
reboot
?
просто есть идея править конфиги в FAR через Samba, сохранять изменения через save&restart/ или все это пустые фантазии?

А смысл какой? Сложно набрать три команды?

Aleks
11-07-2007, 12:35
А смысл какой? Сложно набрать три команды?

да нет, совсем не сложно. это только на случай работы без телнета, когда требуется только правка конфигов, без выполнения команд на сервере. все таки FAR более привычен и быстр, чем МС.

кстати, я тут засомневался, может роутер и нет нужды ребутить после правки, достаточно рестартовать сервисы?

tchaynik
11-07-2007, 14:49
да нет, совсем не сложно. это только на случай работы без телнета, когда требуется только правка конфигов, без выполнения команд на сервере. все таки FAR более привычен и быстр, чем МС.

кстати, я тут засомневался, может роутер и нет нужды ребутить после правки, достаточно рестартовать сервисы?
Нашел отличный плагин для Far-а - WinSCP. Позволяеп подрубица к ssh-у, и выполнять там команды. Причем через ssh мона прикрасно копировать в роутер файлы и править их прям там Фаровским или другим редактором.

Aleks
11-07-2007, 17:27
Нашел отличный плагин для Far-а - WinSCP. Позволяеп подрубица к ssh-у, и выполнять там команды. Причем через ssh мона прикрасно копировать в роутер файлы и править их прям там Фаровским или другим редактором.

о, забавная вещица. сенькс, попробуем в деле!

Alesot
05-04-2008, 13:33
Не получается подключить внешний хард к роутеру.

Роутер: WL-500g Premium
HDD: 500,0 Gb HDD Samsung (HD501LJ) 7200rpm SpinPoint T166S 16Mb SATA-300 NCQ
USB BOX: Tsunami eDATA 3500 USB

Коробка с хардом к компу под виндой подключается отлично. Пробовал отформатировать под разные файловые системы, но все равно роутер хард не видит. Также к роутеру без проблем подключается флешка.



[admin@WL500G root]$ df
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 3072 3072 0 100% /
[admin@WL500G root]$ fdisk -l
[admin@WL500G root]$ cat /proc/scsi/scsi
Attached devices: none
[admin@WL500G root]$


Куда копать? Или коробку поменять?

al37919
05-04-2008, 13:46
грузить усб драйверы, смотреть в лог

Alesot
05-04-2008, 14:50
грузить усб драйверы, смотреть в лог



[admin@WL500G root]$ lsmod
Module Size Used by Tainted: P
usb-storage 63928 0
sd_mod 13276 0
scsi_mod 70200 3 [usb-storage sd_mod]
audio 50664 0 (unused)
soundcore 5288 0 [audio]
printer 12900 0 (unused)
ehci-hcd 23804 0 (unused)
usb-uhci 28580 0 (unused)
usbcore 78496 1 [usb-storage audio printer ehci-hcd usb-uhci]
ip_nat_ftp 3912 0 (unused)
ip_conntrack_ftp 5216 1
ipt_NETMAP 960 2
ip_nat_starcraft 2208 0 (unused)
wl 892280 0 (unused)
et 31288 0 (unused)


Обьясните немного больше по поводу драйверов

Alesot
05-04-2008, 14:52
А вот лог...

Alesot
05-04-2008, 14:58
Версия прошивки 1.9.2.7-10

al37919
06-04-2008, 08:30
usb драйверы загружены.

Jan 1 03:07:41 kernel: Device 08:01 not ready.
Jan 1 03:07:41 kernel: I/O error: dev 08:01, sector 544
Jan 1 03:07:41 kernel: Device 08:01 not ready.
Jan 1 03:07:41 kernel: I/O error: dev 08:01, sector 2
дело явно не в файловых системах. Обычно такие проблемы связаны с недостаточным питанием, хотя у этого цунами, по моему б/п нормальный --- 2 напряжения по 2 ампера, или как?

Alesot
06-04-2008, 14:15
б/п нормальный --- 2 напряжения по 2 ампера, или как?
Да, именно так. Но к компьютеру то подключается без проблем.

Есть ли смысл поставить линукс на компьютер и попробовать под линуксом подключить хард? К сожалению все liveCD отказываются загружаться, видимо железо новое, или еще что...

Пока что буду копать в сторону БП, а в понедельник возьму еще какую нибудь коробку...

vectorm
07-04-2008, 10:18
Да, именно так. Но к компьютеру то подключается без проблем.

Есть ли смысл поставить линукс на компьютер и попробовать под линуксом подключить хард? К сожалению все liveCD отказываются загружаться, видимо железо новое, или еще что...

Пока что буду копать в сторону БП, а в понедельник возьму еще какую нибудь коробку...

Попробуй подключить диск уже после запуска роутера, возможно логика бокса за роутером не успевает ...

Alesot
07-04-2008, 16:05
Попробуй подключить диск уже после запуска роутера, возможно логика бокса за роутером не успевает ...

Пробовал и до, и после, и во время:) Одним словом испробовал любые вариации - результат один и тот же...

И все таки по поводу драйверов что можете сказать? Кто они такие, откуда берутся и как вкорячиваются?

Скоро поеду брать еще одну коробку - результат завтра сообщу...

al37919
07-04-2008, 16:22
драйверы я же писал, что на месте:

usb-storage 63928 0
sd_mod 13276 0
scsi_mod 70200 3 [usb-storage sd_mod]

Коробка SATA с большим вентилятором на сбоку?

Еще некоторым помогает разъем на роутере поджимать...

Alesot
07-04-2008, 16:39
драйверы я же писал, что на месте:

usb-storage 63928 0
sd_mod 13276 0
scsi_mod 70200 3 [usb-storage sd_mod]

Эти модули единственные в своем роде? Или есть аналоги? (или мой вопрос бессмысленен? :) )


Коробка SATA с большим вентилятором на сбоку?

Да. Вентилятор пробовал отключать.


Еще некоторым помогает разъем на роутере поджимать...

Обязательно попробую

al37919
07-04-2008, 17:11
Эта коробка в принципе работать может --- пользователи докладывали [вообще то, именно про эту не докладывали...]

Так что дело в каких то локальных особенностях --- может другим усб кабелем (желательно толще и короче) попробовать подключить...

Cranch
07-04-2008, 19:28
У меня почти такой же кейс - Tsunami S-3500 (http://www.verba.ru/cgi/price/price.pl?group=330&id=38360&cmd=show_tech_info) c WD500AAKS унутре - все завелось с полпинка, правда, я все делал "с нуля".

cat /proc/scsi/usb-storage-0/0 выдает вот такое:



Host scsi0: usb-storage
Vendor: Sunplus Technology Inc.
Product: USB to Serial-ATA bridge
Serial Number: WDC WD5000 WD-WCAS82818220
Protocol: Transparent SCSI
Transport: Bulk
GUID: 04fc0c15fff60cbc82818220
Attached: Yes
Port: 2
Bus: 01:03.2-2


Я не знаю точно, тот ли чипсет стоит в вашей более новой коробке, но сильно подозреваю, что это просто фейслифтинг.

Alesot
09-04-2008, 07:50
Коробку новую так и не купил...

Попробовал заведомо рабочий и качественный USB кабель (экран, ферриты) - результат тот же...

Вот что говорит dmesg (после подключения):



hub.c: new USB device 01:03.2-1, assigned address 2
usb_control/bulk_msg: timeout
usb.c: error getting string descriptor 0 (error=-145)
usb_control/bulk_msg: timeout
usb.c: error getting string descriptor 0 (error=-145)
usb.c: error getting string descriptor 0 (error=-71)
scsi0 : SCSI emulation for USB Mass Storage devices
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
usb.c: USB disconnect on device 01:03.2-1 address 2

justason
09-04-2008, 07:57
У меня 100% похожая ситуация, правда HDD другой:
- 2.5" WD 60GB
- HDD enclosure
- к коробочке подведено свое питание

Alesot
20-04-2008, 17:03
Всем спасибо за ответы, проблема решилась покупкой коробки ViPower VPAS-35018.

al37919
20-04-2008, 17:33
если тот, нерабочий, еще доступен, то любопытно было бы узнать на каком чипе он собран.

Alesot
20-04-2008, 20:14
если тот, нерабочий, еще доступен, то любопытно было бы узнать на каком чипе он собран.

Доступен, попробую узнать.

А есть где нибудь черный список USB коробок? Думаю стоили бы в моем случае добавить к него запись:)

housemouse
20-04-2008, 20:35
У меня в коробке чип JM20339, терабайтный винт - понимает.

Lan-profan
30-07-2008, 17:21
Продолжаю настраивать ASUS WL-500G Premium, возник ряд вопросов. Подключил к USB портам 2 устройства:

а) Flash карту на 1G отформатированную под EXT 3 под следующие разделы:

Disk /dev/scsi/host1/bus0/target0/lun0/disc: 1031 MB, 1031798784 bytes
32 heads, 62 sectors/track, 1015 cylinders
Units = cylinders of 1984 * 512 = 1015808 bytes

Device Boot Start End Blocks Id System
/dev/scsi/host1/bus0/target0/lun0/part1 1 127 125953 82 Linux swap
/dev/scsi/host1/bus0/target0/lun0/part2 128 632 500960 83 Linux
/dev/scsi/host1/bus0/target0/lun0/part3 633 1015 379936 83 Linux

б) Hard Box на 40G отформатированный под FAT 32:

Disk /dev/scsi/host0/bus0/target0/lun0/disc: 40.0 GB, 40060404224 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/scsi/host0/bus0/target0/lun0/part1 1 4870 39118243+ c Win95 FAT32 (LBA)
Вопрос 1
При отключенном Hard Box имеем следующее:

total used free shared buffers
Mem: 30164 15800 14364 0 1984
Swap: 125944 0 125944
Total: 156108 15800 140308

При включенном, следующее:

total used free shared buffers
Mem: 30164 15068 15096 0 1920
Swap: 0 0 0
Total: 30164 15068 15096

Такое ощущение что при включенном Hard Box, Swap отключается, почему?

Вопрос 2
Настраиваю, дошел до пункта 6 "Установка пакетов"

mkdir -p /opt/tmp/ipkg
cd /opt/tmp/ipkg
ipkg.sh update

- это все успешно сделал, загрузил что то а дольше начинает писать мол "not found" и это пишет на все команды что ниже, подскажите пожалуйста что я делаю не так?

Вопрос 3
Встроенная самба:
Не получается прописать директорию для Manual share list.
Пишу \\Server\Media папка Media при попытки войти ругается, мол неправильна директория. При режиме first partition без проблем захожу как \\Server\share Уже перебрал все варианты, не пойму что не так?

Вопрос 4
Могу ли я загрузить нужные мне приложения из Интернет, потом поместить в роутер «ручками» с последующей установкой их в него. Можно так? Если можно, то как?

P.S. пожалуйста ответьте на вопросы по подробней, просто я не телепат, а только учусь.

DemonGloom
31-07-2008, 19:14
1) флеш под swap не рекомендуется использовать... проще все на винт...
2) приведите то, что пишет полностью
3) приведите настройки
4) да можно. запустите ipkg --help и узнаете

Lan-profan
31-07-2008, 21:47
Просто у меня флешка всегда включена в роутер а hdd включаю по необходимости, поэтому мне нужно чтобы swap был на флешке.

По второму пункту - это все что он пишет, может там что то еще не смонтировано?

По третьему пункту: First partition, Read/Write, Server, workgroup, 866 - настройки web интерфейса, ничего дополнительного не устанавливал.

A как запустить ipkg?

DemonGloom
01-08-2008, 06:25
Посмотрите инструкциию http://wl500g.info/showthread.php?t=3171 с начала... там будут ответы на многие вопросы...

vectorm
01-08-2008, 21:54
Продолжаю настраивать ASUS WL-500G Premium, возник ряд вопросов. Подключил к USB портам 2 устройства:

а) Flash карту на 1G отформатированную под EXT 3 под следующие разделы:

Disk /dev/scsi/host1/bus0/target0/lun0/disc: 1031 MB, 1031798784 bytes
32 heads, 62 sectors/track, 1015 cylinders
Units = cylinders of 1984 * 512 = 1015808 bytes

Device Boot Start End Blocks Id System
/dev/scsi/host1/bus0/target0/lun0/part1 1 127 125953 82 Linux swap
/dev/scsi/host1/bus0/target0/lun0/part2 128 632 500960 83 Linux
/dev/scsi/host1/bus0/target0/lun0/part3 633 1015 379936 83 Linux

б) Hard Box на 40G отформатированный под FAT 32:

Disk /dev/scsi/host0/bus0/target0/lun0/disc: 40.0 GB, 40060404224 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/scsi/host0/bus0/target0/lun0/part1 1 4870 39118243+ c Win95 FAT32 (LBA)
Вопрос 1
При отключенном Hard Box имеем следующее:

total used free shared buffers
Mem: 30164 15800 14364 0 1984
Swap: 125944 0 125944
Total: 156108 15800 140308

При включенном, следующее:

total used free shared buffers
Mem: 30164 15068 15096 0 1920
Swap: 0 0 0
Total: 30164 15068 15096

Такое ощущение что при включенном Hard Box, Swap отключается, почему?
Это не ощущение. Что говорит df -h до и после подключения диска? Куда флешка теряется после подключения диска? Что пишет в логе при этом?

Вопрос 2
Настраиваю, дошел до пункта 6 "Установка пакетов"

mkdir -p /opt/tmp/ipkg
cd /opt/tmp/ipkg
ipkg.sh update

- это все успешно сделал, загрузил что то а дольше начинает писать мол "not found" и это пишет на все команды что ниже, подскажите пожалуйста что я делаю не так?
Весь лог действий по этому пункту приложи.

Вопрос 3
Встроенная самба:
Не получается прописать директорию для Manual share list.
Пишу \\Server\Media папка Media при попытки войти ругается, мол неправильна директория. При режиме first partition без проблем захожу как \\Server\share Уже перебрал все варианты, не пойму что не так?
Может стоит для начала разобраться с предыдущими настройками?
А потом воспользоваться например этой темой (http://wl500g.info/showpost.php?p=60936&postcount=7), пункт 15 А).

Вопрос 4
Могу ли я загрузить нужные мне приложения из Интернет, потом поместить в роутер «ручками» с последующей установкой их в него. Можно так? Если можно, то как?

Можно, изучик ключи работы ipkg.

Lan-profan
02-08-2008, 11:23
Я ответил в файле "Продолжение.rar" - просто форма форума ругается на большое количество символов.

vectorm
02-08-2008, 14:14
Я ответил в файле "Продолжение.rar" - просто форма форума ругается на большое количество символов.
Замеченные проблемы:
1. 2 раза запускается dropbear - вероятно бездумное копирование в несколько файлов.
2. Какой-то косяк с монтированием. Что в файле /etc/fstab ?
Если все устанавливать без подключения диска что будет с установкой ipkg и ipkg-opt?

Lan-profan
02-08-2008, 17:29
Замеченные проблемы:
1. 2 раза запускается dropbear - вероятно бездумное копирование в несколько файлов.
2. Какой-то косяк с монтированием. Что в файле /etc/fstab ?
Если все устанавливать без подключения диска что будет с установкой ipkg и ipkg-opt?

Я настраивал по Вашей инструкции и вроде бы следовал точно по ней, подскажите что мне сделать чтобы все правильно работало?

vectorm
02-08-2008, 18:54
Я настраивал по Вашей инструкции и вроде бы следовал точно по ней, подскажите что мне сделать чтобы все правильно работало?
Моя инструкция расчитана на установку с 1 диском, с флешками + дисками не тестировал, ибо негде, поэтому не подскажу ...

Lan-profan
02-08-2008, 20:40
Замеченные проблемы:
1. 2 раза запускается dropbear - вероятно бездумное копирование в несколько файлов.
2. Какой-то косяк с монтированием. Что в файле /etc/fstab ?
Если все устанавливать без подключения диска что будет с установкой ipkg и ipkg-opt?

А по замеченным проблемам, как мне сделать чтобы дважды не запускался dropbear?

Если я откажусь от hdd, какие мои действия чтобы продолжить настройку устройства по инструкции (как решить имеющие проблемы с установкой пакетов)?

Lan-profan
04-08-2008, 20:50
С первым вопросом я решил – проблема была в файле fstab

Но ни чего ни могу решить со вторым вопросом, при попытки установки приложений такое пишет:

[89507705900@Server root]$ ipkg.sh install ipkg-opt
ipkg_get_install: ERROR: Cannot find package ipkg-opt in /opt/lib/ipkg/lists
ipkg_get_install: Check the spelling and maybe run `ipkg update'.
[89507705900@Server root]$ ERROR: Cannot find package ipkg-opt in /opt/lib/ipkg/lists
-sh: ERROR:: not found
[89507705900@Server root]$ ipkg_get_install: Check the spelling and maybe run `ipkg update'.
[89507705900@Server root]$ ipkg update
-sh: ipkg: not found
[89507705900@Server root]$ ipkg upgrade
-sh: ipkg: not found

AndreyPopov
04-08-2008, 21:01
С первым вопросом я решил – проблема была в файле fstab

Но ни чего ни могу решить со вторым вопросом, при попытки установки приложений такое пишет:

[89507705900@Server root]$ ipkg.sh install ipkg-opt
ipkg_get_install: ERROR: Cannot find package ipkg-opt in /opt/lib/ipkg/lists
ipkg_get_install: Check the spelling and maybe run `ipkg update'.
[89507705900@Server root]$ ERROR: Cannot find package ipkg-opt in /opt/lib/ipkg/lists
-sh: ERROR:: not found
[89507705900@Server root]$ ipkg_get_install: Check the spelling and maybe run `ipkg update'.
[89507705900@Server root]$ ipkg update
-sh: ipkg: not found
[89507705900@Server root]$ ipkg upgrade
-sh: ipkg: not found

мой вам совет: сделайте Restore to Factory Default - и все шаги сделайте с самого начала ПО ИНСТРУКЦИИ. "шаг влево или вправо" делать не надо. когда сделаете все по инструкции и все заработает, тогда будете "лишнее" выкидывать или добавлять свое.


поскольку у вас ДВА устройства хранения, то проследите какое из них монтируется ПЕРВЫМ, потому как второе устройство надо монтировать "РУКАМИ". а для нормальной работы ipkg нужна ext3 файловая система!

EugeenB
06-08-2008, 16:51
Помогите!!!Неободимо чтобы в /opt была подмонтирована файловая система ext3 из-за разрешения на файлы и софтлинков.
Убедитесь, что это требование выполнено!!!
Проверить можно командами: df и mount

Если это требование выполнено, и /opt доступна на чтение и запись, то выполняйте пошагово инструкцию http://wl500g.info/showpost.php?p=19984&postcount=2 , с пункта 7 а), со строчки: mkdir -p /opt/tmp/ipkg

pavlitsky
22-08-2008, 00:32
та же проблема с WL-500g Premium + Tsunami eDATA 3500 USB
причем один раз (из наверное полсотни включений с разными вариациями) всё заработало, определилось, разделы ext3 смонтировались, но после выключения коробки снова ошибка (-145)
печально.. деньги на ветер

xyls
02-09-2008, 15:00
Так удалось кому-нибудь подключить Tsunami eDATA 3500???
А то как раз его хотел купить, теперь думаю...
Вешать собираюсь на WL-500W.

pizzadox
28-09-2008, 21:59
Подскажите пожалуйста, как бы подключить винч с локалки.

velsi
29-09-2008, 07:54
Подскажите пожалуйста, как бы подключить винч с локалки.
моей фантазии не хватило на то, чтобы понять проблему... что точно надо?

Cd_spb
29-09-2008, 09:19
Может быть интересует "smbmount"? Тогда в поиск.

pizzadox
29-09-2008, 13:24
Скажем тогда по другому,

- есть комп в сети Роутера с разделом ехт3 его надо подрубить.

- только раздел создан из под винды, следовательно я его не вижу, и не могу расшарить.

вот собственно 2-е насущные проблемки

velsi
29-09-2008, 20:59
Скажем тогда по другому,

- есть комп в сети Роутера с разделом ехт3 его надо подрубить.

- только раздел создан из под винды, следовательно я его не вижу, и не могу расшарить.

вот собственно 2-е насущные проблемки
как можно под виндой создать раздел ext3?

на компе расшарь нужный диск, роутером его подхвати, а дальше раздавай как хочешь.

поиск по ключевому слову: "smbmount"

pizzadox
29-09-2008, 22:17
как можно под виндой создать раздел ext3?

на компе расшарь нужный диск, роутером его подхвати, а дальше раздавай как хочешь.

поиск по ключевому слову: "smbmount"

Спасибо, только вот как расщарить раздел ..... винда же,а создал,акронисом

velsi
30-09-2008, 06:05
Спасибо, только вот как расщарить раздел ..... винда же,а создал,акронисом
хм... я правльно понял, что есть видновый комп, где один из разделов диска создан под ext3? и винда его, естественно не видит?

Если так, то какой был потаённый смысл такого действия?

Отформатируй этот раздел под винду, и потом уже раздавай.

Megarem
23-02-2009, 19:08
Имеется: wl500gp, SATA 250GB 2.5'' винт, USB коробочка Sarotech, куплены недавно.
Суть проблемы: рутер работает круглосуточно на раздаче\скачке торрентов. Иногда происходит сбой, rtorrent падает, а в логе появляются сообщения про "scsi error". После этого сбоя рушится фс. Причем так, что уже не восстанавливается стандартным e2fsck.
Проблема повторилась уже дважды (оба раза где-то было не меньше недели аптайма). При попытке вылечить фc оба раза выдавалась ошибка о неправильном списке inodes. Я так понял, система пытается считать сектор с очень большим номером, которого на самом деле нет. Форматирование решает проблему. Со старым винтом и коробочкой рутер отпахал пару лет без проблем.
Что это может быть:
1. Глюки рутера (глючит USB чип)
2. Глюки коробочки
3. Глюки винта.
Есть идеи, как локализовать проблему? Могу сказать одно: это не связано с питанием (рутер и винт запитаны от мощного бп на 5 ампер) и вряд ли связано с перегревом (хотя хз, но дело точно не в перегреве рутера).
Пока попробовал вокнуть в другой USB порт. Посмотрим, что будет дальше.

al37919
23-02-2009, 19:38
проблема непростая. Однако, ИМХО:
1) питание!
2) провода usb
3) кривой переходник usb-sata

Обосную первый пункт, т.к. тема больная и для меня тоже в данный момент. Имеется usb хаб dlink dub7, кажется. Б/п маркирован как 3А/5В. Отпахал два года... И перестал раскручивать 2.5" SATA hdd с которым отработал больше года. Возникает вопрос --- либо б/п просел по току (ИМХО наиболее вероятно, т.к. раскрутка 2.5" hdd не должна быть больше 1А (ну даже если 1.5А по причине SATA)), либо проглючило hdd и он стал потреблять больше энергии --- ну разве если грязь в подшипниках завелась... (теор. возможно, но вряд ли). Тем более от двух дырок роутера и от ПК раскручивается успешно.

В общем, к чему я это все --- основная мысль, что к тому, что написано на б/п нужно подходить с осмотрением.

starpiv
02-03-2009, 23:14
Купил WD WDG2NC20000, подключил к Windows, запросила драйвер, без прилагаемого к девайсу диска установить не смогла.

Но тем не менее попробовал подключить к роутеру.
В логах нашёл вот что:



1 03:00:04 kernel: hub.c: USB hub found
Jan 1 03:00:04 kernel: hub.c: 4 ports detected
Jan 1 03:00:04 kernel: usb.c: registered new driver usblp
Jan 1 03:00:04 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 03:00:05 kernel: hub.c: connect-debounce failed, port 2 disabled
Jan 1 03:00:06 kernel: usb.c: registered new driver audio
Jan 1 03:00:06 kernel: audio.c: v1.0.0:USB Audio Class driver
Jan 1 03:00:06 kernel: hub.c: new USB device 01:03.0-2, assigned address 2
Jan 1 03:00:06 kernel: usb.c: USB device not accepting new address=2 (error=-145)
Jan 1 03:00:06 kernel: Linux video capture interface: v1.00
Jan 1 03:00:06 kernel: hub.c: new USB device 01:03.0-2, assigned address 3
Jan 1 03:00:06 kernel: usb.c: USB device not accepting new address=3 (error=-145)
Jan 1 03:00:06 kernel: SCSI subsystem driver Revision: 1.00
Jan 1 03:00:06 kernel: Initializing USB Mass Storage driver...
Jan 1 03:00:06 kernel: usb.c: registered new driver usb-storage
Jan 1 03:00:06 kernel: USB Mass Storage support registered.


Доступа к дискам так и не удалось получить.
Видимо эта штука не будет работать с роутером без какого-то специального драйвера?