PDA

Bekijk de volledige versie : pppd ip-up



ural
29-03-2008, 10:29
Народ, расскажите чайнику, как прописать команды (маршруты) в ip-up? в файле какая-то каша...

al37919
29-03-2008, 10:40
он там вообще бинарный. Пишите в /usr/local/sbin/post-firewall Он выполняется при каждом установлении соединения

ural
29-03-2008, 14:21
он там вообще бинарный. Пишите в /usr/local/sbin/post-firewall Он выполняется при каждом установлении соединения

не, post-firewall не прокатывает. помогло прописывание скрипта в конфиге



ip-up-script /opt/etc/ppp/up-script

naves
29-03-2008, 21:29
не, post-firewall не прокатывает.
какие-то у вас колеса квадратные :)
флешку сохраняете? и как вообще подключаетесь?

ural
31-03-2008, 16:13
какие-то у вас колеса квадратные :)
флешку сохраняете? и как вообще подключаетесь?


Подключаюсь ко второму соединению вот так:



[ural@asus_wl-500gp root]$ cat /usr/local/sbin/post-mount
#!/bin/sh

# ...удалил всякую всячину...
pppd file /opt/etc/ppp/options.wan1


а что про флешку? :) конфиг на usb-flash...

naves
03-04-2008, 12:01
http://wl500g.info/showthread.php?t=4658&highlight=ip-up
такой что-ли нужен?
настраиваем маршруты и нат в файле ip-up

#!/bin/sh

log=/tmp/ppp/log.txt
echo $0", "$1", "$2", "$3", "$4", "$5", "$6 >> $log
route add default dev $1 >> $log
iptables -t nat -A POSTROUTING -o $1 -j SNAT --to-source $4 >> $log

Antosha
07-06-2008, 22:21
Что-то поработал у меня VPN и перестал.
теперь при подключении он добавляет маршрут:


default * 0.0.0.0 U 0 0 0 ppp0

а вместо * должен быть ip подключения

Можно как-то решить такую проблему непонятную?

P.S.
Решилось после:


echo "$0", "$1", "$2", "$3", "$4", "$5", "$6" >> $log
route add default gw $4 dev $1 >> $log
iptables -t nat -A POSTROUTING -o $1 -j SNAT --to-source $4 >> $log