PDA

Bekijk de volledige versie : USB IDE-HDD Standby



eriche
14-03-2008, 07:33
Hello,

ich habe hier zwar etwas über ein SCSI-Stop-Script gelesen, dass es ermöglichen soll manche Festplatten in den Standby zu schicken - wollte jedoch nachfragen ob das auch für meinen Aufbau einen Versuch wert ist :confused:

Ich besitze einen AUSUS WL-500w an dem eine IDE-Festplatte in einem Externen USB-Gehäuse hängt.

Hat ja mit SCSI nichts zu tun :rolleyes:

Mit welcher Lösung stehen nun die Chancen am besten - damit die USB-HDD nach 10 Minuten inaktivität in den Standby geht :confused:

Für Tipps bin ich dankbar, denn 24/7 die Festplatte laufen lassen ist keine Lösung - da würde ich sogar auf die Festplatte verzichten - was ja schade wäre ;)

Greet`s Erich

wengi
14-03-2008, 07:53
Stör Dich nicht an dem SCSI.
Das läuft auch mit Deiner USB Platte.

In diesem Forum hat mit Sicherheit niemand eine SCSI Platte an seinem Asus (*ausdemfensterlehn*)

wengi

eriche
14-03-2008, 08:58
Wunderbar - dann werde ich das heute nach der Arbeit gleich mal testen :D
Mal sehen ob ich das hinbekomme - wenn nicht dann darf ich eh auf eure Hilfe zählen? ;)

Greet`s Erich

eriche
14-03-2008, 16:23
Wie befürchtet stehe ich an :eek:
Ich habe zur Zeit DD-WRT auf meinem ASUS WL-500W.


cd /usr/local/sbin
wget http://oleg.wl500g.info/bin/scsi-stop
chmod a+x scsi-stop

Diesen Pfad besitze ich nicht - deshalb habe ich das Tool hier herkopiert
/jffs/usr/sbin/scsi-stop


Please, ensure your login shell is /bin/sh and you run scsi-stop in it. cat /etc/passwd will help you to find out.

Hier kenne ich mich gar nicht aus

root@DD-WRT:~# cat /etc/passwd
root:xxx:0:0:Root User,,,:/tmp/root:/bin/sh
reboot:xxx:0:0:Root User,,,:/tmp/root:/sbin/reboot

Was sagt mir das jetzt :confused:

Dann habe ich folgendes gemacht


root@DD-WRT:~# /jffs/usr/sbin/scsi-stop /dev/scsi/host0/bus0/target0/lun0/disc
/dev/scsi/host0/bus0/target0/lun0/disc is not a SCSI block device
root@DD-WRT:~#
root@DD-WRT:~# cat /proc/scsi/usb-storage-0/0
Host scsi0: usb-storage
Vendor: Cypress Semiconductor
Product: USB2.0 Storage Device
Serial Number: DEF107679C83
Protocol: Transparent SCSI
Transport: Bulk
GUID: 04b468300000def107679c83
Attached: Yes
root@DD-WRT:~#

Bitte helft mir weiter - was läuft bei mir falsch?

Gruß Erich

ChrisP
15-03-2008, 12:47
Ich habe das selbe Problem. Habe Kamikaze installiert.
Wäre toll wenn uns jemand helfen könnte...

wengi
16-03-2008, 10:34
Hi,

Euch ist aber schon bewusst, dass ihr eine Software aus dem Oleg-Feed auf ein anderes Betriebssystem installiert.
Natürlich ist das auch Linux, aber da ist mit Sicherheit Handarbeit angesagt.

Ich kann Euch da nicht weiterhelfen, da ich weder dd-wrt noch kamikaze installiert habe.

Ich würde Euch dringend empfehlen den Versuch abzubrechen und im entsprechenden Forum des Firmwareherstellers zu fragen!

wengi

eriche
16-03-2008, 12:40
Ich habe OLEGS Firmware gestern auf meinem ASUS geflashed!

Einiges ging damit überraschend einfach über das WebInterface zu konfigurieren :D

JEDOCH

Wenn OLEGs Firmware keinen Client Bridge Mode unterstützt kann ich die Firmware mit meiner bestehenden Architektur nicht verwenden!

Siehe

http://wl500g.info/showthread.php?p=88357#post88357

Ich hoffe ich bekomme positives Feedback!

Gruß Erich

wengi
16-03-2008, 12:55
Ich habe zur Zeit DD-WRT auf meinem ASUS WL-500W.
Trotz der widersprüchlichen Aussage:
Wenn Du oleg drauf hast: Was geht denn nicht?
- Geht die Platte überhaupt aus? ( Wie hast Du das getestet/festgestellt?)
- geht Sie aus und dann wieder an?
- Seagate Platte?

wengi

chrispri
17-03-2008, 06:37
Danke für die Antwort!


Euch ist aber schon bewusst, dass ihr eine Software aus dem Oleg-Feed auf ein anderes Betriebssystem installiert.

Das dacht ich mir schon. Nachdem bei oleg ja nunmehr auch das USB-Modem unterstützt wird werd ich umsteigen.

Bzgl. der widersprüchlichen Aussage von eriche. Er schrieb ja:

Ich habe OLEGS Firmware gestern auf meinem ASUS geflashed!

Tuxlover
17-03-2008, 15:34
Wenn OLEGs Firmware keinen Client Bridge Mode unterstützt kann ich die Firmware mit meiner bestehenden Architektur nicht verwenden!


Du hast das hier (http://wl500g.info/showpost.php?p=6094&postcount=1) schon versucht?

Tuxlover

eriche
17-03-2008, 17:36
@Wengi


Trotz der widersprüchlichen Aussage

bitte genauer lesen - ich hatte DD-WRT oben und habe wegen dem Standby Tool auf OLEG geflashed ;)

Jedoch habe ich dann noch keine weiteren Tests bezüglich HDD-Stop gemacht!

Mir ist dann aufgefallen, dass ich bei OLEG - im WebInterface nicht auf Client Bridge Mode umschalten kann,... :eek:
Somit habe ich im Englischen Forum mein Problem gepostet - um mehr Leute damit zu erreichen ;)

@Tuxlover

Das könnte ich mal probieren!
cooper.zl scheint jedoch trotzdem Probleme damit haben - die nicht gelöst wurden :rolleyes:

Greet`s Erich

Tuxlover
17-03-2008, 17:59
cooper.zl scheint jedoch trotzdem Probleme damit haben - die nicht gelöst wurden :rolleyes:

Greet`s Erich

Die Probleme kamen IMHO von einer Firewall.

Ich habe noch eine halb-OT Anmerkung zu Deinem HD-Problem.
Ich habe mal gerade im DD-WRT-Forum gestöbert. Hattest Du von DD-WRT so ein Jumbo-Image installiert, bei dem Webcam-Server, Samba, NFS und das ganze Zeugs dabei waren und ein Teil des OS auf die HD ausgelagert wird? Es kann nämlich sein, dass von DD-WRT ständig zugegriffen wurde und die Platte deshalb nicht zur Ruhe kam.

Nachtrag:
Hast Du Dir schon bei Wireless/Advanced/Extended Mode die möglichen Modi angesehen. Ich kann hier nicht testen, ob da nicht der für Dich passende Modus dabei wäre.

eriche
17-03-2008, 18:51
@Tuxlover

ja ich hatte ein Image mit vielen Dingen.
Jedoch dürfte folgende Meldung nicht erscheinen


root@DD-WRT:~# /jffs/usr/sbin/scsi-stop /dev/scsi/host0/bus0/target0/lun0/disc
/dev/scsi/host0/bus0/target0/lun0/disc is not a SCSI block device

Auf der Seite hier im Forum - quasi die Quelle des STOP-Scripts - scheinen auch einige Festplatten nicht zu funktionieren :rolleyes:

Und auch wenn wengi meint, dass das am DD-WRT lag - glaube ich das nicht,...


Wireless/Advanced/Extended Mode

Wenn du das im OLEG Image meinst, dann habe ich dort schon einiges versucht - aber ich gebe eh nicht so schnell auf - werde noch mehr testen

Auch wenn ich gerne von den Machern der OLEG Firmware hören würde, dass sie "CLient BRIDGE MODE" unterstützen ;)

Greet`s erich