PDA

Bekijk de volledige versie : Twonky media server und asus



ryoku
13-03-2008, 19:27
hi jungs, hoffe auf hilfe....

hab die tutorials jetzt durch und das ding laeuft super, torrent, ftp, telnet samba usw.... jedoch mein twonkymedia, wo ich mir eine lizenz gekauft habe, kann auf die festplatte nicht zugreifen.. wenn ich auf die konfig geh und auf den browser zeigt er mir keines der freigebenen laufwerke an bzw. er zeigt mir die dateien innerhalb nicht an..
mit samba share kann ich dort drauf.
berechtigungen wie folgt:

drwxrwxrwx 3 nobody nobody 4096 Mar 13 05:56 music
drwxrwxrwx 2 nobody nobody 4096 Mar 13 06:18 videos

hat jemand rat? ich versteh naemlich leider nicht...pls help...

ryoku
14-03-2008, 04:56
!!!!!*push*!!!!!

WLAN-Fan
14-03-2008, 07:46
Hi,

ich habe diesen Server nicht. Aber es gibt hier einen Thread wo steht das der Twonky Media Server nicht mehr für die ASUS Geräte geht. Eventuell hängt dort der Wurm.

Du könntetst ja mal ausführlich unterteil beschreiben was du gemacht hast.
Wenig HowTo aber nee mit wiederholen. Sondern nur was du mit dm Twonky Media Server gemacht hast.

Gruß.

wengi
14-03-2008, 07:50
Die Konfiguration des twonky wäre hilfreich...

ryoku
14-03-2008, 14:41
Hi,
danke fuer die Antworten.
Hab das TUt gleich nach wengi's gelesen (super echt hammer, danke! laeuft alles, bis eben auf twonky).
habs runtergeladen die version 4.4
installiert nach usr/local/twonky und in der postboot start ich den twonky mit &
config oberflaeche seh ich alles, kann ich einstellen tod und teufel
aber im medienbroser seh ich nichts.
hier die ini. hab nru den registration key rausgeloscht und dydns adresse..
twonkymedia.ini (http://www.jbauer.eu/files/twonkyvision-mediaserver.ini)
danke fuer eure hilfe im vorraus!

ryoku
15-03-2008, 09:30
hat jemand eine idee?

ryoku
15-03-2008, 13:14
14:07:28:871 LOG_SYSTEM:NO TRANSLATION FOR accessuser
14:07:28:875 LOG_SYSTEM:NO TRANSLATION FOR accesspwd
14:07:28:878 LOG_SYSTEM:NO TRANSLATION FOR autotree
14:07:28:883 LOG_SYSTEM:NO TRANSLATION FOR clearclientsonrestart
14:07:28:887 LOG_SYSTEM:NO TRANSLATION FOR codepage
14:07:28:891 LOG_SYSTEM:NO TRANSLATION FOR contentbase
14:07:28:897 LOG_SYSTEM:NO TRANSLATION FOR dlnastrict
14:07:28:907 LOG_SYSTEM:NO TRANSLATION FOR livevideoname
14:07:28:910 LOG_SYSTEM:NO TRANSLATION FOR liveradioname
14:07:28:913 LOG_SYSTEM:NO TRANSLATION FOR maxmem
14:07:28:923 LOG_SYSTEM:NO TRANSLATION FOR allradio
14:07:28:940 LOG_SYSTEM:NO TRANSLATION FOR platform
14:07:28:948 LOG_SYSTEM:NO TRANSLATION FOR startupmb
14:07:28:960 LOG_SYSTEM:NO TRANSLATION FOR v
14:07:28:971 LOG_SYSTEM:NO TRANSLATION FOR webnodes
14:07:28:974 LOG_HTTP:HTTP_send_header HTTP/1.1 200 OK
Content-Type: text/html; charset=utf-8
Content-Length: 2
Date: Sat, 15 Mar 2008 13:07:28 GMT
Accept-Ranges: bytes
Connection: close
Expires: 0
Pragma: no-cache
EXT:
Server: Linux/2.x.x, UPnP/1.0, pvConnect UPnP SDK/1.0


hilft das was?

ryoku
15-03-2008, 13:16
guckt mal

14:08:34:082 [Error] - LOG_SYSTEM:restart needed because option musicnode1 has changed
14:08:34:084 [Error] - LOG_SYSTEM:restart needed because option musicnode2 has changed
14:08:34:084 [Error] - LOG_SYSTEM:restart needed because option musicnode3 has changed
14:08:34:085 [Error] - LOG_SYSTEM:restart needed because option musicnode4 has changed
14:08:34:085 [Error] - LOG_SYSTEM:restart needed because option picturenode1 has changed
14:08:34:086 [Error] - LOG_SYSTEM:restart needed because option picturenode2 has changed
14:08:34:086 [Error] - LOG_SYSTEM:restart needed because option videonode1 has changed
14:08:34:341 LOG_SCANfilescanner thread started
14:08:34:343 scanning
14:08:34:343 scanning
14:08:34:344 scanning
14:08:34:345 adding /tmp/harddisk/ftp_pub/test/Deichkind - Krawall Remmidemmi (Yippie Yippie Yeah).mp3
14:08:34:350 added /tmp/harddisk/ftp_pub/test/Deichkind - Krawall Remmidemmi (Yippie Yippie Yeah).mp3
14:08:34:351 adding /tmp/harddisk/ftp_pub/test/scrubs-lightbulb.jpg
14:08:34:357 added /tmp/harddisk/ftp_pub/test/scrubs-lightbulb.jpg
14:08:34:358 adding /tmp/harddisk/ftp_pub/test/Alex Gopher & Demon - Long Island.mp3
14:08:34:363 added /tmp/harddisk/ftp_pub/test/Alex Gopher & Demon - Long Island.mp3
14:08:34:364 scanned /tmp/harddisk/ftp_pub/test


er findet ja sgoar ein mp3 aber er zeigts parttout nicht an :-(

ryoku
15-03-2008, 14:15
hi jungs


15:05:43:475 LOG_DB:creating Database
15:05:43:606 LOG_DB:invoking initial database build
15:05:43:607 LOG_SYSTEM:upnp_file_open_write file open write error "./twonkymedia.db/4.4.4"
15:05:43:607 LOG_SYSTEM:upnp_file_open_write file open write error "./twonkymedia.db/twonkymedia.main.db"

das hab ich noch gefunden im log anscheinend darf er in das verzeichnis nicht schreiben???

wengi
16-03-2008, 11:02
15:05:43:475 LOG_DB:creating Database
15:05:43:606 LOG_DB:invoking initial database build
15:05:43:607 LOG_SYSTEM:upnp_file_open_write file open write error "./twonkymedia.db/4.4.4"
15:05:43:607 LOG_SYSTEM:upnp_file_open_write file open write error "./twonkymedia.db/twonkymedia.main.db"
Hi,
das scheint das Problem zu sein.
Versuche doch mal die ini anzupassen:

# MediaServer database directory
dbdir=/opt/twonkymedia.db
/opt ist auf jeden Fall beschreibbar, wenn Du nach meinem HowTo installiert hast.
mit dem dbdir=./twonkymedia.db wird die DB dort angelegt, wo der twonky gestartet wird.
Das könnte das Problem sein.

Gib dann mal Rückmeldung
wengi

ryoku
16-03-2008, 12:57
hi wengi,

danke fuer den tipp... es haut jetzt super hin!
nur leider trennt die ps3 die verbindung zum medienserver nach ca 15 sekunden und stellts dann wieder her wenn ich ein file von der festplatte anspreche und verwenden will..
ich weiß nicht genau was da ist aber es schaut fast so aus als wuerde der server durchstarten?!

ryoku
16-03-2008, 18:36
hat sonst jemand diese erfahrung gemacht?

ryoku
17-03-2008, 05:06
mir ist jetzt aufgefallen, dass er von selbst immer wieder die verbindung abbricht?
hat wer ne idee?

Es kommt die Meldung "Die Verbindung zwischen PS3 System und Medienserver wurde getrennt."

06:02:18:172 LOG_HTTP:HTTP_send_receive GET /DeviceDescription.xml HTTP/1.1
Host: 192.168.1.1:9000
Date: Sun, 18 Mar 2007 06:04:57 GMT
User-Agent: UPnP/1.0
X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment"; mn="PLAYSTATION3"; mv="1.0";


06:02:18:175 LOG_HTTP:HTTP_send_header HTTP/1.1 200 OK
Content-Type: text/xml; charset="utf-8"
Content-Length: 2051
Date: Mon, 17 Mar 2008 05:02:18 GMT
Accept-Ranges: bytes
Connection: keep-alive
EXT:
Server: Linux/2.x.x, UPnP/1.0, pvConnect UPnP SDK/1.0


06:02:18:177 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0
06:02:18:178 LOG_HTTP:HTTP_send_receive received no header in HTTP_send_receive, propably client closed socket, URL=http://192.168.1.1:9000/


das is anscheinend die fehlermeldung ?

ryoku
17-03-2008, 05:12
06:04:52:660 LOG_HTTP:HTTP_send_receive GET /disk/DLNA-PNMPEG_PS_PAL-OP01-FLAGS01700000/video/O3$51$2758057517.mpg HTTP/1.1
Host: 192.168.1.1:9000
User-Agent: PLAYSTATION3
Connection: Keep-Alive
Accept-Encoding: identity
Range: bytes=20054016-20840447


06:04:52:661 LOG_HTTP:HTTP_send_header HTTP/1.1 206 Partial Content
Content-Type: video/mpeg
Content-Length: 786432
Date: Mon, 17 Mar 2008 05:04:52 GMT
Last-Modified: Wed, 08 Aug 2007 00:16:04 GMT
Accept-Ranges: bytes
Connection: keep-alive
Content-Range: bytes 20054016-20840447/824736472
transferMode.dlna.org: Streaming
EXT:
Server: Linux/2.x.x, UPnP/1.0, pvConnect UPnP SDK/1.0


06:04:56:389 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0
06:04:56:402 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0
06:04:56:631 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0
06:04:56:872 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0
06:04:57:089 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0


ich koennte wahnsinnig werden ich sags euch!

wengi
17-03-2008, 10:36
Also wenn twonky sich selbst beendet solltest Du irgendetwas in den logs finden.
Entweder /opt/var/log/messages oder ein eigenes log des twonky.

wengi

ryoku
17-03-2008, 11:56
hi wengi,

danke fuer die antwort.
aber was ich aus den logs vom twonky gesehen habe, hab ich eh gepostet. die error message.
sagt dir die etwas?

wengi
17-03-2008, 13:59
06:04:57:089 [Error] - LOG_HTTP:HTTP_get_header Cannot receive header, clientSocket=14, nBytesReceived=0Falls Du das hier meinst: Das ist eine Fehlermeldung vom Webserver.
Wirklich weiterhelfen kann ich Dir nicht.

wengi

ryoku
17-03-2008, 14:16
ja hab die logs auch an den twonkysupport geschickt aber die haben nur gesagt der wl500 wird nicht mehr unterstuetzt.....
und ich arsch die lizenz gekauft..grml


das die fehlermeldung vom webserver ist war mir schon klar, ich dachte nur vielleicht muss ich da irgendwo ein setting auf persitence setzen oder so aber ich finde eine solche einstellung nicht...es sieht naemlich nicht so aus akls wuerd der server durchstarten fuer das ist er zu schnell wieder da aber ichkann ansonsten den fehler nicht identifizieren...