PDA

Bekijk de volledige versie : Не работает SSH "наружу"



savovich
26-02-2008, 21:51
Сделал всё как описано здесь:
http://wl500g.info/showthread.php?t=3171
SSH работает только из-под локальной сети. А нафига он нужОн из под локальной сети-то? Ни у кого не было такой же проблемы?

djet
26-02-2008, 21:55
Сделайте вывод:

iptables -L -nv
iptables -L -nv -t nat

bocman
28-02-2008, 07:39
Сделайте вывод:

iptables -L -nv
iptables -L -nv -t nat

Подскажите, пожалуйста, на форме упоминаются раличныые комманды, но на сколько я понимаю ,часть из них прописывается где-то и после презагрузки остается активна, а часть нет и их надо в шелл-скриптах прописывать...

вот как понять, надо ли комманды прописыват в шелл скриптах?
Вот, например, приведенные в цитате?

Вот, кстати, выполнил эти комманды, после тех, которые в руководстве по настройке с нуля, и перезагрузился... ssh изнури работает, а через инет - нет...

twinsys
28-02-2008, 09:07
Если у тебя есть внешний IP, или у твоего провайдера настроено так, что твой компьютер видно из интернета то все просто
Проверь что у тебя в файле /usr/local/sbin/post-firewall (исполняется всякий раз, после того как устройство меняет внутренние правила с помощью команд iptables, с тем, чтобы Вы могли внести свои изменения в firewall)
есть строчка iptables -I INPUT -p tcp --dport 22 -j ACCEPT
если нет, надо ее туда добавить, потом не забыть сохранить изменения
flashfs save
flashfs commit
flashfs enable
после можно перезапустить роутер (reboot)
проверить что правило в INPUT port 22 ACCEPT есть можно запустив 'iptables -L –nv'
после можно проверить видно твой компьютер из интернета или нет http://www.utorrent.com/testport.php?port=22
если напишет ОК то все вышло!
если нет то твой компьютер не видно из инета и тебе нужно прикупить у провайдера внешний IP

bocman
28-02-2008, 09:17
Спасибо! Попробую.
Внешний IP есть.

только для меня не понятен все-таи такой вопрос, если я напишу команду
iptables -I INPUT -p tcp --dport 22 -j ACCEPT
а потом
flashfs save
flashfs commit
flashfs enable
и перезгружусь,
первая комманда соханиться где-нибудь?

twinsys
28-02-2008, 10:00
НЕТ!
эту сторочку надо прописать в файл /usr/local/sbin/post-firewall
вот пример что у меня в файле post-firewall
------------------------------------------------
#!/bin/sh

#для SSH
iptables -I INPUT -p tcp --dport 22 -j ACCEPT

#Для FTP port 2233
iptables -I INPUT -p tcp --dport 2233 -j ACCEPT
------------------------------------------------
этот файл можно создать так
#Создаем каталог /usr/local/sbin/
mkdir -p /usr/local/sbin/
#Записываем строчку #!/bin/sh в файл post-firewall
echo "#!/bin/sh" >> /usr/local/sbin/post-firewall
#Добавляем разрешение на запуск
chmod +x /usr/local/sbin/post-firewall
после надо добавить в этот файл iptables -I INPUT -p tcp --dport 22 -j ACCEPT
и осталось только все сохранить
flashfs save
flashfs commit
flashfs enable

bocman
28-02-2008, 10:27
понял, спасибо!