PDA

Bekijk de volledige versie : Диагностика железа



Sheeft
17-02-2008, 17:27
Люди, посоветуйте как можно нормально и досконально проверить железку (wl500gP)..

Предыстория:
После некоторых проблем с питанием - падение напряжения на 1/2, отключение, кз, отключение под нагрузкой и.т.д.
(чудак электрик умудрился вырубить рубильник на целый 6ти подъездный дом в вечернее время, на компе это отразилось сгоранием БД, на роутере опишу ниже)

Последствия:
Как роутер железка работает на ура (тфу тфу тфу)...
Но стоит подумать о чем то большем - скрипты, программы... и на этом работа заканчивается. После установки ipkg и mc ssh/telnet вылетает убивая процессы с ошибкой нехватки памяти (out of memory)...
Полное обнуление софта, прошивки, flashfs и nvram не помогает :-(

Заранее огромное спасибо, буду рад любой помощи =)

Oleg
17-02-2008, 17:30
Так может память банально заканчивается? Ну скажем, забит /tmp чем-то...

Sheeft
17-02-2008, 19:06
Чистил естественно...

Oleg, а есть возможность полного очищения роутера, до состояния "из магазина", или всё прийдеться делать ручками ?
Хотелось бы убить всё что было, все файлы и настройки, весь хлам (логи, ридмихи итд)

Oleg
17-02-2008, 19:15
erase /dev/mtd/3
erase /dev/mtd/4
reboot

MMike
17-02-2008, 19:16
До кучи стоило бы проверить внешний БП.

Sheeft
17-02-2008, 19:28
erase /dev/mtd/3
erase /dev/mtd/4
reboot
Уже пробовал раза 2, не помогло :(


До кучи стоило бы проверить внешний БП.
Напряжение в разумных пределах, да и как роутер работает без перебоев.


Кстати! Забыл упомянуть, когда были перепады напряжения сдох корпус для харда (моделька в подписи), комп перестал его определять... Жесткий жив =) Может он муть какую в USB подал и тот чтото сжег ?!

Oleg
17-02-2008, 19:44
Если он сдох, то куда Вы пакеты ставите?

Sheeft
17-02-2008, 20:09
На флешку =]
После того как сдох корпус вместо харда воткнул в USB флешку 2GB Kingston, разбил и отформатировал силами роутера...

На данный момент получаеться так - ставлю ipkg, ставлю некоторые пакеты (какие позволяет), flashfs & reboot...
После перезагрузки ipkg not found... при том что диск смонтирован.