PDA

Bekijk de volledige versie : Kein Zugriff per NFS + Samba+Mac Problem



tuxianer
09-02-2008, 15:54
hallo,
ich habe meine NFS freigabe unter Mac gemountet aber ich kann nur lesen und nicht schreiben. Sie ist mit rw gemountet. Via Samba von Windows kann ich allerdings schreiben, löschen etc.

Dann habe ich noch ein Problem mit Samba in Verbindung mit MacOs. Auf dem Windowscomputer kann ich auf die Freigabe zugreifen. Wenn ich versuche mit Mac drauf zu zugreifen kommt eine Passwort abfrage. Ich habe dort schon alles mögliche probiert, aber ich komme nicht rein...

wodnik7
09-02-2008, 19:20
hallo,
ich habe meine NFS freigabe unter Mac gemountet aber ich kann nur lesen und nicht schreiben. Sie ist mit rw gemountet. Via Samba von Windows kann ich allerdings schreiben, löschen etc.


Hallo

ich habe es zum laufen gebracht, es hängt mit dem parameter in nfs ab, ich glaube, insecure muss rein. genaues kann ich dir leider gerade nicht sagen, da meine wlhdd nicht zugreifbar ist (habe nmich ausgeperrt, tstst)

tuxianer
09-02-2008, 19:49
ja insecure sorft für ma kompatibilität aber mit klappt es leider auch nicht. Ich habe nur lese Rechte keine Ahnung wieso...

fakehero
11-02-2008, 11:57
wahrscheinlich fasel ich grad völlig an der Fragestellung vorbei, aber ich habe Samba erst zum Laufen gebracht, als folgende Einstellungen in der Konfiguration waren

workgroup = WORKGROUP
netbios name = NAME_DER_WL-HDD
hosts allow = IP_BEREICH_EINTRAGEN
guest account = admin
security = share
browseable = yes
guest ok = yes
guest only = no
log level = 1
max log size = 100
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_SNDBUF=8192

bei mir läuft Samba nur, wenn eine einzige Freigabe gesetzt wurde...

[tmp]
path=/tmp/harddisk/FREIGABEORDNER
read only = no
guest ok = yes
writeable = yes
browseable = yes
public = yes

... wo jeder alle Rechte hat
chmod 755 /tmp/harddisk/FREIGABEORDNER

merkwürdig ist allerdings, dass es unter Windows klappt. Das war bei mir nicht der Fall, also versuchs vielleicht erst mal mit dem chmod (¿?)
Mit den Einstellungen kann ich mich unter OSX jedenfalls als Gast anmelden und werde nicht nach einem Passwort gefragt...

edit: ich hab die neuste FW mit Samba3 am laufen

Gruß

wodnik7
21-02-2008, 14:57
Hallo,

wie versprochen: bei mir läuft es auf dem Leo mit (rw,insecure,async)

Gruß, Michael