Bekijk de volledige versie : WL-500W FTP from Wan side (orig. Firmw)

01-02-2008, 13:12
Hey Freaks,
I gave my best - I cannot access my ftp from wan,
Is it possible to access from outside to the ftp with the original firmware?
And if?! how!
(Virtual server: 20->20 21->21, firewall opened for all adresses 20:21->20:21, can access locally)

Please help me out,


13-02-2008, 11:50
Thanks for your help friends :-/

Well, i found this in the Asustek Forum, didn't try it, though this solution sounds a bit strange to me - why do I put the Wan-address in? And is this save? What about dynamic addresses?

hoping for more response this time,


I have a WL-700gE Router and had trouble getting the ftp to work. I read the forums and it seemed many people had the same problem. I finally figured out what I was doing wrong and if you was like me then this should help you.
1st. succesfully update firmware to 1078

2nd. make sure your dyndns account is setup properly and it receives succesful ping replies.

3rd. create a share folder and switched to user based login. make sure the shared folder has everything enabled (nfs cifs ftp www).

4th. create a user account and gave him/her full access to the newly created share

5th This is where I was making my mistake.
At the Virtual Server Window when you open ports make sure that where it says Local IP you put your external(public) IP not your internal. so where it says port range it should be 20:21 and where it says Local IP it should say for example and where it says local port it should say 21.

This worked for me I didnt need to disable Internet firewall either.

I hope this helps Good Luck.

13-02-2008, 12:11
By the way - Samba is accessible from outside! Strange Router :-D
I'll use smb then for a while instead of ftp
but still i'm wondering why the ftp doesn't act normally

25-02-2008, 19:49
you can use port forwarding (NAT -> virtual server) to put FTP on the wan.
Please do notice that somehow the router doesn't always accept passive FTP connections from the wan, so you need to use active. Windows only knows passive, so you would need a different client ;)