PDA

Bekijk de volledige versie : mc



mistral
13-01-2008, 01:12
:confused:
wl500gp
прошивка 1.9.2.7-7g
поставив себе ipkg, начал ставить полезный софт и не обнаружив в списке горячо любимого midnight commander'a начал разбираться.
Скачал и поставил ручками uclibc-opt_0.9.28-12_mipsel.ipk и uclibc-opt_0.9.28-12_mipsel.ipk. Скачал mc_4.6.1-3_mipsel.ipk но при установке он у меня потребовал зависимость glibc. Нашел и скачал glibc atk_1.9.0-2_mipsel.ipk, но он при установке требует того же glibc.
Помажите кто чем может, что с этим сделать?

mistral
13-01-2008, 01:17
Видимо, три часа ночи все же не лучшее рвемя для такой работы. Нашел и поставил glibc - все встало.
Огромное человеческое спасибо людям все это написавшим :)

angel_il
13-01-2008, 09:41
ну попробуй уж таки mc с поддержкой utf :)
http://wl500g.info/showthread.php?t=11483

hans0n
14-01-2008, 13:20
ребят, извините за глупый вопрос.
Поставил mc, запустил, а когда нажимаю на клавиатуре стрелочки для управления курсором, вместо того чтобы курсор двигался внизу вылезают какие-то буквы.
Вообще непонятно что надо делать.
Причем это и из putty и из виндового cmd.

подскажите что я не так делаю :)

Mam(O)n
14-01-2008, 16:40
подскажите что я не так делаю :)
В факе это есть:

ipkg install ncurses
echo 'export TREM=xterm
export TREMINFO=/opt/share/terminfo' >> ~/.profile
flashfs save && flashfs commit && flashfs enable

al37919
14-01-2008, 16:53
TERM=xterm
TERMINFO=/opt/share/terminfo
а дальше если что не так в самом mc в опциях есть настройка клавиш.

hans0n
14-01-2008, 18:54
большое вам спасибо, ребята.
От души :)

Lopuh
29-03-2008, 17:17
Добавил в файл post-boot как сказано в теме wl500gp c нуля до torrent (transmission) (http://wl500g.info/showthread.php?t=12209) эти строки:


export TERMINFO="/opt/share/terminfo"
export TERM="linux"

и все равно при перезагрузке роутера приходится вбивать их в терминале, иначе в mc все серое и кнопки не работают. Как это исправить?

ps
xterm вместо linux тоже пробовал, не помогает.

Lopuh
29-03-2008, 17:29
...Как это исправить?...

Разобрался, добавил к post-boot'у файл .profile, заработало:)