PDA

Bekijk de volledige versie : VPN Passthrough supported in Oleg?



uffez
12-01-2008, 12:19
Hi, Ive installed OpenWrt on my WL-500GP and it works excellent with Xwrt-GUI. BUT, I simply cannot succeed to provide VPN Passthrough for a connection from an XP-laptop on my network towards a server at work.

I have had it working before on a Linksys WRT-54GL without having to do anything basically using DD-WRT. But, I have tried Tomato on it without any success.

And, now I have also failed with OpenWrt on my new ASUS. So, before doing any changes I need some hints - can I expect VPN Passthrough (using IPSEC) to be supported using Oleg on my ASUS. Or do I have to re-flash with DD-WRT?

I have fiddled around with lots of different IPTABLES-changes (opening port 50, 500, 4500 and so on) - but it never ever works. The tunnel is established, but there is nothing transferred - every time the down-link transmits 144 bytes and then it stops. Using tcpdump Im able to see that signalling seems OK and the tunnel is established using p 500 - but nothing is transmitted to the server...

BTW - can I find a description of how to re-flash Oleg from my current OpenWrt? What are the steps to be done?

Many thanks in advance for any help!

mariusz
16-01-2008, 20:10
I have fiddled around with lots of different IPTABLES-changes (opening port 50, 500, 4500 and so on)


50 is not a port but ip protocol number


M.

newbiefan
19-01-2008, 19:02
It should work, see

http://wl500g.info/showthread.php?t=18&highlight=VPN+passthrough

Marius
18-02-2008, 19:31
Hello,

I use successful a PPTP tunnel through the WL500gP, firmware beeing 1.9.2.7-8.
It worked also with the previous version.
I forwarded port 1723/TCP to the local tunnel endpoint machine, as stated by the PPTP docs, but it doesn't seem necessary, since it works without it, even from multiple machines at once (desktop+laptop from the local net to the same server).

Greetings!