PDA

Bekijk de volledige versie : Проблема с закачкой файла на USB-носитель



Red1C
19-11-2007, 12:50
На WL-500GP(1.9.2.7-7g) возникла проблема - не закачивается определенный файл на внешний носитель, ни через виндовую шару, не по FTP. Винды выдают ошибку отложенной записи, то же самое на ноуте через WiFi(при этом еще и беспроводное соединение рвется, правда потом восстанавливается). Самое странное, что остальные файлы больших и меньших размеров качаются спокойно, проблема именно с конкретным файлом - некий iconv.dll(библиотека т.н. ускорителя Sprint 2 спутникового провайдера Радуга). Такое впечатление что роутер что-то там проверяет в содержимом файла и не дает закачать файл. Пробовал писать как на флэшку(FAT32), так и на внешний жесткий диск(Ext3fs) - результат одинаков. Установка новой прошивки не помогла, а вот с последней прошивкой от Асуа(официальной) все нормально, правда винт пришлось на Ext2fs форматировать. Может кто сталкивался с подобным?

В журнале при этом нечто такое
Jan 1 03:02:39 smbd[139]: [1970/01/01 03:02:39, 0] smbd/oplock.c:request_oplock_break(1204)
Jan 1 03:02:39 smbd[139]: request_oplock_break: no response received to oplock break request to pid 132 on port 1024 for dev = 801, inode = 73
Jan 1 03:02:39 smbd[139]: for dev = 801, inode = 73, tv_sec = 6c, tv_usec = 27e2e

ABATAPA
21-11-2007, 14:49
На WL-500GP(1.9.2.7-7g) возникла проблема - не закачивается определенный файл на внешний носитель, ни через виндовую шару, не по FTP.

Переименовать файл пробовали?
Залить другой под этим именем?

Если нет - то почему? :)

Red1C
21-11-2007, 20:55
Глюк после очередной перепрошивки вроде пропал. Самое интересное, что переименование не помогало. Был еще более странный глюк - переставали открываться файлы Word с носителя(жесткого диска), копируются с носителя на комп нормально, но не открываются. Причем, после перезагрузки роутера могут перестать открываться те которые открывались до этого, и соответственно наоборот, т.е. на носителе они похоже целые, но при чтении повреждаются. Ради интереса взял и проанализировал битый и исправный вариант одного документа. У всех таких документов поврежден 76 байт от начала. В общем полтергейст какой-то, винт 100% исправный.

Ну и напоследок добавлю про Wi-Fi, отваливается через какое-то время после включения роутера, даже если им не пользоваться. Похоже что-то там перегревается, вентилятор сверху на корпус решает вроде проблему(хотя иногда все равно отваливается). Мож куда там радиатор приклеить?

Сорри, если несколько сумбурно :-).