PDA

Bekijk de volledige versie : how to enable a option in the kernel ?



strubbl
11-11-2007, 01:02
Hi,

I need to get my soundcards working on a 2.0 Hub.

I found out what to do:
enable the CONFIG_USB_EHCI_SPLIT_ISO option in the kernel
http://www.nslu2-linux.org/wiki/Peripherals/AudioAdapter

But how to do that? I searched a bit with google and all i found where tutorials how to recompile the kernel. Do I really have to do that?

zheka_ppp
11-11-2007, 13:13
imho, this option only valid for kernel 2.6 and alsa package.

My workaround is to use 1.1 USB hub for 1.1 devices and 2.0 hub for 2.0 devices.

strubbl
11-11-2007, 15:12
imho, this option only valid for kernel 2.6 and alsa package.

"Note that there have been reports of problems with USB 1.1 sound cards connected through USB 2.0 hubs, at least with the 2.4 kernel. These appear to have been resolved in the kernel 2.6 drivers; another possible solution is to enable the CONFIG_USB_EHCI_SPLIT_ISO option in the kernel as described here:" (http://wiki.openwrt.org/UsbAudioHowto)

... seems like this option is for 2.4 - with 2.6 it will work anyway? And I assumed that the sound-module in oleg's fw is alsa?


My workaround is to use 1.1 USB hub for 1.1 devices and 2.0 hub for 2.0 devices.

yeah, that's my current workarround too - but that's a bit uncomfortable, as I need one soundcard directly at the router and the other one in my room, where also my USB2.0 Printer is. So I would have to install another cable :/


... so, is there another way to enable this option than recompiling the kernel? And is recompiling that hard?

zheka_ppp
11-11-2007, 16:55
And I assumed that the sound-module in oleg's fw is alsa?


Definitly no ! There's no alsa package in repositary.




... so, is there another way to enable this option than recompiling the kernel? And is recompiling that hard?

I've set up ubuntu in vmware, installed everything needed for compiling firmware and managed to compile it.
But I couldn't find in sources (*.c,*.h) this option !

Good luck !

strubbl
11-11-2007, 17:04
I wrote to oleg and he confirmed:

Looks like this option is not available in 2.4.20 kernel. Sorry.


damn! seems like I have to reorganize all my wires and hubs :(
... but at least thats a variety to sitting all day in front of the ssh-console :D