PDA

Bekijk de volledige versie : Client mode with NAT on WL-500b/g



Technik
22-01-2004, 14:01
This is the working command sequence for manual IP address assignment (WL-500b was set to AP only mode by web
configurator first).
WARNING - I did not think about any security settings yet so please take this settings as an example only.

brctl delif br0 eth2
ifconfig eth2 down
rmmod wl
echo 1 > /proc/sys/net/ipv4/ip_forward
insmod /mnt/usbfs/wl_apsta.o # file path to root of the USB flash disk - not necessary if you copy wl_apsta.o to /tmp folder using FTP
# (see the wl_apsta.o attached)
# reply: Using /mnt/usbfs/wl_apsta.o
ifconfig eth2 AB.CD.EF.GH netmask 255.255.255.0 up # AB.CD.EF.GH = concrete IP address granted by Access Point Administrator
wl ap 0
wl scan
wl scanresults

#reply must be something like:
# SSID: "AP.Node"
# Mode: Managed RSSI: -71 dBm noise: -98 dBm Channel: 8
# BSSID: 00:01:23:AB:CD:EF Capability: ESS
# Supported Rates: [ 1(b) 2(b) 5.5 11 ]
#
# some other APs can be listed as well

wl join 'AP.Node'
route add default gw CD.EF.GH.IJ eth2 # CD.EF.GH.IJ = gateway address
# udhcpc -i eth2 -s /bin/true # optional - if there's a DHCP server running on wireless network

# NAT activation:
iptables -t nat -P POSTROUTING DROP
iptables -t nat -A POSTROUTING -o eth2 -j MASQUERADE

# ping 216.239.57.99 # test - Google.com



Update 27-Feb-2004: With latest available Firmware patch 1.6.5.3-2 made by Oleg ( http://files.wl500g.info/asus/wl500g/firmware/customized/wl500g-1.6.5.3-2.trx ) it's not necessary to copy wl_apsta.o to the router anymore. The updated wl.o module is already inside.
This firmware is for WL-500g but it is possible to update WL-500b through Firmware Restoration utility.


Update 08-Jul-2004: With latest available customized firmware 1.7.5.9-2 made by Oleg (see http://wl500g.info/showthread.php?t=530 ) the client mode configuration is significantly simplified (FYI the first customized firmware revision with this feature was 1.7.5.6-3). You just need to perform these steps:
- reset the router to factory defaults
- update the router with 1.7.5.9-2 firmware, go to web configurator
- set the router SSID to SSID of the AP you wish to connect
- set LAN interface parameters, also set LAN parameters on workstations connected to router's LAN ports
- set WAN interface parameters in accordance to parameters of wireless network provided by AP administrator (note that in client mode the WAN and WLAN functions are exchanged)

- execute the following nvram commands using Telnet (one times only):
nvram set 13_x_ClientMode=1 # (0 = ap, 1 = sta, 2 = wet)
nvram set 13_x_IBSS=1 # execute only if you need IBSS (Ad-hoc) mode (0 = bss, 1 = ibss)
nvram commit # commit settings
reboot # router restart

After the reboot the router should automatically connect to preferred AP. It may take a long time if the signal quality is low.
Use wl assoc command to check the connection status.

gottabcb
17-10-2004, 00:19
From what I understand the Belkin 7230 should also be able to do this, but so far it hasn't worked. I followed these directions, but even after committing the changes they all go away upon rebooting. Also, after setting these changes I'm still unable to ping anything connected to the other router, though the Belkin seems to think it's connected properly when I check "wl assoc".

Also, the wl_apsta.o file gets deleted from the /tmp folder upon rebooting. Any idea how to stop that from happening?

Thanks!

duwrt
06-11-2004, 17:17
From what I understand, I'm trying to do the same thing but with a Linksys going to the ASuS.

Setup: Cable Modem-->Linskys wireless router --> (wireless connection)-->WL-500g -->wired PC and wireless laptop


If I'm not in the same ballpark, let me know. That being said, with the new firmware, is it necessary to do all the manual entry below or can most of the steps below be accomplished thru the GUI.

Thanks

duwrt

hpeter
12-11-2004, 11:07
Its possible connect to source zcom AP of my destination asus500b ? (as a home gateway). Asus must act as a router for lan clients. Wlan (static IP) and Lan DNS. I read somewhere that asus 500 can be router only for WAN port.... :confused:

Josephus
17-03-2005, 16:15
Is Update 08-Jul-2004 applies to the latest firmware too?
I'm trying to use pppoe over the wifi interface. How can i do that?

*update: It's a wl500g

Oleg
17-03-2005, 20:17
Is Update 08-Jul-2004 applies to the latest firmware too?
I'm trying to use pppoe over the wifi interface. How can i do that?

*update: It's a wl500g
No, there is now completelly different client mode, which is web integrated. Once it's activated WAN port is in fact wi-fi.

helmut
08-06-2005, 15:58
No, there is now completelly different client mode, which is web integrated. Once it's activated WAN port is in fact wi-fi.

I am running 1.9.2.7-5a, is the web integrated client-mode that you mention available in that release? If so, how can I configure it?