Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ..../includes/class_bootstrap.php(430) : eval()'d code on line 123
[How To] Firmware installieren und konfigurieren - Page 3
Page 3 of 37 FirstFirst 1234513 ... LastLast
Results 31 to 45 of 548

Thread: [How To] Firmware installieren und konfigurieren

  1. #31
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Anleitung aktualisiert!
    UPDATE:

    Ich habe folgende Zeilen in /opt/etc/init.d/S05syslogd eingefügt:
    Code:
    # copy content of original syslogd to new syslog.
    cat /tmp/syslog.log >> /opt/var/log/messages
    # remove old syslog.log
    rm /tmp/syslog.log
    Hintergrund: Bei einem Neustart befinden sich jetzt alle Informationen in einer Datei.

    Wenn es also Probleme mit dem System gibt könnt ihr einfach in der /opt/var/log/messages nachsehen.
    Diese Informationen werden ja auch dauerhaft gespeichert (Im Gegensatz zu /tmp...).

    wengi

  2. #32
    hier der Auszug

    [admin@Router root]$ ls -la /opt/etc/init.d/
    total 12
    drwxr-xr-x 2 admin root 1024 Apr 18 2007 .
    drwxr-xr-x 13 admin root 1024 Apr 18 2007 ..
    -rwxr-xr-x 1 admin root 324 Apr 19 2007 S05syslogd
    -rwxr-xr-x 1 admin root 153 Jan 18 2007 S10cron
    -rwxr-xr-x 1 admin root 246 Jan 19 2007 S10xinetd
    -rwxr-xr-x 1 admin root 3127 Apr 9 2007 S80busybox_httpd
    -rwxr-xr-x 1 admin root 264 Feb 23 2007 S80samba
    -rwxr-xr-x 1 admin root 121 Mar 21 2007 S80thttpd
    -rwxr-xr-x 1 admin root 274 Apr 18 2007 rc.unslung

    so habe mal ins sys log geschaut

    Apr 19 18:35:52 thttpd[167]: thttpd/2.25b 29dec2003 starting on port 901
    Apr 19 18:35:52 thttpd[167]: started as root without requesting chroot(), warning only
    Apr 19 18:36:01 thttpd[167]: spawned indexing process 168 for directory '.'
    Apr 19 18:36:06 thttpd[167]: spawned indexing process 169 for directory 'cgi-bin'
    Apr 19 18:36:07 thttpd[167]: 192.168.1.4 URL "/cgi-bin/transmission.cgi" is executable but isn't CGI
    Apr 19 18:36:10 thttpd[167]: 192.168.1.4 URL "/cgi-bin/phf" is executable but isn't CGI
    Apr 19 18:36:13 thttpd[167]: 192.168.1.4 URL "/cgi-bin/redirect" is executable but isn't CGI
    Apr 19 18:36:15 thttpd[167]: 192.168.1.4 URL "/cgi-bin/ssi" is executable but isn't CGI
    Apr 19 18:36:18 thttpd[167]: 192.168.1.4 URL "/cgi-bin/transmission.cgi" is executable but isn't CGI
    Apr 19 18:38:20 thttpd[167]: 192.168.1.4 URL "/cgi-bin/transmission.cgi" is executable but isn't CGI
    Last edited by Hero21382; 19-04-2007 at 17:54. Reason: news

  3. #33
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Apr 19 18:36:07 thttpd[167]: 192.168.1.4 URL "/cgi-bin/transmission.cgi" is executable but isn't CGI
    Apr 19 18:36:10 thttpd[167]: 192.168.1.4 URL "/cgi-bin/phf" is executable but isn't CGI
    Apr 19 18:36:13 thttpd[167]: 192.168.1.4 URL "/cgi-bin/redirect" is executable but isn't CGI
    Apr 19 18:36:15 thttpd[167]: 192.168.1.4 URL "/cgi-bin/ssi" is executable but isn't CGI
    Apr 19 18:36:18 thttpd[167]: 192.168.1.4 URL "/cgi-bin/transmission.cgi" is executable but isn't CGI
    Apr 19 18:38:20 thttpd[167]: 192.168.1.4 URL "/cgi-bin/transmission.cgi" is executable but isn't CGI
    Ups. Das ist wohl ein allgemeines Problem des thttpd und hat nur indirekt was mit transmission zu tun. Ich benutze den busybox-http. Daher kann ich Dir dabei leider nicht weiterhelfen.

    Du solltest nach "thttpd" und "is executable but isn't CGI" suchen. Auf die Schnelle hab ich leider nichts brauchbares gefunden...

    wengi

    PS: Bitte Lösung posten, wenn Du die gefunden hast.

  4. #34
    ok danke fürs drüber schauen im notfall setzte ich es komplett neu auf

  5. #35
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Ich habe ein neues Kapitel - im Moment 10b - eingefügt.
    Jetzt kann endlich die Echtzeituhr genutzt werden.
    Allerdings steht da noch ein bischen Arbeit an.

    wengi

  6. #36
    Sehr schönes HowTo. Auch wenn ich nur ein Viertel davon verstehe. Jetzt aber mal was anderes. Ist Transmission und Samba2 nicht schon in der aktuellen Oleg Firmware enthalten?

    Grüße
    Ey3

  7. #37
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Transmission: Nein.
    Samba: Ja, aber eine ältere V2.

    wengi

  8. #38

    Thumbs up Sehr hilfreich...

    Hi,

    herzlichen Dank für das Tutorial. Hat mir riesig geholfen, vor allem um endlich mal dropbear zu aktivieren und den Paketmanager zu installieren.
    Leider findet IPKG Midnight Commander nicht im Repository, "ipgk install mc" funktioniert also nicht bei mir, auch nicht nach "ipkg update". Woran kann das liegen?

    Gruß, Thorsten

  9. #39
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Probier mal das hier:

    [admin@blechbuechse root]$ ipkg list | grep -i midnight
    mc - 4.5.55-6 - Midnight Commander File Manager
    [admin@blechbuechse root]$
    Wenn Midnight Commander gelistet wird müsste er acuh installierbar sein.
    Falls Du das hier bekommst ist er bereits installiert.
    [admin@blechbuechse root]$ ipkg install mc
    Package mc (4.5.55-6) installed in /opt/ is up to date.
    Nothing to be done
    Successfully terminated.
    [admin@blechbuechse root]$
    Was meldet Deine Box denn?

    wengi

  10. #40

    Jetzt geht's...

    Hi wengi,

    lag einfach daran, dass in der 'normalen' IPKG-installation das veraltete Repository 'http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/' verwendet wird.
    Wie im anderen Thread (http://87.239.14.2/~d02042/showthread.php?t=9105) empfohlen, habe ich den ganzen Kram wieder deinstalliert und nach Deiner Anleitung IPKG-OPT usw. aus dem Oleg-Tree draufgebügelt.
    Läuft alles bestens...

    Gruß, Thorsten

  11. #41
    Hallo wengi,

    bin gerade dabei dein HowTo für meinen Premium durchzuführen.

    Leider sagt mir Putty beim Punkt 4b folgendes:

    mkdir: Cannot create directory `/opt/etc': Read-only file system


    Irgendeine Idee was ich falsch gemacht haben könnte?

    Grüße
    Ey3

  12. #42
    @ Ey3:

    Hast du /opt schon gemountet? Hatte das Problem nämlich auch, als die Partition nicht gemountet war.

    @ wengi:
    Gibt es schon was Neues zu der RTC Geschichte? Habe die Uhr vor ca. einer Woche mit Hilfe der original Asus firmware gestellt und sie geht jetzt "schon" 4 Minuten nach. Irgendwann muss man sie halt doch stellen ...

  13. #43

    Angry Ich bin am verzeifeln!

    Hallo!
    Erstmal vielen Dank für das sehr schöne HowTo.
    Ich hab jetzt aber ein Problem, bei dem ich trotz diverser Suche im Internet und in diesem Forum nicht weiterkomme.
    Bis zum Punkt 8 hat noch alles gut geklappt, dann kam beim Einrichten von transmission die Meldung:

    cannot create directory `/tmp/harddisk/torrent': Read-only file system

    Ich hab dann mal in die Log-Datei des Web-Interfaces geschaut. Der "interessante Teil sieht so aus:

    Jan 1 01:00:08 kernel: Initializing USB Mass Storage driver...
    Jan 1 01:00:08 kernel: usb.c: registered new driver usb-storage
    Jan 1 01:00:08 kernel: scsi0 : SCSI emulation for USB Mass Storage devices
    Jan 1 01:00:08 kernel: Vendor: IC35L080 Model: AVVA07-0 Rev: 0000
    Jan 1 01:00:08 kernel: Type: Direct-Access ANSI SCSI revision: 02
    Jan 1 01:00:08 kernel: Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
    Jan 1 01:00:08 kernel: SCSI device sda: 160836480 512-byte hdwr sectors (82348 MB)
    Jan 1 01:00:08 kernel: Partition check:
    Jan 1 01:00:08 kernel: p1 p2 p3
    Jan 1 01:00:08 kernel: USB Mass Storage support registered.
    Jan 1 01:00:08 PPPoE: connect to ISP
    Jan 1 01:00:13 kernel: kjournald starting. Commit interval 5 seconds
    Jan 1 01:00:13 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,2), internal journal
    Jan 1 01:00:13 kernel: EXT3-fs: recovery complete.
    Jan 1 01:00:13 kernel: EXT3-fs: mounted filesystem with ordered data mode.
    Jan 1 01:00:13 kernel: Adding Swap: 506008k swap-space (priority -1)
    Jan 1 01:00:14 /opt/sbin/cron[143]: (CRON) STARTUP (V5.0)
    Jan 1 01:00:17 kernel: VFS: Can't find ext3 filesystem on dev sd(8,0).
    Jan 1 01:00:17 kernel: MSDOS FS: Using codepage 950
    Jan 1 01:00:17 kernel: MSDOS FS: IO charset cp950
    Jan 1 01:00:17 kernel: FAT: bogus logical sector size 64543
    Jan 1 01:00:17 kernel: VFS: Can't find a valid FAT filesystem on dev 08:00.
    Jan 1 01:00:17 kernel: FAT: freeing iocharset=cp950
    Jan 1 01:00:17 kernel: FAT: bogus logical sector size 64543
    Jan 1 01:00:17 kernel: VFS: Can't find a valid FAT filesystem on dev 08:00.
    Jan 1 01:00:17 kernel: VFS: Can't find ext3 filesystem on dev sd(8,1).
    Jan 1 01:00:17 kernel: MSDOS FS: Using codepage 950
    Jan 1 01:00:17 kernel: MSDOS FS: IO charset cp950
    Jan 1 01:00:17 kernel: Directory 1: bad FAT
    Jan 1 01:00:17 kernel: attempt to access beyond end of device
    Jan 1 01:00:17 kernel: 08:01: rw=0, want=429512616, limit=506016
    Jan 1 01:00:17 kernel: attempt to access beyond end of device
    Jan 1 01:00:17 kernel: 08:01: rw=0, want=429512617, limit=506016
    .
    .
    .
    Jan 1 01:00:17 kernel: Filesystem panic (dev 08:01).
    Jan 1 01:00:17 kernel: FAT error
    Jan 1 01:00:17 kernel: File system has been set read-only
    Jan 1 01:00:17 USB storage: vfat fs mounted to /tmp/harddisk
    Jan 1 01:00:17 kernel: Filesystem panic (dev 08:01).
    Jan 1 01:00:17 kernel: FAT error
    Jan 1 01:00:17 kernel: Directory 2: bad FAT
    Jan 1 01:00:17 kernel: kjournald starting. Commit interval 5 seconds
    Jan 1 01:00:17 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,3), internal journal
    Jan 1 01:00:17 kernel: EXT3-fs: recovery complete.
    Jan 1 01:00:17 kernel: EXT3-fs: mounted filesystem with ordered data mode.
    Jan 1 01:00:17 USB storage: ext3 fs mounted to /tmp/harddisk/part1
    .
    .
    .
    May 1 23:50:45 kernel: ector 0x3333af50) failed
    May 1 23:50:45 kernel: attempt to access beyond end of device
    May 1 23:50:45 kernel: 08:01: rw=0, want=429512616, limit=506016
    May 1 23:50:45 kernel: Directory sread (sector 0x3333af50) failed
    May 1 23:50:45 kernel: attempt to access beyond end of device
    -wiederholt sich zig-mal!!!-
    .
    .
    May 1 23:53:58 dnsmasq[70]: DHCPREQUEST(br0) 192.168.1.101 00:0e:a6:c5:50:82
    May 1 23:53:58 dnsmasq[70]: DHCPNAK(br0) 192.168.1.101 00:0e:a6:c5:50:82 lease not found
    May 1 23:53:59 dnsmasq[70]: DHCPDISCOVER(br0) 00:0e:a6:c5:50:82
    May 1 23:53:59 dnsmasq[70]: DHCPOFFER(br0) 192.168.1.101 00:0e:a6:c5:50:82
    May 1 23:53:59 dnsmasq[70]: DHCPREQUEST(br0) 192.168.1.101 00:0e:a6:c5:50:82
    May 1 23:53:59 dnsmasq[70]: DHCPACK(br0) 192.168.1.101 00:0e:a6:c5:50:82 MisterX
    May 1 23:54:02 dnsmasq[70]: DHCPINFORM(br0) 192.168.1.101 00:0e:a6:c5:50:82
    May 1 23:54:02 dnsmasq[70]: DHCPACK(br0) 192.168.1.101 00:0e:a6:c5:50:82 MisterX
    May 1 23:54:05 dnsmasq[70]: DHCPINFORM(br0) 192.168.1.101 00:0e:a6:c5:50:82
    May 1 23:54:05 dnsmasq[70]: DHCPACK(br0) 192.168.1.101 00:0e:a6:c5:50:82 MisterX
    May 2 00:00:01 /opt/sbin/cron[184]: (admin) CMD (nice /opt/sbin/transmission_watchdog)
    May 2 00:00:01 /opt/sbin/cron[185]: (admin) CMD (run-parts /opt/etc/cron.daily)
    May 2 00:00:01 transmission_watchdog: /tmp/harddisk/torrent/source does not exist.


    Die Ausgabe des Befehls df sieht so aus:

    Filesystem 1K-blocks Used Available Use% Mounted on rootfs 2880 2880 0 100% /
    /dev/root 2880 2880 0 100% /
    /dev/discs/disc0/part2
    988244 81420 856624 9% /opt
    /dev/discs/disc0/part1
    8129024 108 8128916 1% /tmp/harddisk
    /dev/discs/disc0/part3
    77665220 131228 73588832 1% /tmp/harddisk/part1


    Und "free" sieht so aus:

    total used free shared buffers cached
    Mem: 30116 15732 14384 0 2156 6736
    -/+ buffers/cache: 6840 23276
    Swap: 506008 0 506008


    Bei "ps axf" wird folgendes ausgegeben:

    PID TTY STAT TIME COMMAND
    1 ? S 0:01 /sbin/init
    2 ? S 0:00 [keventd]
    3 ? RN 0:00 [ksoftirqd_CPU0]
    4 ? S 0:00 [kswapd]
    5 ? S 0:00 [bdflush]
    6 ? S 0:00 [kupdated]
    7 ? S 0:00 [mtdblockd]
    59 ? S 0:00 telnetd
    64 ? S 0:01 httpd vlan1
    69 ? S 0:00 klogd
    70 ? S 0:00 dnsmasq
    71 ? S 0:00 syslogd -m 0 -O /tmp/syslog.log -S -l 7
    74 ? Ss 0:00 nas /tmp/nas.lan.conf /tmp/nas.lan.pid lan
    77 ? S 0:00 [khubd]
    86 ? Ss 0:00 lpd
    88 ? Ss 0:00 p9100d -f /dev/usb/lp0 0
    91 ? Ss 0:00 waveservermain
    93 ? Ss 0:00 rcamdmain
    99 ? Ss 0:00 pppd file /tmp/ppp/options.wan0
    101 ? Ss 0:00 infosvr br0
    102 ? Ss 0:00 watchdog
    104 ? Ss 0:00 \_ ntp
    114 ? S 0:00 dropbear
    162 ? Ss 0:01 \_ dropbear
    165 pts/0 Ss 0:00 \_ -sh
    196 pts/0 R+ 0:00 \_ ps axf
    121 ? S 0:00 [usb-storage-0]
    124 ? S 0:00 [scsi_eh_0]
    133 ? S 0:00 [kjournald]
    143 ? Ss 0:00 /opt/sbin/cron
    150 ? S 0:00 /usr/sbin/busybox_httpd -c /opt/etc/httpd.conf -p 800
    154 ? S 0:00 [kjournald]
    177 ? S 0:00 upnp -D -L br0 -W ppp0


    Wie gesagt, ich habe jetzt schon 2 Tage mit Suchen im Internet und in diesem Forum verbracht, um herauszufinden woran es liegt. Leider hatte ich bisher nicht viel glück - ich muß aber auch dazu sagen, dass ich auch ein absoluter Newbie bezüglich Linux/Unix bin.

    Ich wäre für jede Anregung und Hilfe absolut Dankbar!

  14. #44
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Quote Originally Posted by Ey3 View Post
    Leider sagt mir Putty beim Punkt 4b folgendes:
    mkdir: Cannot create directory `/opt/etc': Read-only file system
    Moquai hat recht: Deine Platte ist nicht nach /opt gemountet.

    wengi

  15. #45
    Join Date
    Feb 2005
    Location
    Germany - Frankfurt
    Posts
    1,548
    Quote Originally Posted by Moguai View Post
    Gibt es schon was Neues zu der RTC Geschichte? Habe die Uhr vor ca. einer Woche mit Hilfe der original Asus firmware gestellt und sie geht jetzt "schon" 4 Minuten nach. Irgendwann muss man sie halt doch stellen ...
    Leider nein

Page 3 of 37 FirstFirst 1234513 ... LastLast

Similar Threads

  1. [HOW TO] Timeouts beim Laden von bestimmten Seiten beheben - MTU Problem
    By modnet25 in forum German Discussion - Deutsch (DE)
    Replies: 3
    Last Post: 03-09-2006, 10:55
  2. passende firmware
    By marcl in forum German Discussion - Deutsch (DE)
    Replies: 12
    Last Post: 08-05-2006, 21:25
  3. Replies: 3
    Last Post: 13-01-2006, 20:09
  4. Custom Firmware v1.1.2.7
    By JOCKYW2001 in forum WL-HDD Firmware Releases
    Replies: 59
    Last Post: 11-12-2004, 13:26
  5. Flashing Oleg's Firmware in WL HDD
    By hugo in forum WL-HDD Custom Development
    Replies: 29
    Last Post: 21-10-2004, 14:55

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •