Results 1 to 12 of 12

Thread: Benötige Hilfe zu "Refused mount request"

  1. #1

    Red face Benötige Hilfe zu "Refused mount request"

    Hallo Zusammen,

    seit in paar Tagen kann ich die Laufwerk über meine Dbox nicht mehr mounten. Nach ein paar Reboots vom Asus und der Dbox läuft es meistens wieder. Im Logfile der Asus finde ich folgende Fehlermeldung "refused mount request".

    Das komplette Logfile habe ich angefügt. Der Eintrag ist ziemlich weit unten.

    Hat jemand eine Hilfe für mich, wäre sehr dankbar. / Franz

    Jan 1 01:00:10 exportfs[110]: No host name given with /tmp/harddisk/ Jan 1 01:00:11 dnsmasq[71]: read /etc/hosts - 5 addresses
    Jan 1 01:00:11 dnsmasq[71]: reading /tmp/resolv.conf
    Jan 1 01:00:22 USB storage: ext3 fs mounted to /tmp/harddisk
    Jan 1 01:00:43 syslog: refused mount request from 192.168.178.5 for /tmp/harddisk/share/mp3 (/): no export entry
    Jan 1 01:00:44 syslog: refused mount request from 192.168.178.5 for /tmp/harddisk/share/filme (/): no export entry
    Jan 1 01:00:44 syslog: refused mount request from 192.168.178.5 for /tmp/harddisk/share/fotos (/): no export entry
    Jan 1 01:03:12 login[181]: root login on `pts/0'

  2. #2
    Join Date
    Apr 2005
    Location
    Vienna, Austria
    Posts
    191
    Du solltest den ursprünglichen Fehler beheben, und dir nicht über die Folgefehler Gedanken machen ;-)

    Jan 1 01:00:10 exportfs[110]: No host name given with /tmp/harddisk/

  3. #3
    Meine box hat den Namen "ASUS", dieser steht auch in der /etc/hosts. Ein Ping auf den Namen funktioniert. Hast du einen Tip für mich?

    Gruß / Franz

  4. #4
    Join Date
    Apr 2005
    Location
    Vienna, Austria
    Posts
    191
    Wenn ich mir deine Fehlermeldung anschaue, vermute ich eher, dass beim Aufruf von exportfs was nicht stimmt.

    Kurzauszug aus den man pages:

    NAME
    exportfs - maintain list of NFS exported file systems

    SYNOPSIS
    /usr/sbin/exportfs [-avi] [-o options,..] [client:/path ..]
    /usr/sbin/exportfs -r [-v]
    /usr/sbin/exportfs [-av] -u [client:/path ..]
    /usr/sbin/exportfs [-v]
    /usr/sbin/exportfs -f
    Da steht vor /path IMMER client: ...

    P.S. Die Antworten können immer nur so genau sein wie die Fehlerbeschreibung ;-)
    Last edited by MMCM; 06-12-2006 at 15:30.

  5. #5
    Danke.

    Hier der Auszug mit exportfs

    [admin@Asus root]$ exportfs
    exportfs: No host name given with /tmp/harddisk (rw,async,wdelay,hide,nocrossmnt,secure,no_root_sq uash,no_all_squash,subtree_check,secure_locks,mapp ing=identity,anonuid=-2,anongid=-2), suggest *(rw,async,wdelay,hide,nocrossmnt,secure,no_root_s quash,no_all_squash,subtree_check,secure_locks,map ping=identity,anonuid=-2,anongid=-2) to avoid warning
    /tmp/harddisk <world>
    [admin@Asus root]$


    Was kann ich hierzu machen? "Da steht vor /path IMMER client"

  6. #6
    Join Date
    Apr 2005
    Location
    Vienna, Austria
    Posts
    191
    Was steht in /etc/exports ?
    Offensichtlich fehlt dort eine Hostangabe, denn er macht den Vorschlag einen "*" davorzustellen, was den Zugriff von allen Hosts erlauben würde.

  7. #7
    Sorry, mußte kurz weg.

    [admin@Asus root]$ more /etc/exports
    # automagically generated from web settings
    /tmp/harddisk/ (rw,async,no_root_squash)
    [admin@Asus root]$

  8. #8
    Join Date
    Apr 2005
    Location
    Vienna, Austria
    Posts
    191
    Schaut so aus, als wäre bei der Generierung der Datei eine Hostangabe vergessen worden, vor "(".
    Ein "*" erlaubt den Zugriff von allen Rechnern, eine IP Adresse nur den Zugriff von dieser. Genaueres gibt's via Google und "/etc/exports" in der Suchmaske.

  9. #9
    Habe das gleiche Problem. Nun habe ich in /usr/local/sbin/ die post-boot mit folgendem Inhalt angelegt:
    #!/bin/sh
    exportfs -ra
    Dann "flashfs save", "flashfs commit" und "flashfs enable". Die Datei dann mit "chmod +x post-boot" ausf&#252;hrbar gemacht.

    Den Export im Router habe ich auf "/tmp/harddisk/ (rw,async,no_root_sqaush)" ge&#228;ndert. Somit bekomme ich auf exportfs die Meldung "World".

    Nu bekomme ich leider die Daten in etc/hosts nicht dauerhaft gesichert. Ich wollte diese wie folgt &#228;ndern:
    127.0.0.1 localhost.localdomain localhost
    192.168.1.3 WL-HD my.router my.WL500g.Deluxe
    192.168.1.30 dbox2
    Hier noch ein Auszug aus meinem Bootlog mit Mountversuch:

    Jan 1 01:00:08 kernel: scsi0 : SCSI emulation for USB Mass Storage devices
    Jan 1 01:00:08 kernel: Vendor: HDS72808 Model: 0PLAT20 Rev: 0 0
    Jan 1 01:00:08 kernel: Type: Direct-Access ANSI SCSI revision: 02
    Jan 1 01:00:08 kernel: Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
    Jan 1 01:00:08 kernel: SCSI device sda: 160836480 512-byte hdwr sectors (82348 MB)
    Jan 1 01:00:08 kernel: Partition check:
    Jan 1 01:00:08 kernel: p5 >
    Jan 1 01:00:08 kernel: USB Mass Storage support registered.
    Jan 1 01:00:09 kernel: Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
    Jan 1 01:00:09 portmap[106]: user rpc not found, reverting to user bin
    Jan 1 01:00:10 kernel: vlan1: Setting MAC address to 00 11 d8 4c cd ac.
    Jan 1 01:00:10 kernel: VLAN (vlan1): Underlying device (eth0) has same MAC, not checking promiscious mode.
    Jan 1 01:00:10 kernel: vlan1: add 33:33:00:00:00:01 mcast address to master interface
    Jan 1 01:00:10 kernel: vlan1: add 33:33:ff:4c:cd:ac mcast address to master interface
    Jan 1 01:00:10 kernel: vlan1: add 01:00:5e:00:00:01 mcast address to master interface
    Jan 1 01:00:10 dnsmasq[73]: read /etc/hosts - 5 addresses
    Jan 1 01:00:10 dnsmasq[73]: reading /tmp/resolv.conf
    Jan 1 01:00:21 kernel: VFS: Can't find ext3 filesystem on dev sd(8,0).
    Jan 1 01:00:21 kernel: MSDOS FS: Using codepage 950
    Jan 1 01:00:21 kernel: MSDOS FS: IO charset cp950
    Jan 1 01:00:21 kernel: FAT: bogus logical sector size 64543
    Jan 1 01:00:21 kernel: VFS: Can't find a valid FAT filesystem on dev 08:00.
    Jan 1 01:00:21 kernel: FAT: freeing iocharset=cp950
    Jan 1 01:00:21 kernel: FAT: bogus logical sector size 64543
    Jan 1 01:00:21 kernel: VFS: Can't find a valid FAT filesystem on dev 08:00.
    Jan 1 01:00:21 kernel: attempt to access beyond end of device
    Jan 1 01:00:21 kernel: 08:01: rw=0, want=2, limit=1
    Jan 1 01:00:21 kernel: EXT3-fs: unable to read superblock
    Jan 1 01:00:21 kernel: MSDOS FS: Using codepage 950
    Jan 1 01:00:21 kernel: MSDOS FS: IO charset cp950
    Jan 1 01:00:21 kernel: FAT: bogus logical sector size 0
    Jan 1 01:00:21 kernel: VFS: Can't find a valid FAT filesystem on dev 08:01.
    Jan 1 01:00:21 kernel: FAT: freeing iocharset=cp950
    Jan 1 01:00:21 kernel: FAT: bogus logical sector size 0
    Jan 1 01:00:21 kernel: VFS: Can't find a valid FAT filesystem on dev 08:01.
    Jan 1 01:00:21 kernel: kjournald starting. Commit interval 5 seconds
    Jan 1 01:00:21 kernel: EXT3-fs warning: mounting unchecked fs, running e2fsck is recommended
    Jan 1 01:00:21 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,5), internal journal
    Jan 1 01:00:21 kernel: EXT3-fs: recovery complete.
    Jan 1 01:00:21 kernel: EXT3-fs: mounted filesystem with ordered data mode.
    Jan 1 01:00:21 USB storage: ext3 fs mounted to /tmp/harddisk
    Jan 1 01:00:21 FTP server: daemon is started
    Jan 1 01:04:25 login[195]: root login on `pts/0'
    Jan 1 01:06:12 syslog: refused mount request from 192.168.1.30 for /tmp/harddisk/filme (/): no export entry
    Kann mir jemand hier weiter helfen? Hat die Zeile "EXT3-fs warning: mounting unchecked fs, running e2fsck is recommended" etwas zu sagen? Was ist "e2fsck"? Macht es Sinn dieses Programm mal auszuf&#252;hren? Ich habe eine ext3-Partition.

    Es wird wohl auch laut Log kein ext3 Filesystem und kein Superblock gefunden. Wenn ich die Platte komplett in ext3 neu formatieren m&#246;chte und f&#252;r die DBox2 beschreibbar machen m&#246;chte, welche Befehle m&#252;sste ich dann ausf&#252;hren?
    Last edited by Hannes123; 07-12-2006 at 07:12.

  10. #10
    Habe auch noch immer das gleiche Problem, auch hierzu habe ich noch keine Lösung:

    admin@Asus root]$ exportfs
    exportfs: No host name given with /tmp/harddisk (rw,async,wdelay

  11. #11

    Question "refused mount request" & Dbox

    Hi@all,
    habe mit meinem ASUS WL-500g Premium; Oleg's 1.9.2.7-7f (11/06/2006) das gleiche Problem...bekomme meine Dbox nicht gemountet...

    Festplatte ist nach Anleitung nach opt gemountet...
    /dev/discs/disc0/part1 on /opt type ext3 (rw)

    Welche Export Datei tragt Ihr im Router ein & was in der Dbox ???

    Bekomme auch immer folgende Fehlermeldung :

    kernel: EXT3-fs: mounted filesystem with ordered data mode.
    kernel: Adding Swap: 524276k swap-space (priority -1)
    syslog: refused mount request from dbox for /opt/share (/): no export entry
    syslog: refused mount request from dbox for /opt/share (/): no export entry

    P.S.: FTP läuft leider auch nich wenn Festplatte nach opt gemountet ist..
    Vielleicht weiss ja jemand was man da noch ändern muß,damit der FTP
    auch nach opt geht...
    Linksys WRT 54GS (V1.1); DD-WRT v23 SP2 (09/13/2006) std
    ASUS WL-500g Premium; Oleg's 1.9.2.7-7g (04/06/2007)
    ASUS WL-HDD;
    1.Box: Nokia; 2x; Kabel; Avia500; Sportster Pro 1.10 rc008 (07/07/2007)
    2.Box: Nokia; 2x; Kabel; Avia500; BoxCracker Blue Peer V1.1 (11/11/2006)
    Harmony 885; jb Media Light-Manager; Intertechno Dimmer/Schalter

    http://www.boxcracker.org/usersigs/BC-Sig-bb1.1.gif

  12. #12
    Hier einmal, was ich ohne Erfolg versucht habe:

    /usr/local/sbin/post-boot erstellt mit folgendem Inhalt:

    #!/bin/sh
    echo "192.168.1.30 dbox2" >> /etc/hosts
    exportfs -ra

    Somit bekomme ich in /etc/hosts einen Eintrag f&#252;r die DBox2.

    Beim Mounteintrag auf dem Router habe ich folgenden Eintrag gemacht:

    /tmp/harddisk/ *(rw,async,no_root_sqaush)

    Mit dem Befehl "exportfs" bekomme ich "/tmp/harddisk" als "World" angezeigt. Somit d&#252;rften die hier beschriebenen Probleme gel&#246;st sein.

    Was bleibt ist, dass sich die Festplatte nicht mounten l&#228;sst. Geht man jedoch &#252;ber den IE auf den Router und macht ein "Save&Restart", kann man danach ohne Probleme mounten.

    Das log sieht dann so aus:

    ...
    Jan 1 01:00:23 kernel: EXT3-fs: mounted filesystem with ordered data mode.
    Jan 1 01:00:23 USB storage: ext3 fs mounted to /tmp/harddisk
    Jan 1 01:00:23 FTP server: daemon is started
    Jan 1 01:06:08 nmbd[144]: [1970/01/01 01:06:08, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(405)
    Jan 1 01:06:08 nmbd[144]: *****
    Jan 1 01:06:08 nmbd[144]:
    Jan 1 01:06:08 nmbd[144]: Samba name server WL-HD is now a local master browser for workgroup MSHEIMNETZ on subnet 192.168.1.3
    Jan 1 01:06:08 nmbd[144]:
    Jan 1 01:06:08 nmbd[144]: *****
    Jan 1 01:10:49 syslog: authenticated mount request from dbox:753 for /tmp/harddisk/filme (/tmp/harddisk)
    Stellt sich die Frage, ob ich irgendwie der Box noch Rechte zuweise muss?
    Last edited by Hannes123; 07-12-2006 at 18:15.

Similar Threads

  1. refused mount request
    By colalight890 in forum WL-500g Q&A
    Replies: 0
    Last Post: 01-12-2006, 16:03
  2. can't mount my 2nd partition
    By banana in forum WL-HDD Q&A
    Replies: 3
    Last Post: 05-06-2006, 10:46
  3. Mount problem (strenge)
    By qczek in forum WL-500g Custom Development
    Replies: 1
    Last Post: 01-02-2006, 14:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •