Page 3 of 6 FirstFirst 12345 ... LastLast
Results 31 to 45 of 81

Thread: HP LaserJet 1000/1005/1020 not working: sort of solution

  1. #31
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,355
    post-mount gets executed when usbstorage device is detected and the partitions are get mounted. It never gets executed for printers...

  2. #32
    did anyone get LJ 1000 to work? I am trying on asus WL500gP with no success.

    I load FW on printer and I stil cant print (LPR and RAW):

    Code:
    cd /tmp
    wget http://oleg.wl500g.info/hplj/usb_printerid
    wget http://oleg.wl500g.info/hplj/sihp1000.dl
    chmod +x usb_printerid
    ./usb_printerid /dev/usb/lp0 | grep -q FWVER || cat sihp1000.dl > /dev/usb/lp0
    this is added to log when I connect printer to router:

    Code:
    Jun 17 22:37:13 kernel: hub.c: new USB device 01:03.0-1, assigned address 3
    Jun 17 22:37:13 kernel: printer.c: usblp1: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x03F0 pid 0x0517
    Jun 17 22:37:13 kernel: printer.c: usblp1 Device ID string [99]='MFG:Hewlett-Packard;MDL:hp LaserJet 1000;CMD:ZJS;CLS:PRINTER;DES:hp LaserJet 1000;FWVER:20011207;'

  3. #33
    Quote Originally Posted by FauDrei View Post
    To print through 500g/gx you need a printer which support a form of printer language (PCL, PS...)

    [...]

    Needles to say, LaserJet 1010 has both.
    i'm a little confused -- the official documents say that the LaserJet 1010 only supports host-based printing (and that only the LJ 1015 speaks PCL 5).

    now, does the lj 1010 work with the wl-500g or doesn't it? (i plan on getting one, so i would appreciate any informed comments..)

  4. #34
    Hi,
    I have HP LaserJet 1018 so I am in trouble (lesson not to buy cheap things). By reading this thread I found that it is possible to make printer work with 500gP, but now I haven't any USB stick or hard disk.. Maybe there is a way to "include" laserjet 1018 support directly to 500gP firmware ?
    Had problems with this printer in Ubuntu but they are already solved, now it would be nice to have it working without host computer.

  5. #35
    i just got a new WL500g.Premium, and it seems the LaserJet 1100 is working, with a Parallel to USB adapter. With the Wl500g, it didn't work both directly attached to the Parallel port, as well as to the USB port with the adapter.

    Anyone got any reports on the WL500g Deluxe?

  6. #36

    foo2zjs

    Can anybody make ipkg package for foo2zjs? I'm not sure, but I think it could be helpful. Or guide me simply how to install it on WL-500gP. This driver simply solved my problem in SUSE and I wanted to try on my router, but I'm not so good in linux so i didn't manage to compile it.

  7. #37
    Hi everyone,

    I'm running dd-wrt firmware on my wl500g but I'm considering using Oleg's firmaware since the dd-wrt seems not to support my HP LJ1022. As far as I can see there seems to be a workaround to make the printer usable using Oleg's firmware. My question is the following (I'm not very proficient in programming or anything like that):

    - Does the latest Oleg's firmware support the 1022 out ot the box, ie, just install the firmware plug the printer and were good to go? By reading this thread it seems that I should use a USB stick to load the firmware (how to do it is something a can't understand), and I can't understand how this is done.

    - for those that have tried DD-WRT, do you think Oleg's firmware is better?

    All the best,

    nickie

  8. #38
    Join Date
    Oct 2005
    Location
    Ljubljana / Slovenia
    Posts
    5
    Is there any "Plug and Play" way to solve the problem with WL500g and LJ1020?
    I'm defoult windows user and all those solutions writen here are to complicated for me to implement them... Is there a way for a solution to be implemented in some firmware any time soon?
    It ain't the fall that kills you
    It's the sudden stop at the bottom.

  9. #39
    Join Date
    Jan 2008
    Location
    Novi Sad, Vojvodina, Serbia
    Posts
    10

    LJ 1020 - working!

    Setup: Pc with Win XP, WL500gP, HP LJ 1020 plugged in Asus.

    Router flashed with latest Oleg's firmware. 1020 installed in Win as local printer (following Oleg's tutorial) using HP non-PnP driver (I think it's second on the DL list). Printed test page - everything working. No hotplug scripts, Dl firmware, nothing.

    Tomorrow will try LJ 1000 on work, refused to work untill now.

    A.

  10. #40
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,355
    Quote Originally Posted by Rushke View Post
    Setup: Pc with Win XP, WL500gP, HP LJ 1020 plugged in Asus.

    Router flashed with latest Oleg's firmware. 1020 installed in Win as local printer (following Oleg's tutorial) using HP non-PnP driver (I think it's second on the DL list). Printed test page - everything working. No hotplug scripts, Dl firmware, nothing.

    Tomorrow will try LJ 1000 on work, refused to work untill now.

    A.
    Cycle your printer power now and try again.

  11. #41
    Join Date
    Jan 2008
    Location
    Novi Sad, Vojvodina, Serbia
    Posts
    10
    Quote Originally Posted by Oleg View Post
    Cycle your printer power now and try again.
    Tried this too - still working. Any ideas why?

    I have installed only basic driver for HP, via Add hardware/Have disk/ .inf, no additional software. Maybe software somehow blocks pn9100?

    A.

  12. #42
    Join Date
    Jan 2008
    Location
    Novi Sad, Vojvodina, Serbia
    Posts
    10

    1020 working - update

    Time to corect myself: If I powercycle printer, it stops working... It seems I flipped power switch too fast & didn' reset printer. So - hotplug it is.

    Fortunately, I can read Russian, because in Russian thread hotplugging is explained in detail. Mounted USB HDD ext3 partition on /opt, placed hotplug.sh, sihp1020.dl and usb_printerid on disc, modified post-mount & post-boot scripts, and MAGIC - printer is working!

    ... Untill first time I rebooted router without attached HDD...
    Plugged in HDD - and no printing... My partition with hotplug, firmware & the rest is not mounted....

    ... Few hours later, after playing with post-mount, hotplug.sh etc. and a lot of reading later - solution: FSTAB ! Everything is working

    ... Few hours of reading later - flashfs on WL500g Premium is big enough to store firmware. Ouch!

    Epilogue: Everything is working now & I had a lot of fun getting to it long way round

    Thanks, Oleg & everybody else.

    A.

  13. #43
    Join Date
    Jan 2008
    Location
    Novi Sad, Vojvodina, Serbia
    Posts
    10

    Hp LJ 1000 - works too

    Just tried, and it's working fine Firmware needs to be downloaded to printer via hotplug.sh, and bidirectional support shoud be unchecked in windows printer properties.
    LJ 1000 is connected by some kind of usb-to-serial cable, probably this is confusing router and windows driver. If you leave bidirectional printing checked, result is blocked printer port on win and stuck printer on router. Only restarting helps.

    A.

  14. #44
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,781
    According to http://etherboot.sourceforge.net/p910nd/p910nd.txt you might attempt to enable bidirectional support by adding -b parameter to the p910nd instance running.

    Kill existing p910nd and start it again with -b parameter.
    PHP Code:
    kill `pidof p910nd`
    p9100d --/dev/usb/lp0 0 

  15. #45
    Join Date
    Jan 2008
    Location
    Novi Sad, Vojvodina, Serbia
    Posts
    10
    Quote Originally Posted by al37919 View Post
    According to http://etherboot.sourceforge.net/p910nd/p910nd.txt you might attempt to enable bidirectional support by adding -b parameter to the p910nd instance running.

    Kill existing p910nd and start it again with -b parameter.
    PHP Code:
    kill `pidof p910nd`
    p9100d --/dev/usb/lp0 0 
    p910nd -b -f /dev/usb/lp0 0

    did the trick. 1020 returns notthing, it seems driver is not using this (working) capability. 1000 blocks widows port & printer regardless of -b option if bidirectional printing is checked in port settings. Finally I left it unchecked, for me it works fine that way.
    If printer runs out of paper, simply unplug/plug it from router. 1020 resumes printing, 1000 is resetted.

    A.

Page 3 of 6 FirstFirst 12345 ... LastLast

Similar Threads

  1. Replies: 3
    Last Post: 18-12-2005, 01:07
  2. Solution for: No printer driver with Mac OSX
    By tortuga in forum WL-500g/WL-500gx Tutorials
    Replies: 0
    Last Post: 16-12-2005, 13:21
  3. Replies: 1
    Last Post: 09-12-2005, 22:29
  4. Problem mit HP LaserJet 1020
    By Gray in forum German Discussion - Deutsch (DE)
    Replies: 0
    Last Post: 05-12-2005, 17:36
  5. Trying to get IDE working on Oleg's Firmware
    By hugo in forum WL-HDD Custom Development
    Replies: 34
    Last Post: 01-11-2004, 18:06

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •