Page 1 of 2 12 LastLast
Results 1 to 15 of 18

Thread: MPD won't play ogg

  1. #1

    MPD won't play ogg

    Hello together!

    Still on the search for a music streamer/player, I came back to try mpd from opkg.
    Things work fine with MP3s when played with locally attached USB-Soundcard.

    But when it comes to OGG-Files, there is only a once a second short crisp.
    Seems to be a known (and fixed?) problem:
    https://dev.openwrt.org/ticket/9280
    https://forum.openwrt.org/viewtopic.php?id=29475
    https://forum.openwrt.org/viewtopic.php?pid=133669

    However in my case, OGGs are at least indexed. I use the opkg-version (0.16.5), which should have built-in the fix?

    Second problem is the http-streaming. When started (with MP3 ;-) ), CPU load goes up in the sky and I get some milli-seconds of music every minute using VLC on my PC here. This is also documented (http://musicpd.org/mantis/view.php?id=3330 and many more) and reported to be fixed?

    So any ideas, wether the actual wl500g-build may be broken?

    I wanted to compile it on my own, but couldn't find a c-compiler in opkg - any solution to this?

    And last but not least: is there any way, to get the binaries of the older versions to try wether there is some working version?

    Thanks a lot for help,
    pheidrias

  2. #2
    Join Date
    Feb 2008
    Location
    Smolensk, Russia
    Posts
    2,326
    Blog Entries
    15
    Quote Originally Posted by pheidrias View Post
    I wanted to compile it on my own, but couldn't find a c-compiler in opkg - any solution to this?
    opkg is a small program for managing existing packages, it does not include compiler or something else.

    My mpd Makefile taken from OpenWRT trunk and mpd was built with OGG support. You may try to build your own mpd version, just follow this manual.
    Entware Repository ◄ RT-N66U Router + ZyXEL V352L Phone + WD TV Live Player + WD My Book Live NAS

  3. #3
    This refers to cross-compiling, then? It's supposed to be done on my linux machine?

    If it could be done on the router, I do miss a svn-package :-(.

    Are there any older mpd-versions from your opkg (remember to have read something on versioning with opkg)?

    Thanks!

  4. #4
    don't compile it on the router - you'll lose many hours/days preparing the system and compiling the openwrt packages
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-121 K26AC USB AIO-64K running Entware
    lighttpd 1.4.3.0 php 5.4.5 eaccelerator sqlite
    pyload 0.4.10
    minidlna 1.1.2
    samba 3.6.5

    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  5. #5
    Okay...I tried to follow the HowTo (http://code.google.com/p/wl500g-repo.../trunk/INSTALL) by copy/pasting the instructions (took the newest revision instead of r3458).

    Maybe I misunderstood it, but the last step failed
    Code:
    ~/Soft/openwrt/trunk$ make package/compile V=99
    make[1]: Entering directory `/home/guntram/Soft/openwrt/trunk'
    make[2]: Entering directory `/home/guntram/Soft/openwrt/trunk/package/opkg'
    make[2]: Leaving directory `/home/guntram/Soft/openwrt/trunk/package/opkg'
    make[2]: Entering directory `/home/guntram/Soft/openwrt/trunk/package/base-files-network'
    make[2]: Leaving directory `/home/guntram/Soft/openwrt/trunk/package/base-files-network'
    make[2]: Entering directory `/home/guntram/Soft/openwrt/trunk/package/base-files'
    cp -fpR /home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libuClibc-*.so /home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libcrypt-*.so /home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libm-*.so /home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libpthread-*.so /home/guntram/Soft/openwrt/trunk/build_dir/linux-rtn/base-files/
    cp: cannot stat `/home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libuClibc-*.so': No such file or directory
    cp: cannot stat `/home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libcrypt-*.so': No such file or directory
    cp: cannot stat `/home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libm-*.so': No such file or directory
    cp: cannot stat `/home/guntram/Soft/openwrt/trunk/staging_dir/toolchain-mipsel_gcc-4.6-linaro_uClibc-0.9.33/lib/libpthread-*.so': No such file or directory
    make[2]: *** [/home/guntram/Soft/openwrt/trunk/build_dir/linux-rtn/base-files/.built] Error 1
    make[2]: Leaving directory `/home/guntram/Soft/openwrt/trunk/package/base-files'
    make[1]: *** [package/base-files/compile] Error 2
    make[1]: Leaving directory `/home/guntram/Soft/openwrt/trunk'
    make: *** [package/compile] Fehler 2
    If I try make mpd-full/compile instead, it breaks down immediately (No rule to make target `mpd-full/compile')...
    This will be the point where I have to tell him your posted make-file? How?

    Thanks for further support!

    Although I'm learning some things here - could someone of you guys please test, wether MPD on your routers is able to play OGG-files? Maybe its really a package problem and not just my personal fault...thank you!

  6. #6
    Hello again!

    I figured out, that the problem seems to stem from resampling. This takes too much CPU and therefore makes the playback quite impossible (CPU load > 95% for mpd when playing OGG).

    Maybe there is some misconfiguration for mpd 0.16.5?
    It worked when I was using mpd 0.15...

  7. #7
    Join Date
    Feb 2008
    Location
    Smolensk, Russia
    Posts
    2,326
    Blog Entries
    15
    Quote Originally Posted by pheidrias View Post
    I figured out, that the problem seems to stem from resampling. This takes too much CPU and therefore makes the playback quite impossible (CPU load > 95% for mpd when playing OGG).
    Unfortunately, our CPU have no FPU, only FPU emulation unit. This is why massive floating point calculations is painfully slow.
    But! You may relink the mpd from libvorbis to libvorbisidec - a library with integer numbers only algorithms. See Makefile for details.
    Entware Repository ◄ RT-N66U Router + ZyXEL V352L Phone + WD TV Live Player + WD My Book Live NAS

  8. #8
    Quote Originally Posted by ryzhov_al View Post
    You may relink the mpd from libvorbis to libvorbisidec - a library with integer numbers only algorithms.
    if thats working, all applications on our devices using this lib, should be relinked

    I don't have any ogg-files now, but am willing to test it with minidlna this night...
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-121 K26AC USB AIO-64K running Entware
    lighttpd 1.4.3.0 php 5.4.5 eaccelerator sqlite
    pyload 0.4.10
    minidlna 1.1.2
    samba 3.6.5

    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  9. #9
    Quote Originally Posted by ryzhov_al View Post
    But! You may relink the mpd from libvorbis to libvorbisidec - a library with integer numbers only algorithms. See Makefile for details.
    Unfortunately the makefile doesn't tell me anything ...as my above post demonstrates, I'm still stuck on the last step of preparing my system for cross-compiling...

    Or can I "symlink" the libraries?

    I don't have any ogg-files now, but am willing to test it with minidlna this night...
    Shall I send you one?
    I even get those problems with madplay --> in case, minidlna doesn't produce problems (for other reasons?)...

  10. #10
    @!gm: Have you had time to give it a try?

    @ryzhov_al: Could you please help me in setting up this compiling/linking (see above post)?
    As mpd seems to use ogg-reencoding for http-streaming, too, there seems to be a real need for this thing!

    Thanks a lot,
    pheidrias

  11. #11
    Join Date
    Feb 2008
    Location
    Smolensk, Russia
    Posts
    2,326
    Blog Entries
    15
    Quote Originally Posted by pheidrias View Post
    @ryzhov_al: Could you please help me in setting up this compiling/linking (see above post)?
    Sorry, I did not have enough time to teach each member of our forum. Please, refer my guide and this topic.
    Entware Repository ◄ RT-N66U Router + ZyXEL V352L Phone + WD TV Live Player + WD My Book Live NAS

  12. #12
    Quote Originally Posted by ryzhov_al View Post
    Sorry, I did not have enough time to teach each member of our forum.
    Of course! You're already doing a great job in sharing your projects with us!
    I didn't want to sound too demanding...sorry for this.

    I posted the error message I get when trying to follow your HowTo in my earlier post (01-03-2012 12:24) - I don't understand what I've made wrong?

    Thanks,
    pheidrias

  13. #13
    toolchain is not well installed.

    did you read my success story?

    http://wl500g.info/showpost.php?p=244468&postcount=19
    http://wl500g.info/showpost.php?p=244521&postcount=23

    ^these are the most important posts
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-121 K26AC USB AIO-64K running Entware
    lighttpd 1.4.3.0 php 5.4.5 eaccelerator sqlite
    pyload 0.4.10
    minidlna 1.1.2
    samba 3.6.5

    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  14. #14
    hmmm...my problem seems to be at another place...
    However, I may have overseen the following error message the first time I tried the compilation.
    When I do "make toolchain" it stops with:
    Code:
    Ausgecheckt, Revision 3458.
    cp -f ../../toolchain-1.9.2.7-rtn-r3458/src/defconfig ../../toolchain-1.9.2.7-rtn-r3458/src/.config
    sed -i 's,/home/lly/Wl500/rt-n/linux/linux-2.6/,/home/guntram/Soft/openwrt/rtn/toolchain/../../firmware-1.9.2.7-rtn-r3702/src/linux/linux-2.6,g' ../../toolchain-1.9.2.7-rtn-r3458/src/.config
    Fixme: apply uClibc patches for ld.so*
    cp -f ./999-ld-native-search-path.patch  ../../toolchain-1.9.2.7-rtn-r3458/src/toolchain/binutils/patches/2.21.1/
    cp -f ./*-uclibc-*.patch  ../../toolchain-1.9.2.7-rtn-r3458/src/toolchain/uClibc/patches/0.9.32/
    cp: Aufruf von stat fr ./*-uclibc-*.patch nicht mglich: Datei oder Verzeichnis nicht gefunden
    make[1]: *** [.toolchain_compiled] Fehler 1
    make[1]: Verlasse Verzeichnis '/home/guntram/Soft/openwrt/rtn/toolchain'
    make: *** [.toolchain_installed] Fehler 2
    Do I have to get the missing patch somewhere manually?

  15. #15
    Alexander changed the installation-routine in r384.

    http://code.google.com/p/wl500g-repo/source/list

    You may checkout latest trunk as he fixed some issues yesterday.
    Or an revision < 384 and use a precompiled toolchain, as I did.
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-121 K26AC USB AIO-64K running Entware
    lighttpd 1.4.3.0 php 5.4.5 eaccelerator sqlite
    pyload 0.4.10
    minidlna 1.1.2
    samba 3.6.5

    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

Page 1 of 2 12 LastLast

Similar Threads

  1. Asus WL-500gP V2 & Sony Play Station Portable (PSP)
    By Vertige in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 102
    Last Post: 31-10-2011, 06:41
  2. OpenVPN
    By Mirage-net in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 241
    Last Post: 24-05-2011, 20:48
  3. mpd crash
    By Tebra in forum WL-500gP Firmware Discussion
    Replies: 2
    Last Post: 25-10-2010, 20:10
  4. HowTo WL-HDD + USB-Sound-Hub als MP3-Player mit PDA-Fernbedinung
    By WLAN-Fan in forum German Discussion - Deutsch (DE)
    Replies: 47
    Last Post: 17-09-2010, 12:27
  5. mpd: can't load library 'libssp.so.0'
    By drp in forum WL-500g Q&A
    Replies: 5
    Last Post: 03-05-2008, 16:07

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •