Results 1 to 6 of 6

Thread: kein Sound an USB Soundkarte

  1. #1

    kein Sound an USB Soundkarte

    Ich hab letzte Woche das tolle Anleitung gesehen bei der man ber usbsound-karte also habsch mir mal eine billig 3 Teil (noname mit aufdruck eCom 3D Sound) gekauft und wollte das mal probieren.
    wenn ich nun per konsolle
    madplay test.mp3


    eintippe dann kommt kein sound(nur:MPEG Audio Decoder 0.15.2 (beta) - Copyright (C) 2000-2004 Robert Leslie et al. als ausgabe) kann mir also sparen weiter am phpsound-Script zu arbeiten.

    Hat jmd ne Ahnung woran das liegen kann. oder muss man da noch was zustzliches installieren fr den treiber oder so?




    im LogFile steht zumind mal drin:

    Mar 16 18:36:13 kernel: hub.c: new USB device 00:04.0-1, assigned address 2
    Mar 16 18:36:13 kernel: usb.c: USB device 2 (vend/prod 0x1130/0xf211) is not claimed by any active driver.
    Mar 16 18:36:13 USB audio: attached
    Mar 16 18:36:14 kernel: usb.c: registered new driver audio
    Mar 16 18:36:14 kernel: usbaudio: device 2 audiocontrol interface 0 has 1 input and 1 output AudioStreaming interfaces
    Mar 16 18:36:14 kernel: usbaudio: device 2 interface 2 altsetting 1 channels 1 framesize 2 configured
    Mar 16 18:36:14 kernel: usbaudio: valid input sample rate 24000
    Mar 16 18:36:14 kernel: usbaudio: device 2 interface 2 altsetting 1: format 0x00000010 sratelo 24000 sratehi 24000 attributes 0x00
    Mar 16 18:36:14 kernel: usbaudio: device 2 interface 1 altsetting 0 does not have an endpoint
    Mar 16 18:36:14 kernel: usbaudio: device 2 interface 1 altsetting 1 channels 2 framesize 2 configured
    Mar 16 18:36:14 kernel: usbaudio: valid output sample rate 48000
    Mar 16 18:36:14 kernel: usbaudio: device 2 interface 1 altsetting 1: format 0x01000010 sratelo 48000 sratehi 48000 attributes 0x00
    Mar 16 18:36:14 kernel: usbaudio: registered dsp 14,3
    Mar 16 18:36:14 kernel: usbaudio: registered mixer 14,0
    Mar 16 18:36:14 kernel: usbaudio: registered mixer 14,16
    Mar 16 18:36:14 kernel: audio.c: v1.0.0:USB Audio Class driver
    Mar 16 18:36:14 kernel: usbaudio: set_format_out(): failed to find desired format/speed combination.
    Mar 16 18:36:14 kernel: usbaudio: set_format_out(): failed to find desired format/speed combination.
    Mar 16 18:36:14 kernel: usbaudio: set_format_out(): failed to find desired format/speed combination.
    Mar 16 18:36:14 kernel: usbaudio: set_format_out(): failed to find desired format/speed combination.

  2. #2
    Also mein Systemlog sieht so aus (s.u.), und madplay funktioniert. Vielleicht ist deine No-name-Soundkarte nicht in Ordnung, oder sie hat nicht die notwendigen Sample-Raten? Es knnte z.B. sein dass deine Sounds z.B. 44.100 kHz haben, aber die Soundkarte untersttzt nur 48.000 kHz

    Code:
    Feb 16 12:06:18 kernel: usb.c: registered new driver audio
    Feb 16 12:06:18 kernel: usbaudio: device 2 audiocontrol interface 0 has 1 input and 1 output AudioStreaming interfaces
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 1 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 1: format 0x01000010 sratelo 48000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 2 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 2: format 0x00000010 sratelo 48000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 3 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 3: format 0x01000010 sratelo 44100 sratehi 44100 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 4 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 4: format 0x00000010 sratelo 44100 sratehi 44100 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 5 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 5: format 0x01000010 sratelo 32000 sratehi 32000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 6 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 6: format 0x00000010 sratelo 32000 sratehi 32000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 7 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 22050
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 7: format 0x01000010 sratelo 22050 sratehi 22050 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 8 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 22050
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 8: format 0x00000010 sratelo 22050 sratehi 22050 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 9 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 16000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 9: format 0x01000010 sratelo 16000 sratehi 16000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 10 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 16000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 10: format 0x00000010 sratelo 16000 sratehi 16000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 11 channels 2 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 16000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 11: format 0x01000040 sratelo 16000 sratehi 16000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 12 channels 1 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 16000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 12: format 0x00000040 sratelo 16000 sratehi 16000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 13 channels 2 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 8000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 13: format 0x01000040 sratelo 8000 sratehi 8000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 14 channels 1 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 8000
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 14: format 0x00000040 sratelo 8000 sratehi 8000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 15 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 11025
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 15: format 0x01000010 sratelo 11025 sratehi 11025 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 16 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 11025
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 16: format 0x00000010 sratelo 11025 sratehi 11025 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 17 channels 2 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 11025
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 17: format 0x01000040 sratelo 11025 sratehi 11025 attributes 0x00
    Feb 16 12:06:18 kernel: o: device 2 interface 2 altsetting 18 channels 1 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid input sample rate 11025
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 2 altsetting 18: format 0x00000040 sratelo 11025 sratehi 11025 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 0 does not have an endpoint
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 1 channels 2 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 1: format 0x01000010 sratelo 32000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 2 channels 1 framesize 2 configured
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 2: format 0x00000010 sratelo 32000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 3 channels 2 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 3: format 0x01000040 sratelo 32000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 4 channels 1 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 4: format 0x00000040 sratelo 32000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 5 channels 2 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 5: format 0x01000008 sratelo 32000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 6 channels 1 framesize 1 configured
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 32000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 48000
    Feb 16 12:06:18 kernel: usbaudio: valid output sample rate 44100
    Feb 16 12:06:18 kernel: usbaudio: device 2 interface 1 altsetting 6: format 0x00000008 sratelo 32000 sratehi 48000 attributes 0x00
    Feb 16 12:06:18 kernel: usbaudio: registered dsp 14,3
    Feb 16 12:06:18 kernel: usbaudio: registered mixer 14,0
    Feb 16 12:06:18 kernel: usbaudio: no mixer controls found for Terminal 5
    Feb 16 12:06:18 kernel: audio.c: v1.0.0:USB Audio Class driver
    und hier die Ausgabe von madplay (Ton kommt raus!):

    Code:
    madplay /opt/etc/mp3/Test.mp3
    MPEG Audio Decoder 0.15.2 (beta) - Copyright (C) 2000-2004 Robert Leslie et al.
    error: frame 0: lost synchronization
    124 frames decoded (0:00:03.2), -5.2 dB peak amplitude, 0 clipped samples
    Last edited by jojo_m; 16-03-2011 at 23:37.

  3. #3
    also unter windows luft die, also zumind nicht komplett defekt.
    Wie kann man den feststellen ob diese auf meinem WL-HDD nicht luft

    was hast du den fr ein Model wenns wirklich an dem stick liegt kann ich ja noch mal ein kauf risikieren.

  4. #4
    Servus, also ich habe im Lauf der Zeit 3 verschiedene Soundkarten im Einsatz gehabt:

    Nr. 1, Nr. 2 und Nr. 3, die ich momentan verwende. brigens auch an einer WL-HDD!

    Mich wundert, dass in deinem Syslog nur von 48.000 kHz Output-Samplingrate die Rede ist. Bei meinen Soundkarten war immer auch 44.100 dabei.

    Du solltest dir mal diesen Thread anschauen: http://wl500g.info/showthread.php?t=22897.

    Hast du den Waveserver im Webinterface wirklich aktiviert?

    Schau auch mal, ob diese Dateien vorhanden sind: /dev/sound/dsp und /dev/sound/mixer. Wenn nicht, wurde die Soundkarte nicht richtig initialisiert.
    Last edited by jojo_m; 17-03-2011 at 20:20.

  5. #5
    bis auf die printing service (mein drucker kann alleine schon WLAN) ist alles auf YES.

    Code:
    [admin@WL-HDD root]$ cd /dev/sound
    [admin@WL-HDD sound]$ ls
    dsp  mixer  mixer1
    also wohl kacke soundkarte.

  6. #6
    Hi, jetzt hab ich mich noch an den entscheidenden Trick erinnert. Probiere mal folgendes:

    Bevor du den madplay-Aufruf machst, erst noch das hier aufrufen:

    Code:
    killall waveserver
    killall waveservermain
    (sonst blockiert nmlich der Firmware-interne Waveserver die Soundkarte)

    Also: der Waveserver muss im Webinterface aktiviert sein (damit beim Booten die Sound-Treiber geladen werden), aber dann muss er mit killall wieder beendet werden.

    So msste es gehen.

    Wenn es klappt, kannst du diese beiden killall-Befehle natrlich auch in die post-boot-Sequenz reinnehmen.
    Last edited by jojo_m; 21-03-2011 at 18:44.

Similar Threads

  1. linuxrc bug? - WL-500g not booting from usb drive with hub
    By daniel632 in forum WL-500g Custom Development
    Replies: 5
    Last Post: 14-03-2012, 16:28
  2. Samba USB HDD
    By falselight in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 188
    Last Post: 28-02-2012, 16:43
  3. 7.09 + USB + hotplug
    By oilinki in forum WL-700g Q&A
    Replies: 0
    Last Post: 18-11-2007, 13:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •