Results 1 to 4 of 4

Thread: Option iCON 225 modem in OLEG

Hybrid View

  1. #1

    Option iCON 225 modem in OLEG

    Hi!

    As I understand it, the iCON 225 modem is not supported by default in Oleg's image. Are there any plans to support more modem types than Huawei (including the iCON 225) or is it up to each user to add the driver needed?

    I've seen tutorials for using this modem in Ubuntu, so I guess it can be used on Linux. Could anyone give some ideas what has to be added to OLEG's image in order to support another modem?

  2. #2
    Unfortunatly currently this modem not works. Others may work with the koppel firmware (cdma-wifi), witch based on oleg's.

    On desktop linux distros this works with the HSO kernel module, that designed to kernel 2.6 series. I'm waiting for the solution too.

  3. #3
    the latest hso driver 1.12 is for 2.6 kernels,and only version 0.1 was for 2.4
    here's source and compiled hso.o against 2.4.37.2 kernel for 1.9.2.7-d firmware (yes, you have to flash it to get driver working)
    Code:
    [admin@router /home]$ uname -a
    Linux router 2.4.37.2 #2 2009-07-28 12:34:25 YEKST mips GNU/Linux
    [admin@router /home]$ insmod /home/hso.o
    [admin@router /home]$ lsmod
        Tainted: P
    hso                    31816   0 (unused)
    usb-storage            62968   1
    sd_mod                 12660   2
    scsi_mod               72624   2 [usb-storage sd_mod]
    ehci-hcd               28196   0 (unused)
    usb-uhci               27380   0 (unused)
    usbcore                78456   1 [hso usb-storage ehci-hcd usb-uhci]
    but i have no modem of this kind, so can't test if it's working driver.
    Attached Files Attached Files

  4. #4
    Thanks, but my solution was to switch to a Hauwei 220 modem instead (as you can see, the thread was quite old) which I'm running without any problems.

Similar Threads

  1. Kamikaze - tranmission and other stuff
    By calebz in forum WL-500gP Firmware Discussion
    Replies: 23
    Last Post: 20-02-2008, 17:56
  2. D-link 320T as a pure modem and wl500g (oleg fw)
    By IvanS in forum WL-500g Q&A
    Replies: 0
    Last Post: 31-12-2007, 09:48
  3. Vlan configuration with Kamikaze 7.09
    By asle_500g in forum WL-500gP Q&A
    Replies: 0
    Last Post: 07-12-2007, 11:56
  4. Has anyone got Mediatomb running
    By Behrens in forum WL-500gP Q&A
    Replies: 3
    Last Post: 17-10-2007, 16:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •