Page 1 of 2 12 LastLast
Results 1 to 15 of 30

Thread: Flashing Oleg's Firmware in WL HDD

  1. #1

    Question Flashing Oleg's Firmware in WL HDD

    Hello everybody. I'm a proud new owner of a Wl HDD. I have the hope to make a kind of Wl 500g in a smaller shape, with the fast access to HD.

    In the "how to save current firmware" tread, Antiloop tryed to flash Oleg's firmware in the Wl-HDD

    Quote Originally Posted by Antiloop
    to add some points..

    the WL-HDD is able to serve as printserver too

    i just flashed a 1.8.1.7pre3 into it and the thing booted normally but ofcourse acted as an wl500g but the ethernet port is the WAN port then so you have to login wirelessy otherwise you can't access it because of the firewall

    some thinking of me, perhaps it's possible to remove the FTP from the firmware and put a firmware on the HDD itselve
    this should enable us (ofcourse memory use is still a point!) to implement bigger packages
    As far as I understand, I will have the following steps to take:

    1) format a partition using ext3fs using a tool that I would have to copy in the temp directory from the web admin page on a usb key or on the HD

    2) copy all files from the latest Oleg firmware root fs to this partition (should I take special methods as I'm working under Windows system?)

    3) change the nvram setting to boot from this partition using something like :
    nvram set boot_dev="/dev/scsi/host0/bus0/target0/lun0/part1"
    nvram commit

    If I understand correctly, if the WLHDD cannot find the system on the USB drive or HDD, then it will boot the normal system from internal memory, so I have a rollback by removing the drive and reformating it?

    Can I do all this from the web interface, or I need telnet access? I couldn't start telnet until now as busybox doesn't give me any output (I'm using the one from Oleg's firmware)

    Can anybody tell me if my asumption are correct and correct them if needed?

    Thanks a lot

    PS: As Antiloop tryed it, is it a viable solution to work with Oleg's firmware, if I'm ready to access the WL HDD from wireless and let the lan port be a wan port?

  2. #2
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,403
    hm..?

    as I said: 'i just flashed a 1.8.1.7pre3 into it '

    I mean that i flashed it, so just enter restore mode of the wl-hdd:
    power off, hold the button, power on till power led begins to flash then release the button and start firmware restoration at your pc

    after it's finished turn off wl-hdd turn it on, start system
    after that make sure you load the firmware defaults

    at the moment you will NOT be able to access your harddrive

    if things go well perhaps WL-HDD will be incorperated in current WL500g firmware

    the lan port port is the 'WAN' port with the WL500g firmware (thus eth1)

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  3. #3
    Thanks for the confirmation. I wanted to use the external drive to be able to revert to WL HDD mode by just unpluging the usb key for example.

    By the
    at the moment you will NOT be able to access your harddrive
    do you mean I cannot mount the device even by telnet and add the mount point to the stupid ftp?

  4. #4
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,403
    Quote Originally Posted by hugo
    Thanks for the confirmation. I wanted to use the external drive to be able to revert to WL HDD mode by just unpluging the usb key for example.

    By the

    do you mean I cannot mount the device even by telnet and add the mount point to the stupid ftp?
    yes you can not mount the internal hdd because there are NO drivers supplied for the Promise controller inside the WL-HDD in the wl500g firmware

    personally I would like to see the wl500g & wl-hdd firmware to be merged in one firmware, for the time being use one of it with their disadvantages..

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  5. #5
    Quote Originally Posted by Antiloop
    power off, hold the button, power on till power led begins to flash then release the button and start firmware restoration at your pc
    There is no point where the power led blinks. I tryed releasing it a different stages but it wont let me flash via wireless. If I hold the button too much, It simply shut down


    As a side note, I can explain here upon request how to setup a root ftp and a telnet deamon on the WL HDD, as the instruction differs from the WL 500G.

  6. #6
    Join Date
    Apr 2004
    Location
    Netherlands
    Posts
    1,306
    Quote Originally Posted by hugo
    There is no point where the power led blinks. I tryed releasing it a different stages but it wont let me flash via wireless. If I hold the button too much, It simply shut down
    Hmmm, upgrading through wireless is dangerous....allways flash your firmware using a wire. If the router does not want to get in firmware restoration mode in any way then there's only one solution. That is to connect a certain pin of the broadcom chip to ground during boot. Search the forum, there are a lot of folks having problems after firmware upgrade.
    As a side note, I can explain here upon request how to setup a root ftp and a telnet deamon on the WL HDD, as the instruction differs from the WL 500G.
    Why should it be on request?

  7. #7
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,403
    Quote Originally Posted by hugo
    There is no point where the power led blinks. I tryed releasing it a different stages but it wont let me flash via wireless. If I hold the button too much, It simply shut down


    As a side note, I can explain here upon request how to setup a root ftp and a telnet deamon on the WL HDD, as the instruction differs from the WL 500G.
    erhz.. how are you supposed to flash wireless if the wireless device is shutdown during firmware restore mode ??

    so connect by wire, assign static ip

    power OFF the WL-HDD first
    then press and HOLD the button
    then power ON the WL-HDD
    wait until the power led is going to blink
    then release the button
    start firmware restore from your pc (using the firmware restore util, the one from wl500g will do fine. I never used the one from wl-hdd cd)

    woila new firmware

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  8. #8
    Quote Originally Posted by hugo
    As a side note, I can explain here upon request how to setup a root ftp and a telnet deamon on the WL HDD, as the instruction differs from the WL 500G.
    Pls explain Hugo! I compiled vsftpd 2.0.1 and can't get it to run on my WL-HDD. It can't locate user "nobody" and I have no way to add users on my WL-HDD. By Oleg's suggestion I added /etc/passwd and /etc/group but it doesn't make a difference. Seems the WL-HDD runs as UID 0 with no users. Before I start patching vsftpd I wait for your instructions.

  9. #9
    I have the add user problem also with stupid ftp. I would like to add users using the web interface, but It seems to only add up in the samba support.

    I can only help to have access to the whole system, as anonymous. You can for sure extrapolate to create user account as you are probably more experienced than me in this thinks.

    The 2 following posts will explain how to create the root ftp and how to access via telnet, so they can be pruned somewere else if needed

  10. #10

    How to get access to root system via ftp on WL HDD

    You can get access to the hard drive partition in /tmp/harddrive/part1 or partx. For the purpose of this setup, I've created 2 partitions using the web interface. One is the minimum 100 Mb, the other is the remaining space. They will be formated in ext2fs, so it allow us to work seemlesly on this partition and on the system.

    First you have to go to the "secret" admin page:

    http://wl-hdd/Main_AdmStatus_Content.asp

    From there, if you type the ls command then click on refresh, you see that there are a lot of pages available, but they only set up nvram parameters, as they are probably missing the firewall or ppoe files.

    First, copy your stupid ftp conf file from this page:

    Code:
    cp /tmp/stupid-ftpd.conf /tmp/harddisk/part1/stupid-ftpd.conf
    if you are ready to copy it on you first partition (add subfolders if needed)


    Then you need to edit your stupid-ftp.conf using a good editor that keeps the unix formating (like ultraedit, not notepad if you are working under windows)
    As it is on your first hard drive partition, you can fetch the file using ftp or normal network access on the root of your first partition.

    Find the line starting with serverroot=/tmp/harddisk/part1 and replace it by serverroot=/

    save your file, and go back the the "secret admin" page

    type:

    Code:
    cp /tmp/harddisk/part1/stupid-ftpd.conf /tmp/stupid-ftpd.conf
    and hit refresh

    now you have to kill the old ftp deamon. Probably that a killall would have a lot more options, but my simple method (i'm rusty on linux) is to use ps -aux in the admin page, find the stupid ftp line, get the PID (the first number in the row) then type kill -9 xx where xx is the number

    EDIT: a
    Code:
    killall stupid-ftpd
    do the whole trick


    all this must be typed then followed by the refresh button, not enter.

    to finish, type
    Code:
    /bin/stupid-ftpd /tmp/stupid-ftpd.conf
    and hit refresh.

    Et voila, you have an access to the whole system if you ftp your wl-hdd

    As a side note, it seems the process wont use a conf file located anywere else than on the tmp folder.

    Feel free to correct me, as I said I'm rusty on Linux, but I'll go back on track very quickly
    Last edited by hugo; 15-10-2004 at 15:08.

  11. #11

    To get access using telnet to your WL HDD

    To get access using telnet to your Wl HDD, you first have to get the telnetd file here:

    http://files.wl500g.info/asus/wl500g/telnetd/telnetd


    Be sure to get a 324 k file, not a 20 k file. Be sure to use left click, and to let it save on the HD

    Copy this file on your first WL HDD partition. It probably have to be formated with ext2fs, so you might have to create a smaller partition to store your system files

    Use normal ftp or samba access to save this file

    Using the web admin interface:
    http://wl-hdd/Main_AdmStatus_Content.asp

    type
    chmod a+x /tmp/harddisk/part1/telnetd

    if you have located the telnetd file on the first partitioon of your wl-hdd

    and hit refresh button
    then just type /tmp/harddisk/part1/telnetd -d -l /bin/sh &
    and hit refresh

    You can use telnet wl-hdd and start exploring your device.

    EDIT: You don't have to format ext2fs, you can also copy the telnetd file to your tmp directory and chmod it from there

    EDIT2: you can click here if you have chmoded the telnetd in the first partition of your hd:

    http://wl-hdd/apply.cgi?current_page...tion=+Refresh+
    Last edited by hugo; 15-10-2004 at 20:21.

  12. #12
    Join Date
    Sep 2004
    Posts
    123
    hi,
    @hugo
    thanks a lot for the handy instructions to start telnet and get root access with stupid ftp.

    cu,
    peter

  13. #13
    Quote Originally Posted by Antiloop
    start firmware restore from your pc (using the firmware restore util, the one from wl500g will do fine. I never used the one from wl-hdd cd)
    It won't go. The led is flashing, but the firmware utility start connecting
    (upload system recovery file)
    then stop after a few second without any progress bar, saying
    "Upload fail, please check the connection" device is pingable, wl-hdd is 192.168.2.1, pc is 192.168.2.2 on class C subnet with direct cable connection

    BTW, led won't flash until something is plugged in lan port

    Quote Originally Posted by Antiloop
    yes you can not mount the internal hdd because there are NO drivers supplied for the Promise controller inside the WL-HDD in the wl500g firmware
    Is it just a matter of coping the .o files in the /lib/modules/2.4.20/kernel/drivers/ide subfolder before making the firmware? or does it need more work?

  14. #14
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,403
    Quote Originally Posted by hugo
    It won't go. The led is flashing, but the firmware utility start connecting
    (upload system recovery file)
    then stop after a few second without any progress bar, saying
    "Upload fail, please check the connection" device is pingable, wl-hdd is 192.168.2.1, pc is 192.168.2.2 on class C subnet with direct cable connection

    BTW, led won't flash until something is plugged in lan port



    Is it just a matter of coping the .o files in the /lib/modules/2.4.20/kernel/drivers/ide subfolder before making the firmware? or does it need more work?
    is the IP static ? if not than that is causing the problem, I have the same issue when my ip is set to auto

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  15. #15
    all is static, in same subnet, factory reseted

    I can upgrade the firmware using the web page, but it won't accept oleg's one of course, only asus ones

Page 1 of 2 12 LastLast

Similar Threads

  1. oleg's firmware vs openwrt
    By sophana in forum WL-500g Custom Development
    Replies: 5
    Last Post: 15-07-2005, 17:46
  2. Hoe is filestructuur van OLEG's firmware?
    By newbie in forum Dutch Discussion - Nederlands
    Replies: 4
    Last Post: 24-06-2005, 14:23
  3. Problem flashing with custom Firmware
    By eggy in forum WL-HDD Q&A
    Replies: 2
    Last Post: 11-04-2005, 11:09
  4. HELP! Killed wl-500g by flashing old firmware
    By nicd in forum WL-500g Q&A
    Replies: 2
    Last Post: 14-03-2005, 15:57
  5. FTP Connect with Oleg's Firmware?
    By stefan9113 in forum WL-HDD Custom Development
    Replies: 4
    Last Post: 27-02-2005, 00:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •